audio / video artefacts

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
petesky
Posts: 26
Joined: Fri Nov 08, 2013 9:40 pm

audio / video artefacts

Post by petesky »

Besides lockup of APP 20200520 / 20200509 UI i also had a lot of artefacts on some channels (using WLAN). Is there a way to change buffering ? https://imgur.com/NSvh90l

NedS
Silicondust
Posts: 1244
Joined: Mon Dec 10, 2018 12:38 pm

Re: audio / video artefacts

Post by NedS »

That's either a reception issue or the wifi bandwidth isn't able to support the broadcast video. What make and model of router do you have?

petesky
Posts: 26
Joined: Fri Nov 08, 2013 9:40 pm

Re: audio / video artefacts

Post by petesky »

WIFI is 5Ghz (runs well ... have 120Mbit down / 30 Up) ... HDHR3-4DC-HDH/S with latest FW. "Router" is UPC Connect Box.
Other channels are perfectly served. I also noticed that VLC has no artefact issues (or they a maybe minimized or dropped by software) and i can assign more stream buffer ?!

GetMatt
Posts: 1904
Joined: Wed Jan 21, 2009 3:45 pm
Device ID: 1310683C, 13196816, 10733FC0

Re: audio / video artefacts

Post by GetMatt »

petesky wrote:
Tue May 26, 2020 5:29 am
WIFI is 5Ghz (runs well ... have 120Mbit down / 30 Up) ... HDHR3-4DC-HDH/S with latest FW. "Router" is UPC Connect Box.
Other channels are perfectly served. I also noticed that VLC has no artefact issues (or they a maybe minimized or dropped by software) and i can assign more stream buffer ?!
120/30 is your internet connection not your wifi throughput. Is that a test you are running on the same device as the app or on a separate device? Is the UPC Connect Box provided by your ISP? What device are you using the HDHR app on?

petesky
Posts: 26
Joined: Fri Nov 08, 2013 9:40 pm

Re: audio / video artefacts

Post by petesky »

I'm on 5Ghz Band which allows "good" throughput (much better than 2.4) either on local lan as well as on "internet" .. I also know that WIFI normally has speed issues due to encryption (proctocol overhead etc) but theoretically 15 MB/sec should be more than enough for HD stream. And yes i know that WIFI changes channel from time to time etc .. so maybe i get missing frames in case, but i dont really think its a bottleneck here. I use app on a new NB (Win64/16GB/i5) - so no old hardware. The only device which has in fact the most less issues is an old PS3 where "OS" seems to have also buffering @ DLNA streams. The "Connect Box" https://www.onlinekosten.de/testbericht ... t-box.html is provided by ISP and i also now that there are better routers outside ... but it works well so far.

NedS
Silicondust
Posts: 1244
Joined: Mon Dec 10, 2018 12:38 pm

Re: audio / video artefacts

Post by NedS »

We would like to get some diagnostic data:
  1. Please go to the http://my.hdhomerun.com/ site
  2. Click your HDHomeRun's device ID
  3. If it tells you that a firmware update is available, please install it
  4. Click System Status
  5. Check the Send diagnostic information box
  6. Go back one page
  7. Click Channel Lineup
  8. Click on Detect Channels
  9. After the scan finishes, open the HDHomeRun app
  10. Go into the app settings: the gear icon in the top right corner of the "Live/Recorded/Discover/Tasks" page
  11. Enable the option to Send diagnostic information
  12. Watch a problem channel for a few minutes
Reply back and provide us the device ID of your HDHomeRun and we will check the logs. You can find the device ID at the top of the my.hdhomerun.com web page as well as on a label on the bottom of the HDHomeRun itself.

petesky
Posts: 26
Joined: Fri Nov 08, 2013 9:40 pm

Re: audio / video artefacts

Post by petesky »

Allright - done . No error today on this channel but app is 526c right now ... maybe a small bugfix :D
Model: HDHR3-4DC
Device: 14102A7A

NedS
Silicondust
Posts: 1244
Joined: Mon Dec 10, 2018 12:38 pm

Re: audio / video artefacts

Post by NedS »

The diagnostic logging will stay on for ten days before turning back off, to default, so let us know if and when it happens again and we can check the logs.

petesky
Posts: 26
Joined: Fri Nov 08, 2013 9:40 pm

Re: audio / video artefacts

Post by petesky »

Had this issue today 05. Jun 20 around 19:10 (AUSTRIA) on ATV HD.

petesky
Posts: 26
Joined: Fri Nov 08, 2013 9:40 pm

Re: audio / video artefacts

Post by petesky »

20200608-15:57:16 HTTP: rejecting request from 192.168.0.178 - no video data

petesky
Posts: 26
Joined: Fri Nov 08, 2013 9:40 pm

Re: audio / video artefacts

Post by petesky »

After a rescan only the one channel has scrambled video. https://imgur.com/UnRo6Ap

NedS
Silicondust
Posts: 1244
Joined: Mon Dec 10, 2018 12:38 pm

Re: audio / video artefacts

Post by NedS »

The debugging looks like it was manually turned off on May 31st, so unfortunately no data was recorded from the HDHomeRun itself.

petesky
Posts: 26
Joined: Fri Nov 08, 2013 9:40 pm

Re: audio / video artefacts

Post by petesky »

Now i get "unable to play channel - no video data" --- this only happens on one channel (ATV Austria)

Post Reply