Servio Recording Quality Poor

Reception, channel detection, network issues, CableCARD setup, etc.
Post Reply
Andy
Posts: 25
Joined: Tue Aug 12, 2014 6:54 pm

Servio Recording Quality Poor

Post by Andy » Mon Mar 23, 2020 4:42 pm

I have been using a Servio in my installation since early January 2020 and have had ongoing issues with recording quality. I have two HDHR Primes for tuners, but seldom have more than three tuners active at a time. My recordings are often unwatchable because the pictures breaks up severely (loss of key frames I'm guessing). Live feeds sometimes exhibit the same issue which is understandable because they are being run through the servio as well. This is perhaps caused by too high of a data rate being required of the servio. But I was expecting servio to handle two recordings and a playback or live feed at the same time.

What are the limits on concurrent recordings and playbacks for the Servio. Is there any advice to make my recordings watchable. I did not have these problems when I was using WMC, but I decided to leave WMC as it is a fading platform.

nickk
Silicondust
Posts: 15758
Joined: Tue Jan 13, 2004 9:39 am

Re: Servio Recording Quality Poor

Post by nickk » Mon Mar 23, 2020 5:18 pm

Hi,

The SERVIO will happily keep up with all streams from PRIME.

Happy to help figure out what the problem is... go to http://my.hdhomerun.com/ and for each device (PRIME and SERVIO) please enable "Send diagnostic information" in the System Menu.

Then post back with the Device ID of your PRIME and SERVIO.

Nick

Andy
Posts: 25
Joined: Tue Aug 12, 2014 6:54 pm

Re: Servio Recording Quality Poor

Post by Andy » Mon Mar 23, 2020 7:14 pm

Nick,

I have turned on diagnostics. The device IDs are:

HDHR Prime 1: 13137AC5
HDHR Prime 2: 1314A4FB
HDHR Servio: 15302686

The problem has consistently been appearing at about 6:45 - 7:00 pm when we are recording both PBS News hour and NBC Nightly News. Let me know if you want me to send some samples.

NedS
Silicondust
Posts: 835
Joined: Mon Dec 10, 2018 12:38 pm

Re: Servio Recording Quality Poor

Post by NedS » Mon Mar 23, 2020 10:05 pm

Can we also get you to do a channel scan on the PRIMEs as well?
  1. Go to the http://my.hdhomerun.com/ site
  2. Click your HDHomeRun's device ID
  3. Click Channel Lineup
  4. Click Detect Channels
Then reply back

nickk
Silicondust
Posts: 15758
Joined: Tue Jan 13, 2004 9:39 am

Re: Servio Recording Quality Poor

Post by nickk » Mon Mar 23, 2020 11:20 pm

The PRIME and the SERVIO seem quite happy since the logs were enabled. Looks like you watched a recording so it could have been an issue with the recording or a client side issue.

Can you please enable "send diagnostic information" in the HDHomeRun app (gear icon on the top level recorded page), then try viewing live tv.

Nick

Andy
Posts: 25
Joined: Tue Aug 12, 2014 6:54 pm

Re: Servio Recording Quality Poor

Post by Andy » Tue Mar 24, 2020 7:25 am

I did a re-scan of channels in February because the two primes were showing a significant difference in the number of channels detected. The difference was still there after that scan. I started a new one now, but as you know, channel scans take a LONG time.

What would cause a difference in the number of channels detected?

Andy
Posts: 25
Joined: Tue Aug 12, 2014 6:54 pm

Re: Servio Recording Quality Poor

Post by Andy » Tue Mar 24, 2020 7:34 am

I will enable "send diagnostic information" in the HDHomeRun app and watch a Live feed this evening when we normally experience the problem. For sure there is an "issue with the recording" as the poor playback will always show in the same scene if the recording is rewound and played again. The question is why is the recording bad. The Servio and Primes are wired directly to a Mikrotik switch with a Gigabit interface, and the signal quality from the cable is high.

nickk
Silicondust
Posts: 15758
Joined: Tue Jan 13, 2004 9:39 am

Re: Servio Recording Quality Poor

Post by nickk » Tue Mar 24, 2020 7:50 am

We are not getting diagnostics from the HDHomeRun app... can you please double check

Nick

Andy
Posts: 25
Joined: Tue Aug 12, 2014 6:54 pm

Re: Servio Recording Quality Poor

Post by Andy » Tue Mar 24, 2020 9:32 am

I rescanned my channels on both of my HDHR Primes. The number of detected channels remain the same with one of the Primes showing 303 in the other showing 404.

Andy
Posts: 25
Joined: Tue Aug 12, 2014 6:54 pm

Re: Servio Recording Quality Poor

Post by Andy » Tue Mar 24, 2020 9:58 am

Nick,

I will turn on the HDHR app diagnostics now for you. I have indicated I was going to wait until this evening when I normally experience the problem. If you were checking the diagnostics, it would be best to check around 6:50 PM Eastern standard time in the USA.

Andy
Posts: 25
Joined: Tue Aug 12, 2014 6:54 pm

Re: Servio Recording Quality Poor

Post by Andy » Tue Mar 24, 2020 3:58 pm

It is 6:56 PM and I am seeing some video quality problems. Does the diagnostic information show you anything?

NedS
Silicondust
Posts: 835
Joined: Mon Dec 10, 2018 12:38 pm

Re: Servio Recording Quality Poor

Post by NedS » Tue Mar 24, 2020 6:43 pm

Andy wrote:
Tue Mar 24, 2020 3:58 pm
It is 6:56 PM and I am seeing some video quality problems. Does the diagnostic information show you anything?
Did you turn diagnostics off or use another client? We're not seeing app diagnostics from that time.

Andy
Posts: 25
Joined: Tue Aug 12, 2014 6:54 pm

Re: Servio Recording Quality Poor

Post by Andy » Wed Mar 25, 2020 2:04 pm

Yes, I left diagnostics on (see image). I was not able to keep a live stream playing beyond 6:59 pm as I had to join a zoom call and the audio was conflicting. I am adding a link to a clip of the recording so you can view the issue. Sorry, but the audio did not come through on the clip, but you can see the issue.

Image

The clip is here:http://router.andydupont.com:7079/Libra ... BCClip.m4v

Post Reply