20190814 when I start a recording it skips through it and won't stop (!!)

Discussion of the new user interface for the HDHomeRun app.
Post Reply
averyfreeman
Posts: 217
Joined: Sun Apr 09, 2017 11:12 am
Device ID: 1326E235 1313788A
Location: Olympia, WA
Contact:

20190814 when I start a recording it skips through it and won't stop (!!)

Post by averyfreeman » Fri Aug 16, 2019 12:07 am

So this just started happening

env:
W10 1809
build 20190814
logging on
early access to new features on

Opening a recording makes it skip through either backwards or forwards until it gets to the beginning or end and keeps skipping creating a "Max Headroom" sort of experience

Tried on a few recordings - same thing
Tried closing and re-opening the program - same thing
I thought it might have been the remote so I took out the batteries and navigated with the mouse, but it was not the remote

Turned off early access, closed and reopened, same effect

Rebooted the machine -- OK it appears to be playing normally again

That was really bad though, worst bug I've seen so far.

Now it says it's on package 0806 after turning off early access and rebooting. Going to leave it here for a bit but logging will be on.

averyfreeman
Posts: 217
Joined: Sun Apr 09, 2017 11:12 am
Device ID: 1326E235 1313788A
Location: Olympia, WA
Contact:

Re: 20190814 when I start a recording it skips through it and won't stop (!!)

Post by averyfreeman » Fri Aug 16, 2019 5:46 pm

Can anyone from SD tell from the logs if this issue was related to my controller or to the UI? I think my controller actually did die last night, I couldn't get it working after reboot and had to switch to an old one (gotta love $10 throwaway controllers from Amazon)

Thanks

jasonl
Silicondust
Posts: 14067
Joined: Sun Oct 28, 2007 9:23 pm

Re: 20190814 when I start a recording it skips through it and won't stop (!!)

Post by jasonl » Sun Aug 18, 2019 4:30 pm

There were a bunch of seeks being sent.

NedS
Silicondust
Posts: 381
Joined: Mon Dec 10, 2018 12:38 pm

Re: 20190814 when I start a recording it skips through it and won't stop (!!)

Post by NedS » Mon Aug 19, 2019 12:30 am

Some RF/bluetooth remotes, and even some of the IR with USB IR receivers that appear as "keyboards" to the system, will send two codes, one for "button pressed" and one for "button released". I've seen cheaper ones that have weak signal issues, and it would be common for the receiving unit to think that a button had not been released, causing behavior like you've described.

averyfreeman
Posts: 217
Joined: Sun Apr 09, 2017 11:12 am
Device ID: 1326E235 1313788A
Location: Olympia, WA
Contact:

Re: 20190814 when I start a recording it skips through it and won't stop (!!)

Post by averyfreeman » Wed Aug 21, 2019 12:07 pm

NedS wrote:
Mon Aug 19, 2019 12:30 am
Some RF/bluetooth remotes, and even some of the IR with USB IR receivers that appear as "keyboards" to the system, will send two codes, one for "button pressed" and one for "button released". I've seen cheaper ones that have weak signal issues, and it would be common for the receiving unit to think that a button had not been released, causing behavior like you've described.
After reboot my remote no longer worked and I swapped out for another one, it seems like the seeks were a last gasp before it finally kicked the bucket

So must not be the UI after all. Thanks for looking into it for me :)

Post Reply