UI ver. 0814 (early access) crashing

Discussion of the new user interface for the HDHomeRun app.
leerandall
Posts: 552
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

UI ver. 0814 (early access) crashing

Post by leerandall » Thu Aug 15, 2019 1:53 pm

I'm assuming this is being caused by the new UI early release version, but on my Shield, when I start the HDHR app, it plays live TV on the channel that was playing when I exited the app last time. But any button press on the remote throws the dreaded "TypeError: Cannot read property 'id' of null" as well as a list in the form of

in t
in div
in t
in n
...
etc.

ETA: Not all buttons cause the above. I can press the back or home button, each of which takes me out of the app and back to the Shield's home screen. But the navigation keys, up, down, left, right, and OK, all throw the error. So I cannot change channels, nor can I get to the gear icon to turn off early access. I'm now stuck watching MSNBC until this issue is resolved.

ETA 2: I just checked my Win10 laptop and the same issue exists there as well. Can't do anything with it. Clicking the mouse cursor throws the error as do the arrow keys on the keyboard.
Last edited by leerandall on Thu Aug 15, 2019 3:26 pm, edited 2 times in total.

signcarver
Expert
Posts: 8253
Joined: Wed Jan 24, 2007 1:04 am
Device ID: 131B34B7 13231F92 1070A18E 1073ED6F

Re: UI ver. 0814 (early access) crashing

Post by signcarver » Thu Aug 15, 2019 3:20 pm

Not getting those errors here with android tv or win10... but seeing some issues that may be similar.

First off when one uses up/down to change channels (move through slice) when first loaded, it appears to have an issue that the current program title is "loading" but since the slice isn't at the current channel the up and down fail. I have been able to fix by hitting enter (select) and going over to the slice and selecting a channel... now that the channel is known slice works rather normally and quickly (great improvement). However when I hung out in discover for awhile and returned to live, it returned to display starting at the first channel and would no longer allow me to navigate up/down slice even when using the trick. Also if moving very quickly down, on occasion the focus would move to record or search and once there, it would not let one back to navigate slice.

Wanted to check out the red dot feature (will look closer to other possible issues later but for now limiting my scheduling within app) I selected a series from discover and then proceeded to select 3 episodes to record. In the main tile on discover there is a red dot (improvement as last time one-offs were not listed), however only the first episode scheduled to record would have a red dot though all are listed in tasks. Another issue came up in navigating to selected episode in slice. It puts a tile up without a dot for the first instance to be record then repeats the tile as many times as episodes selected could be coincidence but it had 3 copies and I selected 3 episodes (without a dot on first one putting dots on the other ones) but then also puts a red dot on the next item across the slice that isn't to be recorded.

Personally I still have an issue with episodes not showing up with all channels when the same episode is on at the same time as I would prefer such choice for one-offs.

nateb
Silicondust
Posts: 950
Joined: Mon Aug 06, 2018 3:22 pm
Device ID: 1051C73D, 10759F29

Re: UI ver. 0814 (early access) crashing

Post by nateb » Thu Aug 15, 2019 3:54 pm

Signcarver pointed to what we think the issue is. With lazy loading, you literally just don't load elements of the UI that are off the screen which speeds up loading, and if the app tries to start loading a channel that's off the default starting list, it may be causing problems. We also are not able to replicated the int thing, but can replicate the loading thing. Hopefully a fix for one will be a fix for both.

Devs are on it!

leerandall
Posts: 552
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

Re: UI ver. 0814 (early access) crashing

Post by leerandall » Thu Aug 15, 2019 4:21 pm

I hope mine is just another manifestation of the same cause. HDHR on my Shield is useless to me until a fix comes. I can't change channels, and I'm tired of watching news today.

kkid
Posts: 60
Joined: Mon Apr 06, 2009 7:24 am

Re: UI ver. 0814 (early access) crashing

Post by kkid » Thu Aug 15, 2019 4:35 pm

Same thing here also, using win10 Version 1903 ( OS Build 18362.295). I can't get to the gear to find out the version of the UI. Can't change channels, etc. This just started when I went to watch the football game. It was fine an hour ago.

EddieP
Posts: 79
Joined: Sat Jun 08, 2019 11:04 am

Re: UI ver. 0814 (early access) crashing

Post by EddieP » Thu Aug 15, 2019 4:40 pm

Same here new UI is useless stuck on 1 channel. Is this UI being tested before being updated ?
Last edited by EddieP on Thu Aug 15, 2019 4:40 pm, edited 1 time in total.

jasonl
Silicondust
Posts: 14067
Joined: Sun Oct 28, 2007 9:23 pm

Re: UI ver. 0814 (early access) crashing

Post by jasonl » Thu Aug 15, 2019 4:40 pm

You should still be able to switch back to non-early access using the hamburger stack menu (Win10) or play/pause 13x on the remote (Shield).

EddieP
Posts: 79
Joined: Sat Jun 08, 2019 11:04 am

Re: UI ver. 0814 (early access) crashing

Post by EddieP » Thu Aug 15, 2019 4:42 pm

jasonl wrote:
Thu Aug 15, 2019 4:40 pm
You should still be able to switch back to non-early access using the hamburger stack menu (Win10) or play/pause 13x on the remote (Shield).
Get unable to play channels on the Shield without early access... and still cannot change channels.

jasonl
Silicondust
Posts: 14067
Joined: Sun Oct 28, 2007 9:23 pm

Re: UI ver. 0814 (early access) crashing

Post by jasonl » Thu Aug 15, 2019 4:44 pm

Are other devices able to watch TV?

EddieP
Posts: 79
Joined: Sat Jun 08, 2019 11:04 am

Re: UI ver. 0814 (early access) crashing

Post by EddieP » Thu Aug 15, 2019 4:46 pm

jasonl wrote:
Thu Aug 15, 2019 4:44 pm
Are other devices able to watch TV?
Not Working on my FireTV 4K also stuck on 1 channel.

kkid
Posts: 60
Joined: Mon Apr 06, 2009 7:24 am

Re: UI ver. 0814 (early access) crashing

Post by kkid » Thu Aug 15, 2019 4:47 pm

jasonl wrote:
Thu Aug 15, 2019 4:40 pm
You should still be able to switch back to non-early access using the hamburger stack menu (Win10) or play/pause 13x on the remote (Shield).
Yes the "hamburger" allows non-early access, but then we'll be stuck with the non-working build, right?

Ah, now I see where this new problem came from:

"New support for "lazy loading" which should dramatically speed up UI for people with cable and a Prime (this was a big one)."

That's me, Comcast cable and a Prime and the UI has about 5-8 seconds of "lag time"/ (lazy loading).

jasonl
Silicondust
Posts: 14067
Joined: Sun Oct 28, 2007 9:23 pm

Re: UI ver. 0814 (early access) crashing

Post by jasonl » Thu Aug 15, 2019 5:12 pm

Prior to this afternoon, both early access and regular were 0806. This afternoon, 0814 was pushed to early access, but regular is still at 0806. If you turn off early access, you'll be back to 0806, and things will be the same as they were for the last week. Once the issues in 0814 are resolved, that will be pushed to early access as a new version. Regular will remain on 0806 until we are happy with the new changes.

EddieP
Posts: 79
Joined: Sat Jun 08, 2019 11:04 am

Re: UI ver. 0814 (early access) crashing

Post by EddieP » Thu Aug 15, 2019 5:27 pm

jasonl wrote:
Thu Aug 15, 2019 5:12 pm
Prior to this afternoon, both early access and regular were 0806. This afternoon, 0814 was pushed to early access, but regular is still at 0806. If you turn off early access, you'll be back to 0806, and things will be the same as they were for the last week. Once the issues in 0814 are resolved, that will be pushed to early access as a new version. Regular will remain on 0806 until we are happy with the new changes.
Just an FYI I had to clear the data on the Shield before it worked on 0806.

kkid
Posts: 60
Joined: Mon Apr 06, 2009 7:24 am

Re: UI ver. 0814 (early access) crashing

Post by kkid » Thu Aug 15, 2019 6:56 pm

jasonl wrote:
Thu Aug 15, 2019 5:12 pm
Prior to this afternoon, both early access and regular were 0806. This afternoon, 0814 was pushed to early access, but regular is still at 0806. If you turn off early access, you'll be back to 0806, and things will be the same as they were for the last week. Once the issues in 0814 are resolved, that will be pushed to early access as a new version. Regular will remain on 0806 until we are happy with the new changes.
Ok, thanks, at least that procedure works for win 10 with cable and Prime, to go back to 0806. I guess a lag is better than a black screen with gibberish.

leerandall
Posts: 552
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

Re: UI ver. 0814 (early access) crashing

Post by leerandall » Thu Aug 15, 2019 7:10 pm

jasonl wrote:
Thu Aug 15, 2019 4:40 pm
You should still be able to switch back to non-early access using the hamburger stack menu (Win10) or play/pause 13x on the remote (Shield).
Can't play/pause 13x on the Shield. The first press of the center (OK/Enter) button of the direction pad throws the error. I cannot get back to the 0806 UI version.

Post Reply