Unable to play recordings

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
jhford
Posts: 42
Joined: Mon May 21, 2018 3:56 pm

Re: Unable to play recordings

Postby jhford » Wed Aug 08, 2018 6:48 pm

Keep in mind, for this issue, I believe it was NYPlayer who told you to post in the "normal" forum rather than the Unofficial Kodi Add-on Forum as what was perceived there was more of a recording issue which that add-on doesn't really control. However what was posted here was more like the unofficial add-on couldn't play it which SD doesn't support and you need to refer back to that thread. Keep in mind that add-on also got a new release or two as others were having trouble with the code that was around when you posted (though I think it was for live OTA that was having issue in some cases).

Here, SD is expected to help you but only with their app which you indicated also does not play such. And if that is the case they need diagnostic information from that app, not the add-on. And from jasonl's response (in knowing the engine is on a NAS) sounded like something wasn't properly communicating either to the app or preventing the app from submitting diagnostic data to SD, thus the question about firewall.

What would be expected in this section of the forum would be that the official app can play the recordings since that date. I would also state that the error message you got sounded like an issue that something blocked the CmdURL from the engine. Hopefully your engine can be seen from my.hdhomerun.com (note don't use edge) and/or you know its port that way you can add /recorded_files.json to the end of the url (i.e 192.168.1.17:1234/recorded_files.json) and see what is being returned by the engine for the CmdURL's of your recent recordings. It also wouldn't surprise me if someone did some post processing to the files that something might have messed up the metadata and potentially cause a similar error.
I'm new to this forum. So, please forgive my lack of understanding of the protocols. And I have installed the 2 most recent Unofficial PVR client updates, but the problem persists.

jhford
Posts: 42
Joined: Mon May 21, 2018 3:56 pm

Re: Unable to play recordings

Postby jhford » Wed Aug 08, 2018 7:07 pm

Keep in mind, for this issue, I believe it was NYPlayer who told you to post in the "normal" forum rather than the Unofficial Kodi Add-on Forum as what was perceived there was more of a recording issue which that add-on doesn't really control. However what was posted here was more like the unofficial add-on couldn't play it which SD doesn't support and you need to refer back to that thread. Keep in mind that add-on also got a new release or two as others were having trouble with the code that was around when you posted (though I think it was for live OTA that was having issue in some cases).

Here, SD is expected to help you but only with their app which you indicated also does not play such. And if that is the case they need diagnostic information from that app, not the add-on. And from jasonl's response (in knowing the engine is on a NAS) sounded like something wasn't properly communicating either to the app or preventing the app from submitting diagnostic data to SD, thus the question about firewall.

What would be expected in this section of the forum would be that the official app can play the recordings since that date. I would also state that the error message you got sounded like an issue that something blocked the CmdURL from the engine. Hopefully your engine can be seen from my.hdhomerun.com (note don't use edge) and/or you know its port that way you can add /recorded_files.json to the end of the url (i.e 192.168.1.17:1234/recorded_files.json) and see what is being returned by the engine for the CmdURL's of your recent recordings. It also wouldn't surprise me if someone did some post processing to the files that something might have messed up the metadata and potentially cause a similar error.
I'm new to this forum. So, please forgive my lack of understanding of the protocols. And I have installed the 2 most recent Unofficial PVR client updates, but the problem persists.
When I browse for <IP address>:50000/recorded_files.json I get a huge file that begins with "[{"Category":" and ends with "http://<IP address>:50000/recorded/cmd?id=643665bd"}]
Does this help you?
Thanks

signcarver
Expert
Posts: 7490
Joined: Wed Jan 24, 2007 1:04 am

Re: Unable to play recordings

Postby signcarver » Wed Aug 08, 2018 8:35 pm

FIrst make sure it works with the official app and until it does, only the official app for your troubleshooting as if the issue is there, that is something for SD to look at and would need to be fixed first before looking at it with the unofficial add-on I would also stick to win10 app to make sure it works as the firestick can be troublesome for some. Once it works with in the official app, and still doesn't work with the unofficial add-on, then it is back to that thread and perhaps djp952 may see something.

Edit: as for the json, does the CmdURL and PlayURL of the show that doesn't play look like it is correct ( compared to others ) and "match" as far as the number goes. Can you play that play link in your browser or VLC?

jhford
Posts: 42
Joined: Mon May 21, 2018 3:56 pm

Re: Unable to play recordings

Postby jhford » Sat Aug 11, 2018 2:14 pm

FIrst make sure it works with the official app and until it does, only the official app for your troubleshooting as if the issue is there, that is something for SD to look at and would need to be fixed first before looking at it with the unofficial add-on I would also stick to win10 app to make sure it works as the firestick can be troublesome for some. Once it works with in the official app, and still doesn't work with the unofficial add-on, then it is back to that thread and perhaps djp952 may see something.

Edit: as for the json, does the CmdURL and PlayURL of the show that doesn't play look like it is correct ( compared to others ) and "match" as far as the number goes. Can you play that play link in your browser or VLC?
@signcarver
Thanks for your input. I just had the opportunity to intuitively learn to use the "Official app." The result is that the files that were recorded prior to that Saturday (I think 2 weeks ago) are behaving on my Windows 10 laptop using the Official app, as they do on the Unofficial Kodi client installed on my Amazon TV Fire Stick, in other words, the recording made before that Saturday play perfectly on both and those recorded thereafter don't play at all on both -- therefore, there is no difference between Fire TV Stick and the Official app on my laptop.

So, that indicates to me that the Official app is working fine.

What should I do now?

Thanks

signcarver
Expert
Posts: 7490
Joined: Wed Jan 24, 2007 1:04 am

Re: Unable to play recordings

Postby signcarver » Sat Aug 11, 2018 2:39 pm

I would copy the PlayURL and see if vlc can play it (open a network stream). To me the error message you got suggests that though the engine presents the recording for playback, it hasn't properly applied the correct "file" to play back with that number (sounded like the number was actually null from what I remember, though did not reread the thread so I felt that perhaps it didn't have a number in the json).

I would also try to use VLC to try and play the new file itself (open the file directly, not through the url) to make sure the file is intact and if that works I would probably restart the NAS (and the engine) wait 10 minutes, retrieve the json and try the process again.

In the meantime continue working with the official app for troubleshooting, make sure it has internet connection and that sending of diagnostics is turned on in the app (I'd also do tuner so they get diagnostics of new recordings) attempt to watch the recorded show and post the time of the issue and the show you tried to stream, continue to try and watch for at least 5 minutes, then watch one that works and report the name of that show and time you watched it and hopefully SD sees something in the app log or record engine log that they have a better idea of the issue. They may need you to post such file somewhere they can download it from such as google drive or dropbox so they can look at the file itself.

jhford
Posts: 42
Joined: Mon May 21, 2018 3:56 pm

Re: Unable to play recordings

Postby jhford » Sun Aug 12, 2018 1:29 pm

I would copy the PlayURL and see if vlc can play it (open a network stream). To me the error message you got suggests that though the engine presents the recording for playback, it hasn't properly applied the correct "file" to play back with that number (sounded like the number was actually null from what I remember, though did not reread the thread so I felt that perhaps it didn't have a number in the json).

I would also try to use VLC to try and play the new file itself (open the file directly, not through the url) to make sure the file is intact and if that works I would probably restart the NAS (and the engine) wait 10 minutes, retrieve the json and try the process again.

In the meantime continue working with the official app for troubleshooting, make sure it has internet connection and that sending of diagnostics is turned on in the app (I'd also do tuner so they get diagnostics of new recordings) attempt to watch the recorded show and post the time of the issue and the show you tried to stream, continue to try and watch for at least 5 minutes, then watch one that works and report the name of that show and time you watched it and hopefully SD sees something in the app log or record engine log that they have a better idea of the issue. They may need you to post such file somewhere they can download it from such as google drive or dropbox so they can look at the file itself.
Questions.
I really don't know how to make VLC play the PlayURL, by which I assume you mean the json file, correct? So, I'd appreciate you helping me with that.
Should I post the PlayUrl to this forum so you or someone else to read?
I don't know what you mean by "keep working with the official app ..." There is nothing I can do; it won't play the recordings if I waited until the Sun burns out. There is nothing to "watch." It simply times out which is exactly the same thing that happens when I try to play them using the unofficial Kodi client on my Fire TV Stick.

Hold on. I just tried something. I installed VLC on my Windows 10 laptop and loaded File Explorer. "This PC" shows a folder called WDMyCloud (the NAS), which contains all the recorded videos. Prior to that fateful Saturday, I recorded the film "All the President's Men." I right clicked on and chose Play with VLC Media player and it played although it took about 30 minutes to load in VLC.

Then I found a TV Show that was recorded today and did the same thing. This time a black page loaded with the VLC orange and white cone icon in the middle. Not did the video not play, but I couldn't make it play with non-functioning right arrow button.

I hope this helps.

Thanks

jhford
Posts: 42
Joined: Mon May 21, 2018 3:56 pm

Re: Unable to play recordings

Postby jhford » Sun Aug 12, 2018 3:24 pm

I would copy the PlayURL and see if vlc can play it (open a network stream). To me the error message you got suggests that though the engine presents the recording for playback, it hasn't properly applied the correct "file" to play back with that number (sounded like the number was actually null from what I remember, though did not reread the thread so I felt that perhaps it didn't have a number in the json).

I would also try to use VLC to try and play the new file itself (open the file directly, not through the url) to make sure the file is intact and if that works I would probably restart the NAS (and the engine) wait 10 minutes, retrieve the json and try the process again.

In the meantime continue working with the official app for troubleshooting, make sure it has internet connection and that sending of diagnostics is turned on in the app (I'd also do tuner so they get diagnostics of new recordings) attempt to watch the recorded show and post the time of the issue and the show you tried to stream, continue to try and watch for at least 5 minutes, then watch one that works and report the name of that show and time you watched it and hopefully SD sees something in the app log or record engine log that they have a better idea of the issue. They may need you to post such file somewhere they can download it from such as google drive or dropbox so they can look at the file itself.
Questions.
I really don't know how to make VLC play the PlayURL, by which I assume you mean the json file, correct? So, I'd appreciate you helping me with that.
Should I post the PlayUrl to this forum so you or someone else to read?
I don't know what you mean by "keep working with the official app ..." There is nothing I can do; it won't play the recordings if I waited until the Sun burns out. There is nothing to "watch." It simply times out which is exactly the same thing that happens when I try to play them using the unofficial Kodi client on my Fire TV Stick.

Hold on. I just tried something. I installed VLC on my Windows 10 laptop and loaded File Explorer. "This PC" shows a folder called WDMyCloud (the NAS), which contains all the recorded videos. Prior to that fateful Saturday, I recorded the film "All the President's Men." I right clicked on and chose Play with VLC Media player and it played although it took about 30 minutes to load in VLC.

Then I found a TV Show that was recorded today and did the same thing. This time a black page loaded with the VLC orange and white cone icon in the middle. Not did the video not play, but I couldn't make it play with non-functioning right arrow button.

I also saved a copy of recorded_files.json to my Google Drive for you to check. The file I tested today that failed to play is "Reliable Sources."
https://drive.google.com/open?id=1IGWP5 ... XdYtjnWSDk

I hope this helps.

Thanks

signcarver
Expert
Posts: 7490
Joined: Wed Jan 24, 2007 1:04 am

Re: Unable to play recordings

Postby signcarver » Sun Aug 12, 2018 3:44 pm

As far as the recording goes, the json only does someone on your network any good.

What I was asking you to do was use the PlayURL and attempt to play in VLC and then attempt to play the same file in VLC directly. It sounds like you did the second (by browsing to the file) which if it can't play it directly, streaming it would not help (but in the data you provided, you would use

Code: Select all

http://192.168.29.82:50000/recorded/play?id=5033d780
At this time I suggest running a channel scan and making sure the channels you are recording from are not DRM (though I thought you stated live worked in kodi which would not support DRM) I'd also check the logs of both the tuner and the recording engine for the time in question (times are UTC).

jasonl
Silicondust
Posts: 12765
Joined: Sun Oct 28, 2007 9:23 pm

Re: Unable to play recordings

Postby jasonl » Sun Aug 12, 2018 6:58 pm

Are you using an HDHomeRun PRIME? If so, if you run a channel scan on the device's web page, do the channels you're recording come up with a [DRM] indicator next to them?

jhford
Posts: 42
Joined: Mon May 21, 2018 3:56 pm

Re: Unable to play recordings

Postby jhford » Tue Aug 14, 2018 12:20 pm

Are you using an HDHomeRun PRIME? If so, if you run a channel scan on the device's web page, do the channels you're recording come up with a [DRM] indicator next to them?
And this is going to sound stupid, but where is the PlayURL?

signcarver
Expert
Posts: 7490
Joined: Wed Jan 24, 2007 1:04 am

Re: Unable to play recordings

Postby signcarver » Tue Aug 14, 2018 12:50 pm

First run the channel scan to make sure this is not a drm issue.

The recorded_files.json is what gets retrieved to get the list of items recorded. For each item there are several deatails such channel, time, synopsis, image, as well as a CmdURL and a PlayURL.but since you said you couldn't play the file directly with vlc directly, attempting to use the PlayURL would be moot but based on the error you mentioned when attempting to play, I felt that perhaps there was an issue with the engine and that particular file.

In other words since the file itself doesn't play in vlc, forget i mentioned it.

jhford
Posts: 42
Joined: Mon May 21, 2018 3:56 pm

Re: Unable to play recordings

Postby jhford » Tue Aug 14, 2018 5:30 pm

First run the channel scan to make sure this is not a drm issue.

The recorded_files.json is what gets retrieved to get the list of items recorded. For each item there are several deatails such channel, time, synopsis, image, as well as a CmdURL and a PlayURL.but since you said you couldn't play the file directly with vlc directly, attempting to use the PlayURL would be moot but based on the error you mentioned when attempting to play, I felt that perhaps there was an issue with the engine and that particular file.

In other words since the file itself doesn't play in vlc, forget i mentioned it.
I tried something and I hope I did it correctly. I copied what appeared to me to be a PlayURL string from recored_files.json for a non-playable recording: http://<IP address>:50000/recorded/play?id=96869cb6. I opened VLC and selected Media > Open network stream, pasted the link, and let it rip. The VLC progress bar raced back and forth, whatever that signifies, until it pooped out and the recording failed to play in VLC, also. Does that help????
Thanks

signcarver
Expert
Posts: 7490
Joined: Wed Jan 24, 2007 1:04 am

Re: Unable to play recordings

Postby signcarver » Tue Aug 14, 2018 6:14 pm

That is correct but since you said it didn't play it just opening the file something like that was to be expected as the file itself is garbage as far as vlc is concerned and usually vlc will play anything thrown at it (except if the file is corrupt or encrypted) as it supplies its own codecs. Did you run the channel scan? Does the channel in question (after you run the scan) say it is DRM? (Sometimes cable channels don't auto update such status and you must run a scan but even then it could have such protection part time, though that would be strange). One more test you might do is move the file locally to the pc and try to play the file again but I doubt that would work.


What provider (and if spectrum what was it before?)?

jhford
Posts: 42
Joined: Mon May 21, 2018 3:56 pm

Re: Unable to play recordings

Postby jhford » Thu Aug 16, 2018 2:50 pm

That is correct but since you said it didn't play it just opening the file something like that was to be expected as the file itself is garbage as far as vlc is concerned and usually vlc will play anything thrown at it (except if the file is corrupt or encrypted) as it supplies its own codecs. Did you run the channel scan? Does the channel in question (after you run the scan) say it is DRM? (Sometimes cable channels don't auto update such status and you must run a scan but even then it could have such protection part time, though that would be strange). One more test you might do is move the file locally to the pc and try to play the file again but I doubt that would work.


What provider (and if spectrum what was it before?)?
i tried something. I went to myhdhomerun.com and opened the scan utility, which I haven't done in weeks. It showed 15 channels, but I have hundreds, some of which I had marked with X's and some as Favorites. None of those appeared on the scan list. So, I started a new scan. It took forever, but never completed stopping 79% with the same 15 channels.

Why do you think this happened, is this the reason the recordings won't play, and what should I do to fix it, i.e., is this a provider (Charter/Spectrum) issue? It's their cable card. Should I call Charter/Spectrum for service?

Thank you

jasonl
Silicondust
Posts: 12765
Joined: Sun Oct 28, 2007 9:23 pm

Re: Unable to play recordings

Postby jasonl » Thu Aug 16, 2018 3:05 pm

Please enable the sending of diagnostic data on Windows or Mac and run a channel scan (see viewtopic.php?f=15&t=69066) then reply back with the device ID for your HDHomeRun and we will check the logs and see what is happening.


Return to “HDHomeRun Software Setup & Troubleshooting (Live & DVR)”

Who is online

Users browsing this forum: gtb, jseymour, mercblue281 and 14 guests