Black screen with "Audio only", etc.

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Cabal
Posts: 156
Joined: Mon Jun 09, 2014 1:53 pm
x 55

Re: Black screen with "Audio only", etc.

Post by Cabal »

nickk wrote: Tue Feb 27, 2024 10:17 pm I set up a KM2 PLUS in the test lab - it is playing all our MPEG2 test streams from a Linux server ok.
Do you leave your test devices running 24/7? My experience with the KM2 Plus required daily reboots, or else any MPEG-2 video (HDHomeRun app, Kodi, etc) would all lag and stutter, becoming unusable if you had more than a day or two of uptime. I assumed it was something buggy in either the OS or hardware decoder. Support confirmed it quickly and then fixed nothing.

PTSD
Posts: 61
Joined: Wed Jul 22, 2020 5:24 pm
Device ID: 1078183D

Re: Black screen with "Audio only", etc.

Post by PTSD »

Before beginning this testing of the KM2 Plus using "internal" device storage I connected my Plugable USB-C carrier to my PC and used diskpart to entirely 'clean' the enclosed Samsung 970 EVO Plus NVMe drive. Then I moved it back to the KM2 Plus and powered it on. After booting to the Google TV home screen Android 11 complained about "Unsupported Samsung USB drive" and prompted me to click the notification and "set up in a supported format". I clicked that screen and in the next screen I selected "Setup as device storage". After formatting was complete Android prompted me to "Move data to Samsung USB drive" but I chose "Move later".

At that point the HDHomeRun gear menu was not displaying the option to "Use this device for recording", which is what I expected would happen. I tried powering off the KM2 Plus and then powering it back on and then got a notification that the Samsung USB Drive was basically offline, with a prompt to "replug it in" or "Forget this storage device". So I tried to disconnect & reconnect the drive but then things really got weird as the Storage view in Android settings showed two "Samsung USB drive" entries, one "safely ejected and the other "Not connected". This mis-behavior didn't surprise me as Android on my several phones always seems to eventually get wonky when formatting and/or unmounting/remounting SD cards...

Anyway at that point I went ahead and powered off the KM2 Plus and reconnected the Plugable carrier to my PC have a look at the partitions that Android 11 created on the Samsung EVO drive. diskpart reported a GPT-formatted disk with these two partitions (using the 'detail partition' command on each selected partition):

GUID 19A710A2-B3CA-11E4-B026-10604B889DCF (initial 16 MB at 1024 KB offset)
GUID 193D1EA4-B3CA-11E4-B075-10604B889DCF (remaining 465 GB at 17 MB offset)

The GUID Partition Table article in Wikipedia reports those two partition types as "Android Meta" and "Android EXT" respectively, used by "Android 6.0+ ARM"

(more to follow...)

PTSD
Posts: 61
Joined: Wed Jul 22, 2020 5:24 pm
Device ID: 1078183D

Re: Black screen with "Audio only", etc.

Post by PTSD »

Cabal wrote: Wed Feb 28, 2024 7:23 pm [...] My experience with the KM2 Plus required daily reboots, or else any MPEG-2 video (HDHomeRun app, Kodi, etc) would all lag and stutter, becoming unusable if you had more than a day or two of uptime. I assumed it was something buggy in either the OS or hardware decoder. Support confirmed it quickly and then fixed nothing.
Even our KM9 Pro needed remedial reboots more than I liked. I was able to configure Android 9 there to Restart the thing without prompts (on pressing the power button), and we did plenty of that.

This KM2 Plus seems no better in the stability department. Unfortunately the power button can only be configured to Sleep or Shutdown. And too often it was getting Shutdown and then not turned back on again. Another reason to not enable the DVR function there...

Whose "Support confirmed it quickly" that the OS or hardware decoder on the KM2 Plus was to blame, SiliconDust or the ODM Skyworth Digital (or Videostrong Technology)?

Were you ever able to test it with the latest firmware? I have a collection of five different OTA upgrade .zip files, the newest being for version "C3.0.6_20231109" which I believe is still the latest version. (4pda forum has a thread with links to the archives on MEGA.)

PTSD
Posts: 61
Joined: Wed Jul 22, 2020 5:24 pm
Device ID: 1078183D

Re: Black screen with "Audio only", etc.

Post by PTSD »

(Back to testing internal storage...)

After inspecting the partition table that Android 11 created on my Samsung EVO 970 drive I reconnected the Plugable carrier to the KM2 Plus and powered it back on. The HDHomeRun gear menu still did not display the option to "Use this device for making recordings" so in Android Settings > Storage I finally "Moved data to the Samsung USB drive". After that HDHomeRun showed the recording option and it was already turned ON.

At that point I tried making a recording of Live TV but the .mpg file ended up on my Intel NUC instead. So I deleted the recording Task from HDHomeRun on the KM2 Plus, then deleted the recording from HDHomeRun on the Intel NUC. Then I went into HDHomeRUn Setup on the Intel NUC and selected the DVR tab to disable recording. However I found the checkbox for that already unchecked (?), so I checked & unchecked and Applied that setting for good measure.

Back to the KM2 Plus, I started another recording of Live TV then closed the HDHomeRun app. In the meantime I watched the filesystem on the Intel NUC to confirm that no .mpg for the show landed there (there's no easy way to check for recorded files on the Android TV box, and I haven't yet re-enabled Developer options there, nor setup ADB for remote access, etc.). Then I went back to the KM2 Plus and discovered that the recording never materialized. (sigh...)

After repeating that last routine a second time I finally have a Live TV recording on the KM2 Plus, apparently resident on the Samsung USB drive mounted as "internal" device storage. However there is over 10GB of free space on the internal eMMC storage for the KM2 Plus -- is it possible that the .mpg file landed there instead? (Again, no easy way to check for this without ADB.) In any case I can't see the recorded .mpg on the Intel NUC filesystem, so it must reside somewhere on the KM2 Plus...

At this point I've disabled recording on the KM2 Plus and re-enabled recording on the Intel NUC. I will see if I can break the KM2 Plus again on playback of recordings, this time with one on "internal" device storage...

PTSD
Posts: 61
Joined: Wed Jul 22, 2020 5:24 pm
Device ID: 1078183D

Re: Black screen with "Audio only", etc.

Post by PTSD »

After disabling recording on the KM2 Plus I was surprised to see that the one Live TV recording I successfully made there was no longer listed on the Recorded tab? So I had to re-enable recording on that device to make that Live TV recording show up again. (I assumed that "Use this device for making recordings" refers to future recordings only; previous recordings, if available, should be displayed regardless of that setting, no?)

On the very first attempted (local) playback of that Live TV recording I once again got the dreaded black "Audio only" screen. On the second attempted playback I got the same screen but with no audio at all. Third attempt gave the same result, after which I was unable to cleanly exit HDHomeRun and had to Shutdown the device and power back on to regain stability. This behavior was totally repeatable and I think it proves that the type of storage mount or filesystem format has nothing to do with whether or not local recordings can be played back on this KM2 Plus device.

PTSD
Posts: 61
Joined: Wed Jul 22, 2020 5:24 pm
Device ID: 1078183D

Re: Black screen with "Audio only", etc.

Post by PTSD »

I shut down the KM2 Plus again, disconnected the Plugable SSD carrier, powered the device back on, told Android Settings to Forget the Samsung storage, then uninstalled HDHomeRun and reinstalled it (with a few restarts of the device sprinkled in along the way). I want to make absolutely sure that there's no way that any further recordings can be made to this device, which is basically useless for that purpose.

I did connect the Plugable carrier with Samsung SSD to a VirtualBox VM running Debian Bookworm. Debian was able see the "Samsung USB drive" but I was unable to mount either of those Android partitions (the mount error messages mention possibly unrecognized filesystems). So there's no way to prove that the Live TV recording actually landed there (vs. the internal eMMC storage on the KM2 Plus). But at this point I don't care about any further fault isolation. I'm DONE with trying to make local recording work on this KM2 Plus!

I'm actually thankful that this fiasco pushed me to move DVR recording to the Intel NUC. Separating the recording from viewing functions provides a lot of flexibility for regular usage and troubleshooting.

I've beaten this horse to death, have nothing more to say about it, and will call it quits for this thread, except to answer any questions.

Cabal
Posts: 156
Joined: Mon Jun 09, 2014 1:53 pm
x 55

Re: Black screen with "Audio only", etc.

Post by Cabal »

PTSD wrote: Wed Feb 28, 2024 8:37 pm Whose "Support confirmed it quickly" that the OS or hardware decoder on the KM2 Plus was to blame, SiliconDust or the ODM Skyworth Digital (or Videostrong Technology)?

Were you ever able to test it with the latest firmware? I have a collection of five different OTA upgrade .zip files, the newest being for version "C3.0.6_20231109" which I believe is still the latest version. (4pda forum has a thread with links to the archives on MEGA.)
Whoever answers support emails at MeCool confirmed the behavior after I sent them sample video files along with instructions on how to reproduce it. (There was a bit of a language barrier, but we got there.)

I was on the latest firmware available at the time, but it was definitely before 3.0.6. I got rid of the device a number of months ago, I don't remember what was the latest at the time.

nickk
Silicondust
Posts: 20206
Joined: Tue Jan 13, 2004 9:39 am
x 387

Re: Black screen with "Audio only", etc.

Post by nickk »

We just confirmed and fixed an issue where you might get a black screen audio-only message when the broadcaster is sending multiple PMTs on the same PID. The situation is timing sensitive and not seen on all devices.

I don't know if this is the problem you are experiencing but I would recommend installing the apk when it is released later today just in case.

PTSD
Posts: 61
Joined: Wed Jul 22, 2020 5:24 pm
Device ID: 1078183D

Re: Black screen with "Audio only", etc.

Post by PTSD »

Thanks Nick & Co. for your usual stellar support. I will definitely install the update when it comes out in Google Play Store.

Not sure though when I will have time for another round of local recording and playback testing on the KM2 Plus. At this point I'm sold on the idea of keeping recording off "Android TV" boxes and on a dedicated non-Android DVR device.

nickk
Silicondust
Posts: 20206
Joined: Tue Jan 13, 2004 9:39 am
x 387

Re: Black screen with "Audio only", etc.

Post by nickk »


PTSD
Posts: 61
Joined: Wed Jul 22, 2020 5:24 pm
Device ID: 1078183D

Re: Black screen with "Audio only", etc.

Post by PTSD »

Cabal wrote: Thu Feb 29, 2024 8:56 am Whoever answers support emails at MeCool confirmed the behavior after I sent them sample video files along with instructions on how to reproduce it. (There was a bit of a language barrier, but we got there.)

I was on the latest firmware available at the time, but it was definitely before 3.0.6. I got rid of the device a number of months ago, I don't remember what was the latest at the time.
Thanks for clarifying the support path you attempted to take with this thing.
Based on the (translated) revision history I've seen documented at the 4PDA forum thread for the KM2 Plus, I believe that one of the earlier OTA updates included new device drivers for that model. If you weren't testing with at least that update applied then it had to be a terrible experience. :shock:

Post Reply