[UPDATED] Linux DVR stops connecting suddenly during playback

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
averyfreeman
Posts: 252
Joined: Sun Apr 09, 2017 11:12 am
Device ID: 1326E235 1313788A
Location: Olympia, WA
Contact:

[UPDATED] Linux DVR stops connecting suddenly during playback

Post by averyfreeman »

Hi,

My girlfriend was watching TV last night and our DVR service suddenly stopped working. I was watching it this morning and the same thing happened. Without warning, playback just stopped, kicked me out of the recording.

Windows 10 client said "Your DVR is ready to record" (paraphrase)

This combination had been working perfectly fine for the last year after I migrated to Linux from FreeBSD. I haven't done any recent version upgrades, just security updates - it might get updated once a month since I hardly ever have to mess with it.

I haven't changed anything in my network config, either, or the Windows 10 clients we use to view the DVR.

env:

Code: Select all

Linux alpinehdhr 4.19.80-0-vanilla #1-Alpine SMP Fri Oct 18 11:27:53 UTC 2019 x86_64 GNU/Linux 
/etc/alpine-release 3.11.6
hdhomerun_record 20200225 and 20200701 (after first failure)
hdhomerun_record.conf RecordPath=/mnt/hdhr-vmdk/recordings
tune2fs Filesystem created:       Wed Aug 28 12:53:55 2019
I noticed the logs have this message from around the time the DVR stopped working this morning, it was complaining about not having tuners (but not when it stopped last night):

Code: Select all

# cat 20200714.log | grep -C 5 tuners
20200714-16:37:47 Recording: event Andrea Mitchell Reports 20200714 [20200714-1600] creating new worker
20200714-16:37:47 Recording: CNN Newsroom 20200714 [20200714-1600] resuming interrupted recording
20200714-16:37:47 Recording: event CNN Newsroom 20200714 [20200714-1600] creating new worker
20200714-16:37:47 Recording: event MSNBC Live 20200714 [20200714-1700] in future
20200714-16:37:47 Recording: next timer event in 0h21m43s
20200714-16:37:47 Recording: no tuners available to record Andrea Mitchell Reports 20200714 [20200714-1600]
20200714-16:37:47 Recording: no tuners available to record CNN Newsroom 20200714 [20200714-1600]
20200714-16:37:54 Status: Resource: nbk=0 dmk=2218
20200714-16:38:38 Playback: Streaming: CNN Newsroom 20200714 [20200714-1500] to 192.168.1.27 starting at 0MB
20200714-16:38:38 Playback: Streaming: CNN Newsroom 20200714 [20200714-1500] to 192.168.1.27 starting at 609MB
20200714-16:38:40 Playback: cmd set-resume: /mnt/hdhr-vmdk/recordings/CNN Newsroom/CNN Newsroom 20200714 [20200714-1500].mpg @ 1270
20200714-16:38:41 Playback: Streaming: CNN Newsroom 20200714 [20200714-1500] to 192.168.1.27 starting at 898MB

Last night after doing some basic troubleshooting (restarting service, starting binary manually, etc.) I determined I couldn't get it working and thought it was because the binary was old (20200225 vs 20200701) and I upgraded it and it worked until this morning via the openrc script.

Well now, in an attempt to remove however many moving parts I can, I started the binary directly inside the record folder instead of using an openrc script (an old version of 20200225) and it seems to be working OK, but at this point I'm not confident that it will continue. *UPDATE* Actually it wasn't working OK, it didn't record from 9:10 am to about 10:17 am

Now I've updated the firmware in both the hdhomerun primes and am running DVR 20200701 directly from the recordings folder. Fingers crossed.

Is there something going on SD's end that might be causing an issue, like UI updates? It's just been working for so long without issue I am really surprised to see anything like this happening.

NedS
Silicondust
Posts: 1383
Joined: Mon Dec 10, 2018 12:38 pm

Re: [UPDATED] Linux DVR stops connecting suddenly during playback

Post by NedS »

The normal DVR logs haven't really captured anything useful. Everything looks normal, then the DVR clearly stops, then starts back up later on. I will ask the dev team if there are other logs that might have recorded the issue in Alpine Linux, or if we can add anything to help debug this.

averyfreeman
Posts: 252
Joined: Sun Apr 09, 2017 11:12 am
Device ID: 1326E235 1313788A
Location: Olympia, WA
Contact:

Re: [UPDATED] Linux DVR stops connecting suddenly during playback

Post by averyfreeman »

NedS wrote:
Tue Jul 14, 2020 8:00 pm
The normal DVR logs haven't really captured anything useful. Everything looks normal, then the DVR clearly stops, then starts back up later on. I will ask the dev team if there are other logs that might have recorded the issue in Alpine Linux, or if we can add anything to help debug this.
If I experience the issue again, should I reply to this thread, or start a new one?

Thank you

NedS
Silicondust
Posts: 1383
Joined: Mon Dec 10, 2018 12:38 pm

Re: [UPDATED] Linux DVR stops connecting suddenly during playback

Post by NedS »

Either is fine

Post Reply