TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Discussion of the new user interface for the HDHomeRun app.
Post Reply
Bobstr
Posts: 173
Joined: Mon Oct 22, 2012 2:07 pm
Device ID: 131CCFEA, 1314A87C
Location: Seattle area

TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by Bobstr » Mon Feb 03, 2020 12:13 pm

I've had this issue for about a week and a half or, at most two weeks. The only way out is to exit the app. It restarts as normal with no lasting effects, and it occurs approximately once (sometimes twice within a short time), then doesn't happen for multiple days. What are your thoughts on this?


I don't have a screen shot, but this is the scenario:

Standard usage, watching Live TV, usually after using Discover/show screen/watch TV to get to live TV.
Press exit to leave live TV and get to Recorded.
Screen goes black with this line:
"TypeError: Unable to get property 'client height' of undefined or null reference"
Under that in the center of the screen these are in a single vertical column:
ln t
ln div
ln t
ln t
ln div
ln t
ln t
ln div
ln t
ln t
ln t
ln t
ln t
ln t
ln div
ln t
ln t
ln t
ln div
ln t
ln t
ln t
ln t
ln n

idsanity
Posts: 21
Joined: Sun Sep 08, 2013 8:25 pm

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by idsanity » Tue Feb 04, 2020 11:56 am

I've been seeing the same thing for about 1.5 - 2 weeks. Watching Live TV after using Discover (not sure if that's relevant), hit the back button to return to the menu, and receive this error. I'm using an Nvidia Shield 2017.

jasonl
Expert
Posts: 15174
Joined: Sun Oct 28, 2007 9:23 pm

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by jasonl » Tue Feb 04, 2020 11:58 am

How long do you leave it going on live TV before hitting back? We have not been able to reproduce this so far, so we need specifics.

idsanity
Posts: 21
Joined: Sun Sep 08, 2013 8:25 pm

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by idsanity » Tue Feb 04, 2020 12:16 pm

For me, probably less than 10 minutes. It doesn't happen every time. I'll see if I can find a pattern.

Bobstr
Posts: 173
Joined: Mon Oct 22, 2012 2:07 pm
Device ID: 131CCFEA, 1314A87C
Location: Seattle area

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by Bobstr » Tue Feb 04, 2020 7:06 pm

jasonl wrote:
Tue Feb 04, 2020 11:58 am
How long do you leave it going on live TV before hitting back? We have not been able to reproduce this so far, so we need specifics.
I think I get it at varying times. Sometimes it's somewhere under an hour, sometimes it's longer. I haven't really associated a timeline on it. I'll do that when it happens again.

Bobstr
Posts: 173
Joined: Mon Oct 22, 2012 2:07 pm
Device ID: 131CCFEA, 1314A87C
Location: Seattle area

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by Bobstr » Thu Feb 06, 2020 10:57 am

Bobstr wrote:
Tue Feb 04, 2020 7:06 pm
jasonl wrote:
Tue Feb 04, 2020 11:58 am
How long do you leave it going on live TV before hitting back? We have not been able to reproduce this so far, so we need specifics.
I think I get it at varying times. Sometimes it's somewhere under an hour, sometimes it's longer. I haven't really associated a timeline on it. I'll do that when it happens again.
This re-occurred last night somewhere between 8 and 10 pm PST. I enabled reporting in the client app immediately after exiting the app and restarting it. The app had been running since at least 8 am that morning.

Bobstr
Posts: 173
Joined: Mon Oct 22, 2012 2:07 pm
Device ID: 131CCFEA, 1314A87C
Location: Seattle area

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by Bobstr » Mon Feb 10, 2020 11:20 am

Since my last post, this error has occurred an additional 4 or 5 times, usually when the app has been open for a few hours. Always the same apparent cause: Pressing exit/back when in Live TV. Sometimes it's when the slice guide was used to select the channel/show it was on, sometimes when the show was chosen through the discover screen.

Latest time was last night, somewhere between 6 and 8 pm PST (sorry - Id didn't get a chance to write down the specific time).

idsanity
Posts: 21
Joined: Sun Sep 08, 2013 8:25 pm

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by idsanity » Tue Feb 11, 2020 9:58 am

I had this happen again this morning. I've been sending diagnostic data if you're interested.

idsanity
Posts: 21
Joined: Sun Sep 08, 2013 8:25 pm

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by idsanity » Fri Feb 14, 2020 12:07 pm

Is there a more effective way to report bugs ?

NedS
Silicondust
Posts: 846
Joined: Mon Dec 10, 2018 12:38 pm

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by NedS » Fri Feb 14, 2020 6:00 pm

idsanity wrote:
Fri Feb 14, 2020 12:07 pm
Is there a more effective way to report bugs ?
We are still looking into it, but have not been able to reproduce the issue yet. It might have already been fixed when the developer was working on other parts of the UI code, so can you tell us if you are seeing this when the option "Early access to features" is enabled?

Bobstr
Posts: 173
Joined: Mon Oct 22, 2012 2:07 pm
Device ID: 131CCFEA, 1314A87C
Location: Seattle area

Re: TypeError: Unable to get property 'client height' of undefined or null reference when exiting Live TV

Post by Bobstr » Mon Feb 17, 2020 11:56 am

NedS wrote:
Fri Feb 14, 2020 6:00 pm
idsanity wrote:
Fri Feb 14, 2020 12:07 pm
Is there a more effective way to report bugs ?
We are still looking into it, but have not been able to reproduce the issue yet. It might have already been fixed when the developer was working on other parts of the UI code, so can you tell us if you are seeing this when the option "Early access to features" is enabled?
Yes, I do have early access to features enabled.

It looks like this may predominantly be a 'long use of the app' scenario, as it's happened a couple more time - always after it's been left running for hours, even as much as overnight. (I never turn off the app or the windows 10 PC it runs on in my living room, I just turn off the TV and the A/V receiver that the HDMI signal is routed through).

Post Reply