Continued problems on EX4100

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
djp952
Posts: 1108
Joined: Wed Oct 01, 2008 8:46 pm
Device ID: 131EB7F7;131ED0E0
Location: Elkridge, MD

Continued problems on EX4100

Post by djp952 » Tue Feb 04, 2020 8:39 pm

Hi! I'm still having problems with the latest RECORD beta on an EX4100 NAS. What I'm still seeing is that once an hour, the data stream(s) completely drop for a couple/few seconds. This hits both Live and Recorded streams simultaneously. In a previous post in the Hardware area it was noted that my tuners are fine but my NAS was having problems writing to disk.

I've spent a lot of time looking at the NAS and have found nothing wrong with it. I did, however, learn that atop is installed on this device so I've been learning to use that. What I've found so far is that once an hour, you are correct, the disk usage spikes from 2-3% to like 65% for a couple seconds. Unfortunately, the only process that is using the disk at that time is hdhomerun_dvr, from what I can tell. Here is an example event from atop:

FRAME: 2020/02/04 20:59:18 (normal % but avio looks high)

Code: Select all

DSK |          sdd | busy      2% |  read       1 | write     15 | KiB/r     32 | KiB/w     10 | MBr/s    0.0  | MBw/s    0.0 | avio 15.6 ms |
DSK |          sda | busy      2% |  read       0 | write     10 | KiB/r      0 | KiB/w      2 | MBr/s    0.0  | MBw/s    0.0 | avio 24.0 ms |
DSK |          sdc | busy      2% |  read       1 | write     15 | KiB/r     32 | KiB/w     12 | MBr/s    0.0  | MBw/s    0.0 | avio 13.8 ms |
DSK |          sdb | busy      2% |  read       1 | write     11 | KiB/r     32 | KiB/w      4 | MBr/s    0.0  | MBw/s    0.0 | avio 16.7 ms |

   PID                  TID                 RDDSK                WRDSK                WCANCL                 DSK               CMD         1/1  
  5840                    -                    0K               32224K                    0K                100%               hdhomerun_dvr
  3981                    -                    0K                 128K                    0K                  0%               jbd2/md1-8
FRAME: 2020/02/04 20:59:28 (sdd starts ramping up)

Code: Select all

DSK |          sdd | busy     42% |  read       3 | write     95 | KiB/r     42 | KiB/w     31 | MBr/s    0.0  | MBw/s    0.3 | avio 42.4 ms |
DSK |          sdc | busy      4% |  read       4 | write     31 | KiB/r     40 | KiB/w     98 | MBr/s    0.0  | MBw/s    0.3 | avio 11.4 ms |
DSK |          sdb | busy      3% |  read       1 | write     93 | KiB/r     64 | KiB/w     30 | MBr/s    0.0  | MBw/s    0.3 | avio 3.51 ms |
DSK |          sda | busy      3% |  read       2 | write     45 | KiB/r     48 | KiB/w     63 | MBr/s    0.0  | MBw/s    0.3 | avio 7.02 ms |

   PID                  TID                 RDDSK                WRDSK                WCANCL                 DSK               CMD         1/1
  5840                    -                    0K               26880K                    0K                 99%               hdhomerun_dvr
  3981                    -                    0K                 128K                    0K                  0%               jbd2/md1-8
FRAME: 2020/02/04 20:59:38 (sdd ramping down)

Code: Select all

DSK |          sdd | busy     31% |  read       1 | write    427 | KiB/r     64 | KiB/w     43 | MBr/s    0.0  | MBw/s    1.8 | avio 7.20 ms |
DSK |          sdc | busy      6% |  read       9 | write    379 | KiB/r     26 | KiB/w     49 | MBr/s    0.0  | MBw/s    1.8 | avio 1.49 ms |
DSK |          sda | busy      4% |  read       7 | write    360 | KiB/r     36 | KiB/w     52 | MBr/s    0.0  | MBw/s    1.8 | avio 1.17 ms |
DSK |          sdb | busy      4% |  read       5 | write    487 | KiB/r     38 | KiB/w     38 | MBr/s    0.0  | MBw/s    1.8 | avio 0.79 ms |

   PID                  TID                 RDDSK                WRDSK                WCANCL                 DSK               CMD         1/1
  5840                    -                    0K               33312K                    0K                 99%               hdhomerun_dvr
 25875                    -                  112K                   0K                    0K                  0%               kworker/u4:0
FRAME: 2020/02/04 20:59:48 (sdb spikes)

Code: Select all

DSK |          sdb | busy     66% |  read       1 | write    438 | KiB/r     64 | KiB/w     33 | MBr/s    0.0  | MBw/s    1.5 | avio 15.0 ms |
DSK |          sdd | busy      5% |  read       2 | write    440 | KiB/r     32 | KiB/w     34 | MBr/s    0.0  | MBw/s    1.5 | avio 1.06 ms |
DSK |          sdc | busy      4% |  read       2 | write    447 | KiB/r     32 | KiB/w     34 | MBr/s    0.0  | MBw/s    1.5 | avio 0.89 ms |
DSK |          sda | busy      4% |  read       6 | write    388 | KiB/r     53 | KiB/w     38 | MBr/s    0.0  | MBw/s    1.5 | avio 1.02 ms |

   PID                  TID                 RDDSK                WRDSK                WCANCL                 DSK               CMD         1/1
  5840                    -                    0K               21792K                    0K                100%               hdhomerun_dvr
  5326                    -                    0K                   0K                    0K                  0%               system_daemon
FRAME: 2020/02/04 20:59:58 (back to normal)

Code: Select all

DSK |          sda | busy      4% |  read       3 | write     98 | KiB/r     42 | KiB/w     78 | MBr/s    0.0  | MBw/s    0.7 | avio 4.06 ms |
DSK |          sdd | busy      4% |  read       3 | write     94 | KiB/r     32 | KiB/w     80 | MBr/s    0.0  | MBw/s    0.7 | avio 3.92 ms |
DSK |          sdc | busy      4% |  read       4 | write     42 | KiB/r     36 | KiB/w    181 | MBr/s    0.0  | MBw/s    0.7 | avio 8.04 ms |
DSK |          sdb | busy      3% |  read       5 | write     56 | KiB/r     38 | KiB/w    133 | MBr/s    0.0  | MBw/s    0.7 | avio 5.41 ms |

   PID                  TID                 RDDSK                WRDSK                WCANCL                 DSK               CMD         1/1
  5840                    -                    0K               32032K                    0K                 99%               hdhomerun_dvr
  3981                    -                    0K                 160K                    0K                  0%               jbd2/md1-8
I don't know if there is anything else I can do to prove or disprove if the software is at fault. For now I've uninstalled the software and replaced it with the last production version and am monitoring. I have the atop log referenced above if you want to see it. I didn't see anything pop in subsequent logs after the software downgrade, but am watching Live TV now on a device while capturing a fresh atop that I will let run for more than an hour.

Please let me know what, if anything, I can do to help work this out. If it's hardware, well, it's hardware. I just don't see any indication of that being the case. The NAS works perfectly fine 24/7 for everything except DVR, and that is a rather recent issue (December timeframe).

Thank you!!

djp952
Posts: 1108
Joined: Wed Oct 01, 2008 8:46 pm
Device ID: 131EB7F7;131ED0E0
Location: Elkridge, MD

Re: Continued problems on EX4100

Post by djp952 » Wed Feb 05, 2020 9:21 am

Pleased to report that it's so far so good with 20190621. Watched it last night, been using it all morning without any problems. Been capturing with atop as well and scanned through them, no disk % spikes yet, nothing over 10% in fact. No missing TS packets in test recordings done this morning and no drop-outs on Live streaming.

I don't recall when I installed 20190815beta1, but it may have been around when my problems started. Being Roku-less I think I skipped that version for a while.

If I continue to see no problems on 20190621, I'll go back to the newest beta when time allows to ensure the problem comes back.

Hopefully this information is helpful.

edit: Am now beyond the 24-hour mark and there have been zero problems/glitches with the system running 20190621. While not conclusive without reinstalling and checking the BETA version(s), it's looking much more likely that the post 20190621 version(s) of RECORD have something weird going on.

djp952
Posts: 1108
Joined: Wed Oct 01, 2008 8:46 pm
Device ID: 131EB7F7;131ED0E0
Location: Elkridge, MD

Re: Continued problems on EX4100

Post by djp952 » Fri Feb 07, 2020 8:03 am

OK, the problem finally happened with the old version as well. It took a couple days to manifest.

Whatever is going on only happens when the DVR software is running, presumably because it's the only thing writing to the disk(s). I've done a reset on the NAS and will re-install the latest beta and see what happens. Hopefully I don't need a new NAS.

Post Reply