Planned recordings don't occur

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
.willow.
Posts: 10
Joined: Mon Oct 28, 2019 12:24 am

Planned recordings don't occur

Post by .willow. » Mon Oct 28, 2019 12:40 am

Hi all,

Hoping someone can assist. I have paid for a subscription and when I go to "Recorded" it tells me "Record your favorite shows with HDHomerun DVR". In settings, it says my DVR is "Active". But every time I schedule a recording, it doesn't actually happen.
I have tried on multiple devices and multiple shows and they then show up as "Tasks", but when the time comes, nothing records.

I am using a Synology NAS for the location, and have redone the setup there. No issues I can see. (I have even tried setting the NAS to always awake in case that was the issue).

I can also pause live TV ok.

I just can't record.

The fault log text document n the NAS shows the following:

0xe5592573
11
(nil)
0x100138b0
0x10012eb0
0x10034f34
0x1003af24
0x1003f0a0
0x100473b8
0x1003622c
0x1003f0a0
0x10009fe4
0x10033f0c
0x10001288
0x10014e7c
0x100000d4
0x10008c38
0x1003f0a0
0x10001288
0x100045bc
0x10004758
0x100091e8
0x10009fe4
0x100091e8
0x10009fe4
0x100095a8
0x100000d4
0x1000a130
0x10004918
0x10032c4c
0x10000dc4
0x100000d4
0x1003b1bc
0x1003f0a0
0x100000d4
0x1003b9f8
0x1003f0a0
0x1003af24
0x1003f0a0
0x100042e0
0x10008d90
0x100140b4
0x10001288
0x10012c4c
0x1003ca2c
0x1003c9f0
0x100000d4
0x1000040c
0x1000015c
0x1000040c


Any help greatly appreciated, I have googled and searched these forums to no avail.

Cheers

Willow

cincylion
Posts: 17
Joined: Fri Nov 20, 2015 7:29 pm

Re: Planned recordings don't occur

Post by cincylion » Mon Oct 28, 2019 7:11 am

I had the same problem with my NAS. A reboot fixed it.

jasonl
Silicondust
Posts: 14749
Joined: Sun Oct 28, 2007 9:23 pm

Re: Planned recordings don't occur

Post by jasonl » Mon Oct 28, 2019 2:00 pm

Has this particular NAS ever recorded previously?

How did you install the DVR on the NAS (NAS Install in HDHomeRun Setup, install package from the forums, something else)?

Did you change to a different recording location or change any permissions on the default recording location?

.willow.
Posts: 10
Joined: Mon Oct 28, 2019 12:24 am

Re: Planned recordings don't occur

Post by .willow. » Tue Oct 29, 2019 1:14 am

Hey all,

Thanks for the quick replies.

Answers to questions:

- This NAS has never recorded before. This is my first HDHomerun.
- Installed onto NAS using HDHomerun setup program (twice, in case I stuffed it up the first time)
- Did not change any directory or modify anything from the user guide.

Have tried a NAS reboot (Good idea, had rebooted everything else....) but no luck.

NedS
Silicondust
Posts: 585
Joined: Mon Dec 10, 2018 12:38 pm

Re: Planned recordings don't occur

Post by NedS » Tue Oct 29, 2019 1:26 am

Try using the Synology package from here: viewtopic.php?f=126&t=67044

It's the same DVR software, but with a different installation method (that's actually much better than what we normally use, and some day we'll have some native Synology/QNAP/etc stuff set up).

.willow.
Posts: 10
Joined: Mon Oct 28, 2019 12:24 am

Re: Planned recordings don't occur

Post by .willow. » Tue Oct 29, 2019 1:49 am

Thanks Neds.

Is there any sort of Uninstall I should do of the current stuff first?

Cheers

.willow.
Posts: 10
Joined: Mon Oct 28, 2019 12:24 am

Re: Planned recordings don't occur

Post by .willow. » Tue Oct 29, 2019 1:51 am

Disregard! I just read further down the forum you sent me and there is advice on how to do it!

Cheers

.willow.
Posts: 10
Joined: Mon Oct 28, 2019 12:24 am

Re: Planned recordings don't occur

Post by .willow. » Tue Oct 29, 2019 2:36 am

Alright.

I learnt how to SSH. followed all the steps (I think).

Interestingly, when I went to stop the recording service, it told me that it wasn't running....

After following the rest of the process, I started the service through the DSM Web and it says it is running.

I then clicked on the URL and at the bottom of the page that popped up it says the recording service is NOT running.....

Clicked on the settings icon and it gives me a log. Not sure what it means... Can post if needed.

Is a "Curl extension" important? It seems that is not available....


Cheers

jasonl
Silicondust
Posts: 14749
Joined: Sun Oct 28, 2007 9:23 pm

Re: Planned recordings don't occur

Post by jasonl » Tue Oct 29, 2019 12:28 pm

Please uninstall the package, delete the HDHomeRun share, reboot the NAS, and then reinstall the package. Don't go through any of the steps to transfer from a previous install, just see if it works from the start. You have no existing recordings to transfer over so there's no need to go through those steps.

.willow.
Posts: 10
Joined: Mon Oct 28, 2019 12:24 am

Re: Planned recordings don't occur

Post by .willow. » Tue Oct 29, 2019 1:13 pm

Thanks Jasonl,

I'll list the steps I have done in case I do something wrong.

1 - I uninstalled the SPK by going to package center and using the drop down to select "uninstall"
2 - I went to "Control Panel => Shared Folder" to delete the share folder and found 2. HDHomerun and HDHomeRunDVR. I deleted both.
3 - I rebooted the NAS
4 - I used package Center to manually install the SPK

Once that was done, I clicked on the URL in the package center and bought up the HDHomerun page. Recording says still not recording with error:

"HDHomeRun RECORD not running | 0x1000040c"

Went to dashboard and stopped then started.

Interestingly noticed that the record path was different this time and the port number is filled in.

Went to my Synology and found a folder for the recordings had not been made, So I made one (Called "HDHomeRunDVR" as per the record path) and gave it as many permissions as I could.

Stopped and started the service, but no luck.

Any more thoughts?

Cheers

jasonl
Silicondust
Posts: 14749
Joined: Sun Oct 28, 2007 9:23 pm

Re: Planned recordings don't occur

Post by jasonl » Tue Oct 29, 2019 3:36 pm

Which model Synology is this?

.willow.
Posts: 10
Joined: Mon Oct 28, 2019 12:24 am

Re: Planned recordings don't occur

Post by .willow. » Wed Oct 30, 2019 1:54 am

It's a DS413

demonrik
Posts: 1141
Joined: Mon May 04, 2015 10:03 am
Device ID: 10736454, 1073A35A, 1075C377

Re: Planned recordings don't occur

Post by demonrik » Wed Oct 30, 2019 7:35 am

.willow. wrote:
Tue Oct 29, 2019 1:13 pm
Interestingly noticed that the record path was different this time and the port number is filled in.
How do you mean different?
Went to my Synology and found a folder for the recordings had not been made, So I made one (Called "HDHomeRunDVR" as per the record path) and gave it as many permissions as I could.
This is worrying.. the directory should be created on installation if it doesn't exist. Something didn't go right on the installer for some reason. You did install the SPK as an administrator user?
How did you create it?
Can you look in /tmp/hdhr_arch_choice and post here.
It should help us understand if the permissions are sufficient.
.willow. wrote:
Tue Oct 29, 2019 1:13 pm
"HDHomeRun RECORD not running | 0x1000040c"
Would seem that it's picking up a log file (the 0x1000040c) - can you share the contents of the directory?

Code: Select all

 ls -l <RecordPath>
.willow. wrote:
Tue Oct 29, 2019 2:36 am
Clicked on the settings icon and it gives me a log. Not sure what it means... Can post if needed.
Yes please.. this is a diagnostic log which might help us..

jasonl
Silicondust
Posts: 14749
Joined: Sun Oct 28, 2007 9:23 pm

Re: Planned recordings don't occur

Post by jasonl » Wed Oct 30, 2019 11:18 am

The DS413 uses a PowerPC CPU, which is not supported by the DVR. You'll need to run the DVR on another device.

.willow.
Posts: 10
Joined: Mon Oct 28, 2019 12:24 am

Re: Planned recordings don't occur

Post by .willow. » Wed Oct 30, 2019 12:09 pm

Hi Demonrik,

Thanks for the reply, sounds like the issue might be my Synology based on the answer from Jason L. I will try later to install the engine on a windows PC and just use the NAS for storage (I assume I can do that....).

Nonetheless, in case it helps you with other stuff, the answers to your questions are:

Regarding record path and port number"
- First install, the port number was empty (I Searched the forums for it but couldn't find what to put)
- The record path was "HDHomerun" My original folder from using the HD installer. The second time it was "HDHomeRUNDVR"

Installing the SPK
- Yes, done as an administrator
- I am sorry, but I am not sure how to access /tmp/hdhr_arch_choice . I tried using the SSH thing and it said permission denied...... No idea if that is even what I am supposed to use.

The log file from the HDHomeRunDVR is:

0xe5592573
11
(nil)
0x100138b0
0x10012eb0
0x10034f34
0x1003af24
0x1003f0a0
0x100473b8
0x1003622c
0x1003f0a0
0x10009fe4
0x10033f0c
0x10001288
0x10014e7c
0x100000d4
0x10008c38
0x1003f0a0
0x10001288
0x100045bc
0x10004758
0x10009fe4
0x100091e8
0x10009fe4
0x100095a8
0x100000d4
0x1000a130
0x10004918
0x10032c4c
0x10000dc4
0x100000d4
0x1003b1bc
0x1003f0a0
0x100000d4
0x1003b9f8
0x1003f0a0
0x1003af24
0x1003f0a0
0x100042e0
0x10008d90
0x100140b4
0x10001288
0x10012c4c
0x1003ca2c
0x1003c9f0
0x100000d4
0x1000040c
0x1000015c
0x1000040c


The log file from the DVR page is:


---------- OS and ENV VARIABLES --------------------------------------------------
Operating System = Linux NAS 2.6.32.12 #24922 SMP Tue Apr 23 17:36:30 CST 2019 ppc
HTTP_HOST = 192.168.1.160
SERVER_NAME = 192.168.1.160
SERVER_ADDR = 192.168.1.160
SERVER_SOFTWARE = nginx/1.15.7
SYS TEMP = /var/services/tmp
---------- PHP INFO -------------------------------------------------------------
php version = 7.2.20
php.ini file = /volume1/@appstore/PHP7.2/misc/php-fpm.ini
php.ini date.timezone =
date_default_timezone_get() = UTC
---------- DVRUI VARS -----------------------------------------------------------
DVRUI_DEBUG =
DVRUI_name = Synology HDHomeRun DVR Manager
DVRUI_version = 0.7.4
DVRUI_TZ =
---------- PERMISSIONS ----------------------------------------------------------
style = 0755
style/style.css = 0644
---------- Config File ----------------------------------------------------------
Location = /volume1/@appstore/HDHomeRunDVR/etc/HDHomeRunDVR.conf
RecordPath = /volume1/HDHomeRunDVR
RecordStreamsMax = 16
ServerPort = 59090
StorageID = F7A481F7-2D35-F477-82FA-D36AA702A890
---------- CONNECTIVITY CHECKS --------------------------------------------------
DVRUI_apiurl = http://api.hdhomerun.com/
Discover URL = http://api.hdhomerun.com/discover
Ping to api.hdhomerun.com success
curl extension = not available
checking alternative connection
stream returned = [ { "DeviceID": "1241D94C", "LocalIP": "192.168.1.37", "BaseURL": "http://192.168.1.37", "DiscoverURL": "http://192.168.1.37/discover.json", "LineupURL": "http://192.168.1.37/lineup.json" } ]
---------- HDHR TUNERS-----------------------------------------------------------
tuner(0) id: 1241D94C
tuner(0) model: HDHR5-2DT
tuner(0) firmware: 20190621
tuner(0) baseurl: http://192.168.1.37
tuner(0) auth: Qjg6Q50Q0kxwf85gF8/I0jr4
---------- HDHR DVR ENGINES------------------------------------------------------
---------- HDHR Account -----------------------------------------------------------
curl extension = not available
stream returned = { "AccountEmail": "adam.tesswilson@gmail.com", "AccountDeviceIDs": [ "1241D94C" ], "DvrActive": 1, "AccountState": "Active" }
------------ DVR Series ------------------------------------------------------
?DisplayGroupID=root
------------ DVR Recordings ------------------------------------------------------


Hope this helps, Have to run to work, will try the PC install this evening!

JasonL,

Thanks for figuring that out, I'll see how the PC install goes!

Post Reply