Extend issue; reset reason = application watchdog

Reception, channel detection, network issues, CableCARD setup, etc.
Post Reply
ckwsp101_tv
Posts: 9
Joined: Fri Mar 13, 2015 4:46 pm
Location: marin county , ca

Extend issue; reset reason = application watchdog

Post by ckwsp101_tv » Thu Aug 08, 2019 9:23 am

I experienced a watchdog reset on my old Extend.
Original power supply.
Happens maybe 1 time out of 60 recording sessions.
I use the wget command from linux shell.

Any suggestions on how to debug?

Hardware Model HDTC-2US
Firmware Version 20190621
Device ID 10519452

19700101-00:00:17 System: reset reason = application watchdog
19700101-00:00:17 System: E5592573 0000000E 004FDB88 00474E28 00474018 00517B08 0050F3C8 00410EE4
19700101-00:00:17 System: 00410EE4 0050F3C8 0051D4A8 00410EE4 00407110 0051D4A8 00406FC0 00473B68
19700101-00:00:17 System: network link 100f
19700101-00:00:19 System: ip address obtained: 192.168.1.108 / 255.255.255.0
20190808-05:41:13 System: time changed from Thu Jan 1 00:00:36 1970 to Thu Aug 8 05:41:13 2019

gtb
Expert
Posts: 3996
Joined: Thu Oct 06, 2011 1:00 pm
Location: Sunnyvale, CA USA

Re: Extend issue; reset reason = application watchdog

Post by gtb » Thu Aug 08, 2019 9:37 am

ckwsp101_tv wrote:
Thu Aug 08, 2019 9:23 am
Any suggestions on how to debug?
You might try an alternative power supply, but the original extends were notorious to run hot, and the fan reportedly often died. And high heat can result in badness with electronics. I would generally recommend that if the extend is the right answer for you to have it upgraded with a new passive thermal cooling case, which SD offers through their store (I don't remember the price, but it was reasonable considering what they have to do).

whmaurer
Posts: 6
Joined: Thu Jun 13, 2019 11:25 am

Re: Extend issue; reset reason = application watchdog

Post by whmaurer » Mon Sep 09, 2019 7:28 am

What does this error message mean? Is this exclusively a heat warning?

For what it's worth, I'm seeing this issue as well. I have 2 Extend HDTC-2US units running Firmware Version 20190621. Both are original units with fans that I sent into SD to be upgraded into the new fanless, metal case; I still have the original PSUs.

I've been noticing some recordings through Plex where the video capture seems to lag; in this case, a show will be recording, then the video audio will seamlessly skip forward a few minutes; this process repeats so that Plex records 30 minutes over the course of a much longer period, so I essentially get scattered clips of several shows in the order that they aired. I was checking the logs to see if there was anything useful, but both logs are very short:

Extend #1:
HDHomeRun EXTEND
System Log
19700101-00:00:17 System: reset reason = application watchdog
19700101-00:00:17 System: E5592573 0000000E 004FE4A8 00440B88 00447DC0 00412FC8 004F942C 004F9400
19700101-00:00:17 System: 00524FAC FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
19700101-00:00:17 System: network link 100f
19700101-00:00:19 System: ip address obtained: 192.168.1.47 / 255.255.255.0
20190909-11:04:00 System: time changed from Thu Jan 1 00:00:36 1970 to Mon Sep 9 11:04:00 2019

Extend #2:
HDHomeRun EXTEND
System Log
19700101-00:00:17 System: reset reason = application watchdog
19700101-00:00:17 System: E5592573 0000000E 004FE4A8 00440B88 00447DC0 00412FC8 004F942C 004F9400
19700101-00:00:17 System: 00524FAC FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
19700101-00:00:17 System: network link 100f
19700101-00:00:19 System: ip address obtained: 192.168.1.46 / 255.255.255.0
20190909-03:25:36 System: time changed from Thu Jan 1 00:00:36 1970 to Mon Sep 9 03:25:36 2019
20190909-03:25:47 Tuner: tuner0 tuning 32.2 WHUTKid (8vsb:587MHz-2)
20190909-03:25:47 Tuner: tuner0 streaming http to 192.168.1.192:54356
20190909-03:25:52 Tuner: tuner0 http stream ended (remote closed)

Is there any reason that these 2 units would reset at the same time? Power outage/surge?

goofnroxx
Posts: 79
Joined: Fri Jun 16, 2017 10:30 am

Re: Extend issue; reset reason = application watchdog

Post by goofnroxx » Mon Sep 09, 2019 10:46 am

Looks to me they reset hours apart. The timestamp on the restart is just the start of when an epoch time starts from. Meaning they didn't restart in 1970. The actual time is a few lines later.

whmaurer
Posts: 6
Joined: Thu Jun 13, 2019 11:25 am

Re: Extend issue; reset reason = application watchdog

Post by whmaurer » Tue Sep 24, 2019 11:45 am

goofnroxx wrote:
Mon Sep 09, 2019 10:46 am
Looks to me they reset hours apart. The timestamp on the restart is just the start of when an epoch time starts from. Meaning they didn't restart in 1970. The actual time is a few lines later.
Haha, got it. I'm still having this issue on a regular basis.

Is APPLICATION WATCHDOG definitely caused by a hardware issue? Looking at the forums, it doesn't seem like this is a hugely common issue. If it were, I think more people would be on here complaining. For that reason, it seems unlikely that both of my recently upgraded Extends would have the same issue, right? Unless there is an issue with the Extend upgrade process or with using the old PSUs...

Could this possibly be a Plex DVR issue (seems like a good possibility)? A network or DVR drive issue? Is there any way to write logs to external media so I can see what was happening before my Extend resets?

Ken.F
Posts: 2175
Joined: Fri Apr 05, 2013 9:20 am
Device ID: 1041A706, 1043EB32, 104BAD9E, 13168DC5, 1322A7AC
Location: West Rockhill, PA

Re: Extend issue; reset reason = application watchdog

Post by Ken.F » Tue Sep 24, 2019 12:19 pm

whmaurer wrote:
Tue Sep 24, 2019 11:45 am
Looking at the forums, it doesn't seem like this is a hugely common issue. If it were, I think more people would be on here complaining.
I get them once in a while. I asked on the forum a year or two ago what it means and nobody replied. Here's my latest one.

HDHR4-2US (Connect) 104BAD9E

Code: Select all

19700101-00:00:02 System: reset reason = application watchdog
19700101-00:00:02 System: E5592573 0000000E 00045F72 00047366 000472CE 0004EE24 000194E8 FFFFFFFF
19700101-00:00:02 System: FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
19700101-00:00:09 System: network link 100f
19700101-00:00:10 System: ip address obtained: 192.168.1.42 / 255.255.255.0
20190831-01:15:50 System: time changed from Thu Jan  1 00:00:26 1970 to Sat Aug 31 01:15:50 2019

whmaurer
Posts: 6
Joined: Thu Jun 13, 2019 11:25 am

Re: Extend issue; reset reason = application watchdog

Post by whmaurer » Wed Sep 25, 2019 7:16 am

So, based on some really rough local testing, it seems like my problems manifest chiefly when I use the EXTEND for transcoding on a specific channel (in this case, PBS WHUT 32.1 in the Washington, DC area, which airs some shows that I regularly DVR for my kids).

I generally don't use transcoding to watch live TV in my home, the default transcode profile in EXTEND settings is set to NONE. That said, I have my Plex server set to transcode when recording to reduce DVR file size (my Plex server Live TV config is set to "Highest Quality," NOT "Original Quality", for this device). When streaming using these settings, the EXTEND appears to use the HEAVY transcode profile. For most channels, I can sustain streams to my EXTEND using the HEAVY profile without any issue.

For this one channel in particular, each time I start a stream, the video lasts just a couple of seconds before the stream dies and the HDHR becomes momentarily unresponsive and resets. In the couple of seconds before the EXTEND resets, I can see that it is using the HEAVY transcode profile. Here is what I saw in the tuner status during my most recent test right before the EXTEND reset:

Tuner 0 Status
Virtual Channel 32.1 WHUT HD
Frequency 587.000 MHz
Program Number 1
Modulation Lock 8vsb
Signal Strength 100%
Signal Quality 78%
Symbol Quality 100%
Transcode Profile heavy
Streaming Rate 8.338 Mbps
Resource Lock 192.168.xxx.xxx

To work around this, I changed my Plex server settings to request "Original Quality" instead of "Highest Quality" in the HDHomerun device settings (the EXTEND is still set to DEFAULT TRANSCODE PROFILE = NONE). After making this change, the EXTEND TUNER STATUS displays the transcode profile as NONE when streaming to Plex, which I believe means that it is not transcoding at all; here is the TUNE STATUS output:

Tuner 0 Status
Virtual Channel 32.1 WHUT HD
Frequency 587.000 MHz
Program Number 1
Modulation Lock 8vsb
Signal Strength 93%
Signal Quality 74%
Symbol Quality 100%
Transcode Profile none
Streaming Rate 11.433 Mbps
Resource Lock 192.168.xxx.xxx

With these settings, the EXTEND does NOT reset and I am able watch without issue. From there, I can change the stream quality in the Plex player (not in the server settings), which shifts transcoding from the Extend to my server, without any trouble. This does NOT work with the DVR recordings, however, since those are handled in the server settings and not in the client player, so I supposed I'm stuck with large files.

Since this channel works as long as I don't try to transcode using the EXTEND, and Plex is able to transcode the stream when the EXTEND is not, it suggests to me there must be something particular to this channel's OTA signal that is causing the EXTEND to crash. Does that seem possible?

bglf83
Posts: 4
Joined: Mon Oct 14, 2019 7:41 pm

Re: Extend issue; reset reason = application watchdog

Post by bglf83 » Mon Oct 14, 2019 7:47 pm

Did you get a solution to this? The same issue occurs with CBS where I live. The other channels seem fine but CBS will cause the tuners to reset. I have 2 extends used with Plex.

ckwsp101_tv
Posts: 9
Joined: Fri Mar 13, 2015 4:46 pm
Location: marin county , ca

Re: Extend issue; reset reason = application watchdog

Post by ckwsp101_tv » Tue Oct 15, 2019 10:43 am

Sorry never found root cause.

Happens less often at this time.

Bad news for me is stations switching to aux transmitter antennas for repack activity.
I no longer receive KGO (RF 7) ABC network. It should return when Sutro Tower engineering finished in 2020.

I'm looking for other ways to view ABC stuff.

bglf83
Posts: 4
Joined: Mon Oct 14, 2019 7:41 pm

Re: Extend issue; reset reason = application watchdog

Post by bglf83 » Tue Oct 15, 2019 12:14 pm

Interesting, my issue is on RF 11 (CBS 11.1 Houston) which is also VHF. PBS on RF 8 seems fine which is also VHF.

I have noticed that the bit rate of video from CBS is much higher than what I get from ABC, Fox and NBC as well.

bglf83
Posts: 4
Joined: Mon Oct 14, 2019 7:41 pm

Re: Extend issue; reset reason = application watchdog

Post by bglf83 » Wed Oct 16, 2019 5:19 pm

I may have found an element on my antenna that was bent and touching another area it should not. The **** I had did not mind this, but my signal jump significantly and became more steady when I bent this part back to where it looked like it should be.

Post Reply