HDHomeRun Prime - streaming stops after a few seconds

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
tvhub01
Posts: 5
Joined: Sat Jul 06, 2019 12:15 pm

HDHomeRun Prime - streaming stops after a few seconds

Post by tvhub01 » Sat Jul 06, 2019 12:48 pm

I have a strange issue with streaming any channels using HDHomeRun Prime tuner. After a few seconds the channel sops and the screen turns black. I didn't have any problems until two days ago. I have rebooted the tuner as well as TA multiple times. I also tried to re-insert the cable card a couple of times. It happens on multiple devices (iPhone, iPad, Mac and Apple TV).

In the logs I see "Remote Closed" message:

20190706-19:05:14 CableCARD: tuner2 1148 SUNHD access = subscribed
20190706-19:05:49 Tuner: tuner2 http stream ended (remote closed)
20190706-19:06:37 Tuner: tuner0 tuning 1122 HMKHD
20190706-19:06:38 Tuner: tuner0 streaming http to 192.168.1.42:50568
20190706-19:06:38 CableCARD: tuner0 1122 HMKHD access = subscribed
20190706-19:07:35 Tuner: tuner0 http stream ended (remote closed)
20190706-19:10:16 Tuner: tuner2 tuning 1137 CBSSHD
20190706-19:10:16 Tuner: tuner2 tuning 1137 CBSSHD
20190706-19:10:17 CableCARD: tuner2 1137 CBSSHD access = subscribed
20190706-19:10:17 Tuner: tuner2 streaming http to 192.168.1.38:51137
20190706-19:10:35 Tuner: tuner2 http stream ended (remote closed)

Yesterday, in the morning it wasn't working, but afternoon I was able to to watch different channels without issues. So I thought, OK, that was a temporary glitch. Unfortunately, today, the issue came back.

One more thing. When this is happening I am looking at the logs in a browser. When the channel stops playing, the web page I am looking at (log.html) is displaying an error "404 Not Found. ngnix".

Does any one have any ideas?

Thank you.

gtb
Expert
Posts: 3985
Joined: Thu Oct 06, 2011 1:00 pm
Location: Sunnyvale, CA USA

Re: HDHomeRun Prime - streaming stops after a few seconds

Post by gtb » Sat Jul 06, 2019 2:58 pm

A common issue for streaming stopping after a second or so is that channel requires a full protected path, and your path no longer qualifies (sometimes a video driver update loses the authorization, sometimes it is more complicated).

Typically the request by SD will be to turn on tuner and application diagnostic logging, reproduce the issue, and post back with the date/time and device ID of your devices, and someone from SD will try to look at the logs during SD's normal business hours (having done so in advance means you/they avoid a back-and-forth delay).

tvhub01
Posts: 5
Joined: Sat Jul 06, 2019 12:15 pm

Re: HDHomeRun Prime - streaming stops after a few seconds

Post by tvhub01 » Sat Jul 06, 2019 4:30 pm

Thank you!

I just reproduced the issue (7:25 pm EST). Device ID: 1310733D.

nickk
Silicondust
Posts: 15524
Joined: Tue Jan 13, 2004 9:39 am

Re: HDHomeRun Prime - streaming stops after a few seconds

Post by nickk » Sat Jul 06, 2019 5:05 pm

Hi,

First, recommend upgrading the software on your Mac to the latest release:
https://www.silicondust.com/support/downloads/

There is a record engine running on the Mac but no DVR service. I would recommend removing it to simplify testing... see the Uninstall instructions at the bottom of this page:
https://info.hdhomerun.com/info/dvr:mac

Once removed please restart the app and see if it plays ok.

If it still stops after a few seconds please enable "send diagnostic information" in the app - press play/pause 13 times to open the menu.

Nick

tvhub01
Posts: 5
Joined: Sat Jul 06, 2019 12:15 pm

Re: HDHomeRun Prime - streaming stops after a few seconds

Post by tvhub01 » Sun Jul 07, 2019 6:16 am

Hi Nick,

Thanks for your help. I have updated the software and removed the DVR. It worked this morning for a few minutes, then started again. I just submitted the logs.

Thanks,

Gordon

Online
jasonl
Silicondust
Posts: 14043
Joined: Sun Oct 28, 2007 9:23 pm

Re: HDHomeRun Prime - streaming stops after a few seconds

Post by jasonl » Mon Jul 08, 2019 12:53 pm

Is it possible you have another device on your network that is using a static IP and is set to the same IP address the HDHomeRun has been assigned via DHCP? Recommend that if you're going to set any devices to use a static IP that you reserve that IP address in your router's configuration to prevent it from assigning that IP to other things, like the HDHomeRun.

tvhub01
Posts: 5
Joined: Sat Jul 06, 2019 12:15 pm

Re: HDHomeRun Prime - streaming stops after a few seconds

Post by tvhub01 » Mon Jul 08, 2019 7:38 pm

You are right! When this happened I scanned the network and there was another device with the same IP. HDHomeRun has a reserved IP in the router so it always gets that IP. I have no clue what that device is. It has a different MAC address. I scanned the entire network and searched for it but couldn't find what that was. I have a bunch of devices with reserved IPs.

So I blocked that address in the router and rebooted it to see if it resolved the issue. And it did. But I noticed on different channels the video was stuttering for a couple of seconds from time to time. I've never seen this before.

Online
jasonl
Silicondust
Posts: 14043
Joined: Sun Oct 28, 2007 9:23 pm

Re: HDHomeRun Prime - streaming stops after a few seconds

Post by jasonl » Mon Jul 08, 2019 7:52 pm

I wouldn't trust the router to be blocking it. You might want to unblock it, disconnect the HDHomeRun, and then set up a ping of that IP address. Watch the network activity LEDs on the router and any switches or other devices you might have to see if you can trace back to the offending device. Or, start the ping and start pulling plugs one at a time until it stops responding. And hope it's not on wifi :lol:.

tvhub01
Posts: 5
Joined: Sat Jul 06, 2019 12:15 pm

Re: HDHomeRun Prime - streaming stops after a few seconds

Post by tvhub01 » Thu Jul 11, 2019 11:40 am

I have assigned a different IP to the tuner and now it’s working as expected. Thank you all for your help!

Post Reply