HDHomeRun Add On crashing on Kodi 17.1

Kodi Community Development

Moderator: TVJunkie198

Post Reply
cuccil
Posts: 1
Joined: Fri Jan 13, 2017 6:31 pm

HDHomeRun Add On crashing on Kodi 17.1

Post by cuccil » Wed Apr 26, 2017 6:39 pm

Hi I am running the HDHomeRun Kodi addon on Kodi v 17.1 (Krypton) with an OpenELEC OS (v8.0.2)

This set up works perfectly on my Widows 10 devices running Kodi v 17.1 and my iOS devices running the Channel app.

The behavior on the OpenELEC OS devices are as follows:

I launch the addon it find the HDRomeRun Prime on my server, launches the add on, video displays fine for a short while (but never any sound), then it crashes causing Kodi to reboot.

I just uprgraded from OpenELEC (v6.0.3) and the HDHomeRun addon was working fine in that version of OpenELEC.

HDHomeRun Prime 1312190B7 Version 20161117

Please help!

Lou


Log below

20:34:09.303 T:140193720600704 DEBUG: Previous line repeats 12 times.
20:34:09.303 T:140193720600704 DEBUG: Activating window ID: 10016
20:34:09.624 T:140193720600704 DEBUG: ------ Window Deinit (Custom_1100_AddonLauncher.xml) ------
20:34:09.625 T:140193720600704 DEBUG: ------ Window Init (SettingsCategory.xml) ------
20:34:11.544 T:140191423526656 DEBUG: CWebServer[80]: request received for /jsonrpc
20:34:12.591 T:140193720600704 DEBUG: Previous line repeats 4 times.
20:34:12.591 T:140193720600704 NOTICE: Disabled debug logging due to GUI setting. Level 0.
20:34:12.591 T:140193720600704 NOTICE: Log level changed to "LOG_LEVEL_NORMAL"
20:35:28.677 T:140190962091776 WARNING: CSkinInfo: failed to load skin settings
20:35:31.072 T:140193720600704 WARNING: Previous line repeats 1 times.
20:35:31.072 T:140193720600704 NOTICE: VideoPlayer: Opening: http://192.168.0.194:5004/auto/v102
20:35:31.072 T:140193720600704 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
20:35:31.074 T:140190928520960 NOTICE: Creating InputStream
20:35:32.152 T:140190928520960 NOTICE: Creating Demuxer
20:35:32.889 T:140190928520960 NOTICE: Opening stream: 0 source: 256
20:35:32.889 T:140190928520960 NOTICE: Creating video codec with codec id: 2
20:35:32.889 T:140190928520960 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: MPEG-2 video
20:35:32.889 T:140190928520960 NOTICE: Creating video thread
20:35:32.889 T:140190928520960 NOTICE: Opening stream: 1 source: 256
20:35:32.889 T:140190928520960 NOTICE: Finding audio codec for: 86019
20:35:32.889 T:140190970484480 NOTICE: running thread: video_thread
20:35:32.889 T:140190928520960 NOTICE: Creating audio thread
20:35:32.889 T:140191004055296 NOTICE: running thread: CVideoPlayerAudio::Process()
20:35:32.892 T:140190928520960 NOTICE: Opening stream: 0 source: 256
20:35:32.892 T:140190928520960 NOTICE: Creating video codec with codec id: 2
20:35:32.892 T:140190928520960 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: MPEG-2 video
20:35:32.892 T:140190928520960 NOTICE: Opening stream: 1 source: 256
20:35:32.895 T:140190899152640 NOTICE: COutput::OnStartup: Output Thread created
20:35:32.899 T:140191004055296 NOTICE: Creating audio stream (codec id: 86019, channels: 2, sample rate: 48000, pass-through)
20:35:32.910 T:140193720600704 NOTICE: GL: Selecting Single Pass YUV 2 RGB shader
20:35:32.925 T:140193720600704 NOTICE: GL: NPOT texture support detected
20:35:32.925 T:140193720600704 NOTICE: GL: Using GL_ARB_pixel_buffer_object
20:35:32.925 T:140193720600704 NOTICE: Using GL_TEXTURE_2D
20:35:32.940 T:140193720600704 NOTICE: GL: Selecting Single Pass YUV 2 RGB shader
20:35:32.949 T:140193720600704 NOTICE: GL: NPOT texture support detected
20:35:32.949 T:140193720600704 NOTICE: GL: Using GL_ARB_pixel_buffer_object
20:35:33.640 T:140190970484480 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
20:35:33.942 T:140190970484480 NOTICE: CDVDVideoCodecFFmpeg::CDropControl: calculated diff time: 33366

bemowski
Posts: 1
Joined: Thu Apr 27, 2017 10:57 am

Re: HDHomeRun Add On crashing on Kodi 17.1

Post by bemowski » Thu Apr 27, 2017 11:00 am

I am getting same behavior. OpenELEC 8, Kodi 17.1.

I have mpeg 2 code for the raspberry pi. I've tried all combinations of "hardware acceleration" options in player.

All channels fail in about 5 seconds, and cause kodi crash/restart.

with debug log enabled, I am seeing this:
0:54:47.603 T:1708127136 DEBUG: CMMALRenderer::Run - starting
10:54:47.603 T:1946824720 DEBUG: CMMALRenderer::Configure - 1280x720->1280x720@59.94 flags:0 format:14 ext:0 orient:0
10:54:47.603 T:1946824720 DEBUG: CRenderManager::Configure - 3
10:54:47.604 T:1470100384 DEBUG: OMXPlayerVideo::SetVideoRect 0,0,1280,720 -> 0,0,0,0 (0,0,0,0,mono)
10:54:47.604 T:1470100384 DEBUG: COMXVideo::SetVideoRect 0,0,1280,720 -> 0,0,0,0 t:100000
10:54:47.606 T:1569751968 DEBUG: CVideoPlayer::HandleMessages - player started 2
10:54:47.611 T:1946824720 DEBUG: CMMALRenderer::RenderUpdate - vsync -1 (+8137)
10:54:47.644 T:1569751968 DEBUG: CVideoPlayer::HandleMessages - player started 1
10:54:47.644 T:1569751968 DEBUG: CVideoPlayer::SetCaching - caching state 3
10:54:47.644 T:1461711776 DEBUG: COMXPlayerAudio - CDVDMsg::PLAYER_SETSPEED 1000
10:54:47.644 T:1470100384 DEBUG: COMXPlayerVideo - CDVDMsg::PLAYER_SETSPEED 1000
10:54:47.644 T:1569751968 DEBUG: CDVDClock::SetSpeedAdjust - adjusted:0.000000
10:54:47.644 T:1569751968 DEBUG: VideoPlayer::Sync - Audio - pts: 415989.222223, cache: 0.000000, totalcache: 4024000.167847
10:54:47.644 T:1569751968 DEBUG: VideoPlayer::Sync - Video - pts: 1067922.555558, cache: 50000.000000, totalcache: 100000.000000
10:54:47.644 T:1569751968 DEBUG: CVideoPlayer::HandlePlaySpeed player started RESET
10:54:47.644 T:1569751968 NOTICE: OMXClock using audio as reference
10:54:47.645 T:1569751968 DEBUG: OMXClock::OMXReset audio / video : 1 / 1 wait mask 0->3 state : 2->1
10:54:47.645 T:1470100384 DEBUG: CVideoPlayerVideo - CDVDMsg::GENERAL_RESYNC(415989.222223)
10:54:47.645 T:1569751968 DEBUG: CVideoPlayer::SetCaching - caching state 0
10:54:47.645 T:1569751968 DEBUG: CDVDClock::SetSpeedAdjust - adjusted:0.000000
10:54:47.654 T:1461711776 DEBUG: COMXPlayerAudio - CDVDMsg::GENERAL_RESYNC(415989.222223)
10:54:47.659 T:1461711776 INFO: COMXPlayerAudio - Switching to normal playback
10:54:47.693 T:1470100384 DEBUG: OMXPlayerVideo::SetVideoRect 0,0,1280,720 -> 0,0,1360,768 (0,0,0,0,mono)
10:54:47.693 T:1470100384 DEBUG: COMXVideo::SetVideoRect 0,0,1280,720 -> 0,0,1360,768 t:100000
10:54:47.780 T:1946824720 DEBUG: ------ Window Deinit (DialogBusy.xml) ------
10:54:51.611 T:1569751968 DEBUG: ffmpeg[5D9083A0]: Assertion len >= s->orig_buffer_size failed at libavformat/aviobuf.c:535

############### END LOG FILE ################

TheKLB
Posts: 1
Joined: Fri Apr 28, 2017 9:26 pm

Re: HDHomeRun Add On crashing on Kodi 17.1

Post by TheKLB » Fri Apr 28, 2017 9:28 pm

Experiencing the same thing. Click on the app and it crashes within a few seconds.

Post Reply