Windows 10 HdHomeRun App Issues

ATSC 3.0 Forum
TBR
Posts: 15
Joined: Fri Feb 19, 2021 12:26 pm

Re: Windows 10 HdHomeRun App Issues

Post by TBR »

Computer Configurations and Issues:

HDHomeRun app plays only video on HEVC channels:
Dell Vostro 3560 laptop
i5-3210M CPU @2.50 GHz
Windows 10 Pro v1909 build 18363.1256
HDHomeRun v1.1.311.0
HEVC Video Extensions from Device Manufacturer v1.0.40203.0
Advanced Audio FX Engine 1.12.05 (I don't know where this came from)
Enhanced Video 9.1.0.0 (I don't know where this came from)
Intel Graphics Driver v10.18.10.4885
MyFreeCodec (a codec pack I installed after upgrading to W8 from W7)

HDHomeRun app plays audio and video on HEVC channels (initially just a black screen, unknown why it started working):
Acer Desktop
AMD E2-6110 APU with AMD Radeon R2 Graphics 1.50 Ghz
Windows 10 Home v20H2 build 19042.804
HDHomeRun v1.1.311.0
HEVC Video Extensions from Device Manufacturer v1.0.40203.0
MPEG-2 Video Extension v1.0.22661.0

HDHomeRun app just shows black screen on HEVC channels:
CyberPower PC Desktop
i5-8400 CPU 2.81 GHz
Radeon RX580 card software v21.2.1
Windows 10 Home v20H2 build 19042.804
HDHomeRun v1.1.311.0
HEVC Video Extensions from Device Manufacturer v1.0.40203.0
MPEG-2 Video Extension v1.0.22661.0

HDHomeRun app just shows black screen on HEVC channels:
Alfawise Z83
Intel Atom x5-Z8350 CPU 1.44 GHz
Windows 10 Home v20H2 build 19042.804
HDHomeRun v1.1.311.0
HEVC Video Extensions from Device Manufacturer v1.0.40203.0
MPEG-2 Video Extension v1.0.22661.0

TBR
Posts: 15
Joined: Fri Feb 19, 2021 12:26 pm

Re: Detroit ATSC 3.0 - Jan 2021

Post by TBR »

CBme wrote: Sat Feb 20, 2021 12:16 pm For the app install the setup software https://download.silicondust.com/hdhome ... s_beta.exe
Then run the config_gui.exe and select the tuner to see what it is doing. "C:\Program Files\Silicondust\HDHomeRun\hdhomerun_config_gui.exe"

As to AC-4, there is a thread specifically about it and compatibility.
I wound up building the Linux version of the GUI first, but this one has colors...

According to the GUI, generally the signal strength is around 50% on "unused" channels, although several go to 100%. That's a pretty high level of noise, so some adjustments to my antenna system might be in order (although there is not much I can do now) just to see how that affects the noise level.

Apparently the ATSC 3.0 channels are all on broadcast channel 31, which has a signal strength of 67% (yellow) tonight, a signal quality of 85% (green), a symbol quality of 100%, and "no data" from the tuner on anything but the mobile channel (31-2 which is 120.99). It also reports as PLP0 qam16.

Considering the LONG buffering time (the VideoPlayer app is taking 30 seconds tonight before playing the 120.99 channel), could it be that the HDHomeRun app can't fill its buffer "enough" to start playing? Perhaps the buffer is smaller on the Acer and that's why it plays when the others do not. Is the app expecting the same amount of data bytes from the H.265 HEVC channels as it gets from the H.264 (guessing here) ATSC 1.0 channels?

TBR
Posts: 15
Joined: Fri Feb 19, 2021 12:26 pm

Re: Windows 10 HdHomeRun App Issues

Post by TBR »

Other issues with the W10 app, but a much lower priority:

The app crashes if Windows "moves" it from the C: drive. The Z83 box only has a 32GB flash chip for C: and thus I try to move everything possible to the 128 GB D: SD card. Considering this app is likely to be used on similar "tiny C:/" machines, it's a worthwhile feature and I'm glad "moving" is enabled. I just wished it worked.

The program guide is inaccurate on a number of channels. Some stations here apparently do not publish a schedule (my phone app has no idea, either), but others are incorrect. For example, the PBS World channel may show the PBS Kids listings.

TBR
Posts: 15
Joined: Fri Feb 19, 2021 12:26 pm

Re: Windows 10 HdHomeRun App Issues

Post by TBR »

31-5 102.1 WJBK results
Signal strength 66%
Signal Quality 45%
Symbol Quality 0-20%
PLP1 no-lock bouncing with PLP1 qam256
Using the CyberPower PC:
W10 app: black screen
VLC (via the VIEW button): video-only (broken up)
VideoPlayer: audio and video until it crashed

TBR
Posts: 15
Joined: Fri Feb 19, 2021 12:26 pm

Re: Windows 10 HdHomeRun App Issues

Post by TBR »

One more bit of information:

The ATSC 3.0 signal is coming in fairly well except for 120.99 (mobile). The laptop (still no sound) just gave this error
MF_MEDIA_ENGINE_ERR_ DECODE : HRESULT 0xC00D3E84

I "blew up" the CyberPower PC (oops), and the Z83 still doesn't play ATSC 3 on HDHR app although the VideoPlayer does (slowly at the moment as Windows demands the CPU).

Post Reply