ATSC 3.0 Portland: QUATRO 4K

ATSC 3.0 Forum
Post Reply
robbadler
Posts: 6
Joined: Mon Oct 19, 2020 8:40 pm

Re: ATSC 3.0 Portland: QUATRO 4K

Post by robbadler »

kyl416 wrote: Fri Oct 23, 2020 1:00 pm
robbadler wrote: Fri Oct 23, 2020 12:42 pm I wasn't trying to play it on mac. I was using ffmpeg to inspect the streams, and don't see an audio stream.
FFmpeg can't detect the audio stream because there's no open source AC-4 codec available. There's an open ticket about it:
https://trac.ffmpeg.org/ticket/8349

This also affects other FFmpeg based platforms like VLC, Kodi and Plex.
Edit:
With the latest 20201023 firmware, I am now seeing the AC4 stream via ffmpeg info. From 8.1 KGW:

Code: Select all

    Stream #0:0[0x31]: Video: hevc (Main 10) ([36][0][0][0] / 0x0024), yuv420p10le(tv, bt709), 1920x1080 [SAR 1:1 DAR 16:9], Closed Captions, 59.94 fps, 59.94 tbr, 90k tbn, 59.94 tbc
    Stream #0:1[0x32](eng): Data: bin_data (AC-4 / 0x342D4341)
    Stream #0:2[0x3a](eng): Data: bin_data (STPP / 0x50505453)
Still does not play the audio on the mac, for known reasons. Audio is not playing on the Android app for this channel.
With this same firmware, on a channel re-scan, I lost HEVC for 2.1 KATU, 6.1 KOIN, and 32.1 KRCW.

kyl416
Posts: 56
Joined: Wed Sep 17, 2014 12:09 pm
Device ID: 1080DB11
Location: Tobyhanna, PA
x 3
Contact:

Re: ATSC 3.0 Portland: QUATRO 4K

Post by kyl416 »

Notice how it's listed as "bin_data". FFmpeg doesn't know what to do with the AC-4 stream, so it appears as undecodable binary data instead of an audio stream.

Hopefully now that ATSC 3.0 is finally being deployed, FFmpeg's developers will take a greater interest in supporting it.

elmerF
Posts: 8
Joined: Thu Dec 10, 2015 6:27 am

Re: ATSC 3.0 Portland: QUATRO 4K

Post by elmerF »

Isn't the ac4 codec proprietary? If so, then ffmeg will not support it.

kyl416
Posts: 56
Joined: Wed Sep 17, 2014 12:09 pm
Device ID: 1080DB11
Location: Tobyhanna, PA
x 3
Contact:

Re: ATSC 3.0 Portland: QUATRO 4K

Post by kyl416 »

The specs are freely available but it is covered by a patent. Patents haven't stopped them from supporting codecs in the past, up until March 2017 ac3 was covered by patents, and they've supported that since the early 00s.

kengee1023
Posts: 3
Joined: Fri Oct 23, 2020 1:49 pm
x 1

Re: ATSC 3.0 Portland: QUATRO 4K

Post by kengee1023 »

Setup: Quatro4K Firmware 20201023, HDHomeRun app v20201023, Windows10 w/Dolby Access

Happy to report I see video & hear audio on all ATSC3 HEVC channels here in Portland,
however I only hear left speaker channel on 2.1-KATU, 6.1-KOIN, 32.1-KRCW
versus both speaker channels on 8.1-KGW, 10.1-OPB, 12.1-KPTV, 49.1-KPDX

Also able to view & hear HDHomeRun-DVR recordings from last night on channels 8.1 & 10.1

Great to see real progress in this 4K beta. Congrats!

Bluehawk
Posts: 151
Joined: Wed Jul 08, 2015 1:37 pm
Device ID: 1031AB0B 103436F7 1054A790 1054B12E 1072B2F3 1317A118 1323884C
x 1

Re: ATSC 3.0 Portland: QUATRO 4K

Post by Bluehawk »

kengee1023 wrote: Fri Oct 23, 2020 2:34 pm Setup: Quatro4K Firmware 20201023, HDHomeRun app v20201023, Windows10 w/Dolby Access

Happy to report I see video & hear audio on all ATSC3 HEVC channels here in Portland,
however I only hear left speaker channel on 2.1-KATU, 6.1-KOIN, 32.1-KRCW
versus both speaker channels on 8.1-KGW, 10.1-OPB, 12.1-KPTV, 49.1-KPDX

Also able to view & hear HDHomeRun-DVR recordings from last night on channels 8.1 & 10.1

Great to see real progress in this 4K beta. Congrats!
What kind of audio gear are you using to play audio out of this PC. Would like to duplicate.

Alderem
Posts: 16
Joined: Fri Oct 23, 2020 1:48 pm
x 2

Re: ATSC 3.0 Portland: QUATRO 4K

Post by Alderem »

Received my ATSC3.0 a few weeks ago but haven't had time to play with it much. Looks like I have a few of you to thank for providing critical details to SiliconDust leading to fixes in the latest firmware, 20201021b, which I installed the other day.

I've got 50 channels when I scan (I'm on top of a big hill, so I get pretty good reception). The HEVC channels definitely take a few seconds to sync onto.

Here's my experience with this so far:

Windows 10 build 18363
HDHomeRun (MS Store): Asked me to install "HEVC Video Extensions", then WORKS GREAT for HEVC stations
VLC 3.0.11 Vetinari: No audio on HEVC stations, even after installing extensions (above)
Plex Web in Brave 1.15.76: No audio on HEVC stations

iOS 13.7
HDHomeRun (20200521): Freezes when I select HEVC stations, does not work
Plex 7.8.1: No audio on HEVC stations
Channels - Live TV 4.2.0 by Fancy Bits LLC: Plays both audio and video but EXTREMELY CHOPPY (on iPhone SE 2020).

Obviously the "no audio" situations are due to lack of AC-4 support through those apps.

Hopefully the HDHomeRun app receives an iOS update soon.

Right now, think I'll need to investigate splitting my cable between my old CONNECT and the new HDHR5-4K, and tell Plex to record the major channels through the CONNECT.

kengee1023
Posts: 3
Joined: Fri Oct 23, 2020 1:49 pm
x 1

Re: ATSC 3.0 Portland: QUATRO 4K

Post by kengee1023 »

Bluehawk wrote: Fri Oct 23, 2020 2:37 pm What kind of audio gear are you using to play audio out of this PC. Would like to duplicate.
PC audio for speakers HDMI connection from Radeon RX570 video card to Yamaha RX-V465 receiver [lacks Dolby Atmos],
and for headphones simple Logitech USB headset.

OS: Windows 10 Pro Build 19041, Dolby Access requires at least build 18362

robertbaetke
Posts: 4
Joined: Thu Oct 22, 2020 4:29 pm
x 4

Re: ATSC 3.0 Portland: QUATRO 4K

Post by robertbaetke »

Installed the latest HDHomeRun app from the Microsoft store on Windows 10 and firmware V20201023.
Able to tune all HEVC channels in Portland.
Video and audio work on all channels except 12.1 but I think that is a broadcast problem because there is a sound track, but it is low in volume and doesn't match the picture.
Anyway, this is the first release where I can finally tune and watch all of the local HEVC channels.
Nice work Nick and crew!

I can't wait for it to start working on PLEX :D

Alderem
Posts: 16
Joined: Fri Oct 23, 2020 1:48 pm
x 2

Re: ATSC 3.0 Portland: QUATRO 4K

Post by Alderem »

Just upgraded to the new firmware for the QUATRO 4K. Also got my 2 channel CONNECT back online side by side.

Looks like the new firmware initially seemed to break the display of channels styling, but now it's working fine. *shrug* not sure what that was about.

Noticed that my CONNECT picks up 54 channels, 4 more than the QUATRO 4K. Missing on QUATRO 4K (20201023), present on CONNECT (20200907):
3.1 KVDO
17.1 KWVT
27.1 KRCW
37.1 Azteca

Set Plex up to record the HEVC channels and above 4 from the CONNECT, and everything else on the QUATRO, for now.

Question: With the desktop HDHomeRun app, how do I select which device I want to use? When I first started it up with 2 devices on the network, it saw both and gave me a screen about it, but now it seems to be defaulting to the CONNECT for all channels and ignoring the QUATRO.

Bluehawk
Posts: 151
Joined: Wed Jul 08, 2015 1:37 pm
Device ID: 1031AB0B 103436F7 1054A790 1054B12E 1072B2F3 1317A118 1323884C
x 1

Re: ATSC 3.0 Portland: QUATRO 4K

Post by Bluehawk »

kengee1023 wrote: Fri Oct 23, 2020 4:04 pm
Bluehawk wrote: Fri Oct 23, 2020 2:37 pm What kind of audio gear are you using to play audio out of this PC. Would like to duplicate.
PC audio for speakers HDMI connection from Radeon RX570 video card to Yamaha RX-V465 receiver [lacks Dolby Atmos],
and for headphones simple Logitech USB headset.

OS: Windows 10 Pro Build 19041, Dolby Access requires at least build 18362
Thank You

darcilicious
Posts: 120
Joined: Thu Sep 06, 2018 3:08 pm
Location: Portland, OR
x 14

Re: ATSC 3.0 Portland: QUATRO 4K

Post by darcilicious »

Anyone know what's going on today with Portland? None of the ATSC 3.0 virtual channels are tuning; everything was working great yesterday and last night! Nothing has changed on this end...

ejohannes
Posts: 20
Joined: Mon Feb 04, 2013 6:51 pm
x 5

Re: ATSC 3.0 Portland: QUATRO 4K

Post by ejohannes »

darcilicious wrote: Tue Oct 27, 2020 5:12 pm Anyone know what's going on today with Portland? None of the ATSC 3.0 virtual channels are tuning; everything was working great yesterday and last night! Nothing has changed on this end...
I am seeing the same thing at 8:32 pm Tuesday. I have made no changes to any of my configuration. Things worked earlier, possibly even this morning.
With all of them down my guess is there must be some kind of upgrade or something going on???

Lost Dog
Posts: 123
Joined: Tue Jul 03, 2007 11:46 pm
x 2

Re: ATSC 3.0 Portland: QUATRO 4K

Post by Lost Dog »

darcilicious wrote: Tue Oct 27, 2020 5:12 pm Anyone know what's going on today with Portland? None of the ATSC 3.0 virtual channels are tuning; everything was working great yesterday and last night! Nothing has changed on this end...
As of 7:20 am I cannot tune in any either!

robbadler
Posts: 6
Joined: Mon Oct 19, 2020 8:40 pm

Re: ATSC 3.0 Portland: QUATRO 4K

Post by robbadler »

Lost Dog wrote: Wed Oct 28, 2020 7:22 am
darcilicious wrote: Tue Oct 27, 2020 5:12 pm Anyone know what's going on today with Portland? None of the ATSC 3.0 virtual channels are tuning; everything was working great yesterday and last night! Nothing has changed on this end...
As of 7:20 am I cannot tune in any either!
Same as of 8am in Sherwood

Post Reply