ATSC 3.0 Portland: QUATRO 4K

ATSC 3.0 Forum
KU7PDX
Posts: 18
Joined: Wed Jun 07, 2017 10:25 am
Device ID: 1080277F
Location: Hillsboro, Oregon, USA
x 2
Contact:

ATSC 3.0 Portland: QUATRO 4K

Post by KU7PDX »

Just got my QUATRO 4K connected here in Portland. A scan via the web interface detects neither of our two ATSC 3.0 stations and neither did they via the HDHomeRun Setup app.

I ran the HDHomeRun Config GUI and tuned it to channel 33 manually:

Image

Here's channel 30:

Image

I believe both are using Harmonic XOS encoders if that helps with troubleshooting at all.

KU7PDX
Posts: 18
Joined: Wed Jun 07, 2017 10:25 am
Device ID: 1080277F
Location: Hillsboro, Oregon, USA
x 2
Contact:

Re: ATSC 3.0 Portland: QUATRO 4K

Post by KU7PDX »

Here's the result of a scan via the command line:

Code: Select all

C:\Program Files\Silicondust\HDHomeRun>hdhomerun_config 1080277F scan 1
SCANNING: 695000000 (us-bcast:51)
LOCK: none (ss=46 snq=0 seq=0)
SCANNING: 689000000 (us-bcast:50)
LOCK: none (ss=46 snq=0 seq=0)
SCANNING: 683000000 (us-bcast:49)
LOCK: none (ss=47 snq=0 seq=0)
SCANNING: 677000000 (us-bcast:48)
LOCK: none (ss=48 snq=0 seq=0)
SCANNING: 671000000 (us-bcast:47)
LOCK: none (ss=46 snq=0 seq=0)
SCANNING: 665000000 (us-bcast:46)
LOCK: none (ss=46 snq=0 seq=0)
SCANNING: 659000000 (us-bcast:45)
LOCK: none (ss=49 snq=0 seq=0)
SCANNING: 653000000 (us-bcast:44)
LOCK: none (ss=49 snq=0 seq=0)
SCANNING: 647000000 (us-bcast:43)
LOCK: none (ss=79 snq=0 seq=0)
SCANNING: 641000000 (us-bcast:42)
LOCK: none (ss=75 snq=0 seq=0)
SCANNING: 635000000 (us-bcast:41)
LOCK: none (ss=49 snq=0 seq=0)
SCANNING: 629000000 (us-bcast:40)
LOCK: none (ss=47 snq=0 seq=0)
SCANNING: 623000000 (us-bcast:39)
LOCK: none (ss=47 snq=0 seq=0)
SCANNING: 617000000 (us-bcast:38)
LOCK: none (ss=47 snq=0 seq=0)
SCANNING: 605000000 (us-bcast:36)
LOCK: none (ss=47 snq=0 seq=0)
SCANNING: 599000000 (us-bcast:35)
LOCK: 8vsb (ss=58 snq=55 seq=100)
TSID: 0x0001
PROGRAM 1: 38.1 KORK-CD
PROGRAM 2: 38.2 KOXO-CD
PROGRAM 3: 38.3 KKEI-CD
PROGRAM 4: 38.4 KORS-CD
SCANNING: 593000000 (us-bcast:34)
LOCK: 8vsb (ss=80 snq=81 seq=100)
TSID: 0x1FED
PROGRAM 3: 47.1 KUNP-LD
PROGRAM 4: 47.2 TBD
PROGRAM 5: 47.3 Charge
SCANNING: 587000000 (us-bcast:33)
LOCK: atsc3 (ss=85 snq=100 seq=100)
SCANNING: 581000000 (us-bcast:32)
LOCK: 8vsb (ss=100 snq=100 seq=100)
TSID: 0x097F
PROGRAM 3: 24.1 TBN HD
PROGRAM 4: 24.2 Hilsong
PROGRAM 5: 24.3 SMILE
PROGRAM 6: 24.4 Enlace
PROGRAM 7: 24.5 POSITIV
SCANNING: 575000000 (us-bcast:31)
LOCK: none (ss=58 snq=0 seq=0)
SCANNING: 569000000 (us-bcast:30)
LOCK: atsc3 (ss=100 snq=100 seq=100)
SCANNING: 563000000 (us-bcast:29)
LOCK: none (ss=49 snq=0 seq=0)
SCANNING: 557000000 (us-bcast:28)
LOCK: none (ss=45 snq=0 seq=0)
SCANNING: 551000000 (us-bcast:27)
LOCK: none (ss=46 snq=0 seq=0)
SCANNING: 545000000 (us-bcast:26)
LOCK: none (ss=54 snq=0 seq=0)
SCANNING: 539000000 (us-bcast:25)
LOCK: 8vsb (ss=99 snq=91 seq=100)
TSID: 0x0977
PROGRAM 3: 6.1 KOIN-HD
PROGRAM 4: 6.2 GetTV
PROGRAM 5: 6.3 Bounce
PROGRAM 6: 32.2 Antenna
PROGRAM 7: 32.3 Courttv
PROGRAM 8: 32.4 TBD
SCANNING: 533000000 (us-bcast:24)
LOCK: 8vsb (ss=100 snq=94 seq=100)
TSID: 0x0975
PROGRAM 3: 2.1 KATU
PROGRAM 4: 2.2 MeTV
PROGRAM 5: 2.3 Comet
PROGRAM 6: 2.4 Stadium
PROGRAM 7: 32.1 KRCW
SCANNING: 527000000 (us-bcast:23)
LOCK: 8vsb (ss=74 snq=70 seq=100)
TSID: 0x0979
PROGRAM 3: 8.10 KGW
PROGRAM 4: 8.20 Crime
PROGRAM 5: 8.30 Quest
PROGRAM 6: 49.20 Escape
PROGRAM 7: 49.40 Grit
SCANNING: 521000000 (us-bcast:22)
LOCK: 8vsb (ss=100 snq=97 seq=100)
TSID: 0x0987
PROGRAM 3: 22.1 ION
PROGRAM 4: 22.2 qubo
PROGRAM 5: 22.3 IONPlus
PROGRAM 6: 22.4 Shop
PROGRAM 7: 22.5 QVC
PROGRAM 8: 22.6 HSN
PROGRAM 9: 22.7 TLMD
SCANNING: 515000000 (us-bcast:21)
LOCK: 8vsb (ss=84 snq=81 seq=100)
SCANNING: 509000000 (us-bcast:20)
LOCK: none (ss=46 snq=0 seq=0)
SCANNING: 503000000 (us-bcast:19)
LOCK: none (ss=45 snq=0 seq=0)
SCANNING: 497000000 (us-bcast:18)
LOCK: none (ss=49 snq=0 seq=0)
SCANNING: 491000000 (us-bcast:17)
LOCK: none (ss=45 snq=0 seq=0)
SCANNING: 485000000 (us-bcast:16)
LOCK: none (ss=45 snq=0 seq=0)
SCANNING: 479000000 (us-bcast:15)
LOCK: none (ss=45 snq=0 seq=0)
SCANNING: 473000000 (us-bcast:14)
LOCK: none (ss=45 snq=0 seq=0)
SCANNING: 213000000 (us-bcast:13)
LOCK: none (ss=59 snq=0 seq=0)
SCANNING: 207000000 (us-bcast:12)
LOCK: 8vsb (ss=100 snq=67 seq=100)
TSID: 0x097D
PROGRAM 3: 12.1 FOX 12
PROGRAM 4: 12.2 COZI
PROGRAM 5: 12.3 LAFF
PROGRAM 6: 12.4 DABL
PROGRAM 7: 49.1 Fox12+
PROGRAM 8: 49.3 Bounce
SCANNING: 201000000 (us-bcast:11)
LOCK: none (ss=79 snq=0 seq=0)
SCANNING: 195000000 (us-bcast:10)
LOCK: 8vsb (ss=100 snq=80 seq=100)
TSID: 0x097B
PROGRAM 3: 10.1 OPB
PROGRAM 4: 10.2 OPBPlus
PROGRAM 5: 10.3 OPBKids
PROGRAM 6: 10.4 OPB-FM
SCANNING: 189000000 (us-bcast:9)
LOCK: none (ss=61 snq=0 seq=0)
SCANNING: 183000000 (us-bcast:8)
LOCK: 8vsb (ss=100 snq=78 seq=100)
TSID: 0x0979
PROGRAM 3: 8.1 KGW
PROGRAM 4: 8.2 Crime
PROGRAM 5: 8.3 Quest
PROGRAM 6: 49.2 Escape
PROGRAM 7: 49.4 Grit
SCANNING: 177000000 (us-bcast:7)
LOCK: none (ss=56 snq=0 seq=0)
SCANNING: 85000000 (us-bcast:6)
LOCK: none (ss=78 snq=0 seq=0)
SCANNING: 79000000 (us-bcast:5)
LOCK: none (ss=74 snq=0 seq=0)
SCANNING: 69000000 (us-bcast:4)
LOCK: none (ss=70 snq=0 seq=0)
SCANNING: 63000000 (us-bcast:3)
LOCK: none (ss=71 snq=0 seq=0)
SCANNING: 57000000 (us-bcast:2)
LOCK: none (ss=70 snq=0 seq=0)
Lines of interest:

SCANNING: 587000000 (us-bcast:33)
LOCK: atsc3 (ss=85 snq=100 seq=100)


SCANNING: 569000000 (us-bcast:30)
LOCK: atsc3 (ss=100 snq=100 seq=100)


So the tuner definitely knows there is an ATSC 3.0 signal on those frequencies, but it can't seem to figure out what to do with it.

KU7PDX
Posts: 18
Joined: Wed Jun 07, 2017 10:25 am
Device ID: 1080277F
Location: Hillsboro, Oregon, USA
x 2
Contact:

Re: ATSC 3.0 Portland: QUATRO 4K

Post by KU7PDX »

This morning I made a couple of PCAP captures of RF 33 and RF 30 from my Triveni StreamScope XM, so let me know if you would like those to help with more troubleshooting. Thanks!

nickk
Silicondust
Posts: 16063
Joined: Tue Jan 13, 2004 9:39 am
x 27

Re: ATSC 3.0 Portland: QUATRO 4K

Post by nickk »

KU7PDX wrote: Tue Oct 13, 2020 9:21 am This morning I made a couple of PCAP captures of RF 33 and RF 30 from my Triveni StreamScope XM, so let me know if you would like those to help with more troubleshooting. Thanks!
Yes please - please drop me a quick PM and I will run them through our test environment here. PCAP format is perfect.

Thanks!

nickk
Silicondust
Posts: 16063
Joined: Tue Jan 13, 2004 9:39 am
x 27

Re: ATSC 3.0 Portland: QUATRO 4K

Post by nickk »

Both broadcasts are using a destination multicast IP that doesn't match the ATSC standard. The HDHomeRun blocks unknown multicast IP traffic.

I will raise the question with ATSC.

Nick

KU7PDX
Posts: 18
Joined: Wed Jun 07, 2017 10:25 am
Device ID: 1080277F
Location: Hillsboro, Oregon, USA
x 2
Contact:

Re: ATSC 3.0 Portland: QUATRO 4K

Post by KU7PDX »

Thanks Nick! Please let me know what you find out and I can contact my engineering counterparts at Meredith and Nextstar here in Portland if changes need to be made.

I do suspect that there were issues as when we originally launched, RF 33 had two PLPs (one robust and one high-bitrate) but they couldn't get televisions (Samsung Q800T in our case) to tune both of them so they went to just the robust PLP.

nickk
Silicondust
Posts: 16063
Joined: Tue Jan 13, 2004 9:39 am
x 27

Re: ATSC 3.0 Portland: QUATRO 4K

Post by nickk »

It looks like what they are doing is allowed...
All IP packets other than LLS IP packets shall carry a Destination IP address either (a) allocated and reserved by a mechanism guaranteeing that the destination addresses in use are unique in a geographic region2,or (b) in the range of 239.255.0.0 to 239.255.255.2553, where [...]

nickk
Silicondust
Posts: 16063
Joined: Tue Jan 13, 2004 9:39 am
x 27

Re: ATSC 3.0 Portland: QUATRO 4K

Post by nickk »

Update - we should have a fix out tomorrow.

Nick

nickk
Silicondust
Posts: 16063
Joined: Tue Jan 13, 2004 9:39 am
x 27

Re: ATSC 3.0 Portland: QUATRO 4K

Post by nickk »

New firmware update out.

The HDHomeRun will now detect the sub-channels correctly, however the HEVC video is missing SPS NALs so it won't play. I have a query into ATSC regarding this.

Nick

menkelis
Posts: 13
Joined: Sun Apr 15, 2018 9:09 am
x 1

Re: ATSC 3.0 Portland: QUATRO 4K

Post by menkelis »

When will the “firmware” be downloable?
It’s not in the Downloads area.

signcarver
Expert
Posts: 9231
Joined: Wed Jan 24, 2007 1:04 am
Device ID: 10802091 131B34B7 13231F92 1070A18E 1073ED6F 15300C36
x 12

Re: ATSC 3.0 Portland: QUATRO 4K

Post by signcarver »

Assuming the device has internet access, easiest is to reboot device and it will tell you there is a firmware update on it's web page. otherwise it can take up to 8 hours before it checks in with SD again.

Edit: of course it told me I had an update after doing so but it still states the old version. Unfortunately my lone ATSC 3.0 channel that I can receive is down so I can't test if it indeed has the new feature of specifying channel with plp

Edit2: my browser probably cached something and/or it just took longer to reboot then it implied as a few minutes later it was showing the new date.

menkelis
Posts: 13
Joined: Sun Apr 15, 2018 9:09 am
x 1

Re: ATSC 3.0 Portland: QUATRO 4K

Post by menkelis »

Okay, now updated.
During channel scan, I saw HEVC icons
In display while the scan is running.
When scan completed they disappeared.

I can view atsc1 channels from Config GUI
But not at atsc3 from Config GUI
Last edited by menkelis on Wed Oct 14, 2020 3:01 pm, edited 1 time in total.

signcarver
Expert
Posts: 9231
Joined: Wed Jan 24, 2007 1:04 am
Device ID: 10802091 131B34B7 13231F92 1070A18E 1073ED6F 15300C36
x 12

Re: ATSC 3.0 Portland: QUATRO 4K

Post by signcarver »

correct... from my understanding that behavior is "expected" in config gui. My suggestion would be to try tuning in VLC but if you read the notes about the update, it only detects the channels as there is some apparent missing data for the video so they still can't be played.

Also why would you expect to see an icon of an "Air Conditioner" :D

menkelis
Posts: 13
Joined: Sun Apr 15, 2018 9:09 am
x 1

Re: ATSC 3.0 Portland: QUATRO 4K

Post by menkelis »

Auto correct at its best

ejohannes
Posts: 11
Joined: Mon Feb 04, 2013 6:51 pm

Re: ATSC 3.0 Portland: QUATRO 4K

Post by ejohannes »

I just got my 4K unit today here in the Portland area.
Just to be clear, right now even with the very latest firmware, which I have loaded up, the 4K broadcast viewing is not working, correct?
I do see the atsc 3 on 33 and 30. But can't seem to tune to them. And when I try going to channel 2-1 (which has the 4k broadcast, instead it goes to 24 for the ATSC 1.0 broadcast). So there are two channels for 2.1 and the 3.0 one doesn't show up in the channel list. Which I think is what was described earlier in this discussion.

Is there any kind of ETA on when the issues maybe resolved? And will the solutions work on all the viewers like the FireTV?

Post Reply