Odd behavior first time opening slide guide.

Discussion of the new user interface for the HDHomeRun app.
leerandall
Posts: 684
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

Re: Odd behavior first time opening slide guide.

Post by leerandall » Sat Feb 15, 2020 11:35 am

So far, I like what I'm seeing with the 20200215b UI.

Thunderthud
Posts: 442
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Sat Feb 15, 2020 11:42 am

leerandall wrote:
Sat Feb 15, 2020 11:35 am
So far, I like what I'm seeing with the 20200215b UI.
I'm not. As far as the no highlight problem on the slice guide, with up on remote. Have to exit out and go into live again, to get a highlight back.

leerandall
Posts: 684
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

Re: Odd behavior first time opening slide guide.

Post by leerandall » Sat Feb 15, 2020 12:13 pm

Thunderthud wrote:
Sat Feb 15, 2020 11:42 am
leerandall wrote:
Sat Feb 15, 2020 11:35 am
So far, I like what I'm seeing with the 20200215b UI.
I'm not. As far as the no highlight problem on the slice guide, with up on remote. Have to exit out and go into live again, to get a highlight back.
I'm not seeing that anymore on my Shield. Prior to 0215b, I was seeing it nearly every time I tried to change the channel.

Thunderthud
Posts: 442
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Sat Feb 15, 2020 12:39 pm

Happened on my win 10 with 20200215b.

Also, trying to channel surfing with one slice pulled out is still a mess on my Firestick. Regular surfing is somewhat faster though, when it works.

leerandall
Posts: 684
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

Re: Odd behavior first time opening slide guide.

Post by leerandall » Sat Feb 15, 2020 12:40 pm

I just tried it on one of my Jetstream boxes and it appears to be working better there as well.

Thunderthud
Posts: 442
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Sat Feb 15, 2020 4:30 pm

It just happened in my Shield as well.

Multiple times.

Green highlight comes back if you continue to hit up several times.

If you hit down, it seems to go to lowest channel.

leerandall
Posts: 684
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

Re: Odd behavior first time opening slide guide.

Post by leerandall » Sat Feb 15, 2020 10:18 pm

I did just experience an issue on my Shield with the 0215b UI. I was watching channel 241 and pressed the down button to scroll to channel 264, and when the slice popped out, it was showing channels starting at channel 1 instead of the current channel 241. I pressed the back button to make the slice go away, and then pressed the down button again and this time the highlight was where it should be, on channel 241, and I was able to scroll down to channel 264.

mcewinter
Posts: 628
Joined: Wed Oct 14, 2009 4:36 pm
Device ID: 131044D3, 103188F3
Location: Chicago

Re: Odd behavior first time opening slide guide.

Post by mcewinter » Tue Feb 18, 2020 6:38 am

Pressing 'right' first seems to ensure that the highlight will land in the slice section. At which point it may end up at the top channel in the list, or bottom as another has reported. After over a month of this I'm beginning to navigate around the issue. No pun intended.

nateb
Silicondust
Posts: 1173
Joined: Mon Aug 06, 2018 3:22 pm
Device ID: 1051C73D, 10759F29

Re: Odd behavior first time opening slide guide.

Post by nateb » Tue Feb 18, 2020 1:01 pm

Thunderthud wrote:
Sat Feb 15, 2020 11:42 am
leerandall wrote:
Sat Feb 15, 2020 11:35 am
So far, I like what I'm seeing with the 20200215b UI.
I'm not. As far as the no highlight problem on the slice guide, with up on remote. Have to exit out and go into live again, to get a highlight back.
Yep, working on fixing this now.

Thunderthud
Posts: 442
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Tue Feb 18, 2020 1:04 pm

Thank you!

mcewinter
Posts: 628
Joined: Wed Oct 14, 2009 4:36 pm
Device ID: 131044D3, 103188F3
Location: Chicago

Re: Odd behavior first time opening slide guide.

Post by mcewinter » Tue Feb 18, 2020 3:24 pm

nateb wrote:
Tue Feb 18, 2020 1:01 pm
Thunderthud wrote:
Sat Feb 15, 2020 11:42 am
leerandall wrote:
Sat Feb 15, 2020 11:35 am
So far, I like what I'm seeing with the 20200215b UI.
I'm not. As far as the no highlight problem on the slice guide, with up on remote. Have to exit out and go into live again, to get a highlight back.
Yep, working on fixing this now.
I kinda though you already were working it, seeing that thread was created at the end of last year.

NedS
Silicondust
Posts: 820
Joined: Mon Dec 10, 2018 12:38 pm

Re: Odd behavior first time opening slide guide.

Post by NedS » Tue Feb 18, 2020 7:55 pm

mcewinter wrote:
Tue Feb 18, 2020 3:24 pm
nateb wrote:
Tue Feb 18, 2020 1:01 pm
Thunderthud wrote:
Sat Feb 15, 2020 11:42 am


I'm not. As far as the no highlight problem on the slice guide, with up on remote. Have to exit out and go into live again, to get a highlight back.
Yep, working on fixing this now.
I kinda though you already were working it, seeing that thread was created at the end of last year.
Different issues. They might sometimes show similar symptoms, but not caused by the same code/issue.

mcewinter
Posts: 628
Joined: Wed Oct 14, 2009 4:36 pm
Device ID: 131044D3, 103188F3
Location: Chicago

Re: Odd behavior first time opening slide guide.

Post by mcewinter » Wed Feb 19, 2020 9:38 am

NedS wrote:
Tue Feb 18, 2020 7:55 pm
mcewinter wrote:
Tue Feb 18, 2020 3:24 pm
nateb wrote:
Tue Feb 18, 2020 1:01 pm


Yep, working on fixing this now.
I kinda though you already were working it, seeing that thread was created at the end of last year.
Different issues. They might sometimes show similar symptoms, but not caused by the same code/issue.
So it could possibly take two more months?

Thunderthud
Posts: 442
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Thu Feb 20, 2020 4:40 pm

Seems to be ok now, at first tries. Thanks!

mcewinter
Posts: 628
Joined: Wed Oct 14, 2009 4:36 pm
Device ID: 131044D3, 103188F3
Location: Chicago

Re: Odd behavior first time opening slide guide.

Post by mcewinter » Fri Feb 21, 2020 6:25 am

Slice is much better now. Thank you!

I noticed that the bounce effect has been removed. Again, thank you!

Post Reply