Odd behavior first time opening slide guide.

Discussion of the new user interface for the HDHomeRun app.
Jimmersd
Posts: 369
Joined: Thu Jun 27, 2013 5:32 pm

Odd behavior first time opening slide guide.

Post by Jimmersd » Sat Dec 14, 2019 5:09 am

This behavior is consistent across all recent versions of the HDHR player.

After initial start of the player: When calling up the slide guide. Arrow up and down keys on Tallon remote do not move cursor to adjacent channels. At that point the cursor is positioned in the function menu on the bottom of the screen. I have to close the slide guide and reopen for this to function properly.

At the same point after starting the player: while keying in a direct access channel number on the remote, the guide always misses the second digit that is keyed in.

For both of these behaviors I can close the player app and recreate the behavior after reopening the app. I have 3 XBOX One S and this happens on all.

Version 20191209 (app) / 20191212 (UI) Xbox One S

NedS
Silicondust
Posts: 726
Joined: Mon Dec 10, 2018 12:38 pm

Re: Odd behavior first time opening slide guide.

Post by NedS » Mon Dec 16, 2019 4:03 am

Strange, I am unable to reproduce either issue on my Xbox One S when using the Talon remote, in either the stable or beta UI. I wonder if there is another variable needed, like two PRIMES instead of one, or a certain number of channels.

ZacMan
Posts: 222
Joined: Wed Feb 06, 2008 7:40 pm
Device ID: 10115FF2, 1033A485, 13106388, 13111AC9, 1060B7DD
Location: New Jersey

Re: Odd behavior first time opening slide guide.

Post by ZacMan » Mon Dec 16, 2019 5:35 am

Jimmersd wrote:
Sat Dec 14, 2019 5:09 am
This behavior is consistent across all recent versions of the HDHR player.

After initial start of the player: When calling up the slide guide. Arrow up and down keys on Tallon remote do not move cursor to adjacent channels. At that point the cursor is positioned in the function menu on the bottom of the screen. I have to close the slide guide and reopen for this to function properly.
I intermittently have this same behavior on both Shield and MiBox. It can be quite annoying at times.

nateb
Silicondust
Posts: 1164
Joined: Mon Aug 06, 2018 3:22 pm
Device ID: 1051C73D, 10759F29

Re: Odd behavior first time opening slide guide.

Post by nateb » Mon Dec 16, 2019 10:28 am

Just trying to figure out how to reproduce. Are you default starting in Live TV?

edit: reproduced it. I'm guessing you're calling up the UI using the OK button, and then trying to hit up and down to get to slice? And for some reason that only works the second time you call up slice.

Thunderthud
Posts: 422
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Sat Dec 21, 2019 11:37 am

I have same issue on MiBox and firestick. When it happens, I have to get out of live and then go back in to be able to get to slice guide with up/down press on the remote.

Again.. if you'd get rid of the progress bar when just using slice guide (where the curser lands instead of highlighting the guide), it might help. I see no purpose for the progress bar to be visible when just channel surfing. It's just a distraction.

Jimmersd
Posts: 369
Joined: Thu Jun 27, 2013 5:32 pm

Re: Odd behavior first time opening slide guide.

Post by Jimmersd » Sun Dec 22, 2019 12:53 pm

nateb wrote:
Mon Dec 16, 2019 10:28 am
Just trying to figure out how to reproduce. Are you default starting in Live TV?

edit: reproduced it. I'm guessing you're calling up the UI using the OK button, and then trying to hit up and down to get to slice? And for some reason that only works the second time you call up slice.
Cool. Yeah I am using the OK button. Sorry for the delay, I was away from the internet last week.

Bmxerbray
Posts: 27
Joined: Sat Jul 01, 2017 8:36 pm

Re: Odd behavior first time opening slide guide.

Post by Bmxerbray » Mon Dec 23, 2019 6:32 pm

Same here on
all platforms

Thunderthud
Posts: 422
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Tue Dec 24, 2019 3:28 pm

Slice guide still same problems. 20191219c.
Happens on initial entry into live. Win 10, MiBox, Firestiy. All the same. You hit up on remote, slice guide channel not hilighted. Cursor winds up highlighting rewind arrow. Merry Christmas! Sorry to be a Grinch.

steve1214
Posts: 41
Joined: Wed Mar 12, 2014 7:16 pm

Re: Odd behavior first time opening slide guide.

Post by steve1214 » Fri Dec 27, 2019 9:07 am

I am experiencing the same on both of my xbox's, glad to see im not alone.

Thanks.

Thunderthud
Posts: 422
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Wed Jan 15, 2020 2:57 pm

This is happening again. Shield hdhr version 20200114g. Hit up on remote and rewind arrow on progress bar highlighted instead of slice guide. Couldn't arrow over to slice guide. Had to exit live and go back in to get to the slice guide, with up on remote.

Thought I saw that this was fixed. hmm...

nateb
Silicondust
Posts: 1164
Joined: Mon Aug 06, 2018 3:22 pm
Device ID: 1051C73D, 10759F29

Re: Odd behavior first time opening slide guide.

Post by nateb » Wed Jan 15, 2020 3:12 pm

Thunderthud wrote:
Wed Jan 15, 2020 2:57 pm
This is happening again. Shield hdhr version 20200114g. Hit up on remote and rewind arrow on progress bar highlighted instead of slice guide. Couldn't arrow over to slice guide. Had to exit live and go back in to get to the slice guide, with up on remote.

Thought I saw that this was fixed. hmm...
Can't replicate on Shield. Both when hitting OK and then hitting up and down, and when hitting up or down with Slice dismissed. Any more info to reproduce?

leerandall
Posts: 670
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

Re: Odd behavior first time opening slide guide.

Post by leerandall » Wed Jan 15, 2020 4:58 pm

Seeing the same thing here on my Shield. After starting the app directly to Live TV, hitting either up or down on the remote pops the slice out, but the selection highlight is located on the progress bar instead of the slice.

Edit: I cannot repeat this following the exact same steps, but I know it happened the first time starting the app after updating to today's new UI. And I notice another difference in today's UI update: I can no longer use the back arrow to dismiss the slice anymore. Doing so takes me to the L/R/D/T menu screen.
Last edited by leerandall on Wed Jan 15, 2020 6:05 pm, edited 1 time in total.

Thunderthud
Posts: 422
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Wed Jan 15, 2020 5:07 pm

My wife just had a repeat experience. Was watching a live program and attempted to change channels by pressing up button on the remote and no channel was highlighted. Green cursor was on the Rew arrow of progress bar.

mcewinter
Posts: 618
Joined: Wed Oct 14, 2009 4:36 pm
Device ID: 131044D3, 103188F3
Location: Chicago

Re: Odd behavior first time opening slide guide.

Post by mcewinter » Thu Jan 16, 2020 10:04 am

I'm seeing this too. It is quite random when it occurs.

Thunderthud
Posts: 422
Joined: Sun Apr 12, 2015 6:59 am
Device ID: 1322B8A6, 13257C3D, 1041CFDB, 10514020
Location: Virginia

Re: Odd behavior first time opening slide guide.

Post by Thunderthud » Sat Jan 18, 2020 8:07 am

Still happening, MiBox. HDHR Version 20200117

Post Reply