New Interface - Lag

Discussion of the new user interface for the HDHomeRun app.
Jimmersd
Posts: 301
Joined: Thu Jun 27, 2013 5:32 pm

New Interface - Lag

Post by Jimmersd » Thu Jul 18, 2019 4:36 am

The new interface has a substantial lag between button push and function being displayed on live TV when using a remote. I am using an XBox One.

When the enter button is pressed on the Xbox remote it take about 2~3 seconds for the channel guide to slide out. Once it does then I can scroll up and down but there still is a small pause on each channel while it displays an arrow that points to the right, This feature is a minor irritant I understand the desire to include this type of prompt (the arrow) but there should be a way to disable it.

When in the Live|Recordings|Discover|Tasks menu the cursor moves freely but when I select Live there is also a substantial delay (5 seconds) before the screen changes to the live TV feed.

On a positive note the XBox One now accepts direct channel input using the number keys from the remote. But there is also a substantial lag before the guide slides out to display the selection.

jasonl
Silicondust
Posts: 14067
Joined: Sun Oct 28, 2007 9:23 pm

Re: New Interface - Lag

Post by jasonl » Thu Jul 18, 2019 3:40 pm

We are investigating the responsiveness issues on Xbox One.

GGRussell
Posts: 1346
Joined: Mon Dec 31, 2012 3:08 pm
Device ID: 131F5AA2 ; 1325E5E9

Re: New Interface - Lag

Post by GGRussell » Thu Jul 18, 2019 5:26 pm

I noticed same thing this evening using Harmony remote with XBox. At first thought the remote wasn't working at all.

leop
Posts: 18
Joined: Tue Feb 07, 2017 12:59 pm

Re: New Interface - Lag

Post by leop » Thu Jul 18, 2019 7:41 pm

I also see a lag when viewing on a Windows 10 machine. I liked the former UI much better as the guide fonts and images were smaller and clicking on the title of the viewed show gave a description. The only description on the current UI is from the guide listing on the side and that description is truncated.

LP

MoeDee
Posts: 16
Joined: Wed Mar 02, 2016 5:10 am
Location: USA

Re: New Interface - Lag

Post by MoeDee » Sat Jul 20, 2019 9:37 am

I also experience huge lag times on Xbox one S for channel selection.. (up and down)
using either Remote or Game Controller.

I wonder whether it has to do with the guide details to be loaded - I have a quattro and a prime, so there is a lot of channels and guide data..

Jimmersd
Posts: 301
Joined: Thu Jun 27, 2013 5:32 pm

Re: New Interface - Lag

Post by Jimmersd » Wed Jul 24, 2019 5:57 pm

Just got 20190723.

The slide out is faster and channel change is less laggy. Still a little slow. Definitely an improvement.

But when I return to Live from the Live/Recorded/Discover/Tasks menu the live channel is blank with no video/audio I can access the slideout but I cannot just hit the channel it is on to reload. I have to select a different channel and return to the first.

Still no search by network call sign (sigh).

Jimmersd
Posts: 301
Joined: Thu Jun 27, 2013 5:32 pm

Re: New Interface - Lag

Post by Jimmersd » Fri Jul 26, 2019 5:26 am

... also when I return to live TV after watching a recording. While there is no Audio/Video, the lower function bar continues to display the name of the recorded program that I was watching.

3579mike777
Posts: 39
Joined: Mon Sep 03, 2012 5:10 pm

Re: New Interface - Lag

Post by 3579mike777 » Fri Jul 26, 2019 1:49 pm

20190723 is when all the lag/guide issues started, mainly with an android box as the DVR player, but also with Windows 10. This would drive people that change channels a lot absolutely nuts. Even if you want to switch between two channels, it is painfully slow.

leerandall
Posts: 556
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

Re: New Interface - Lag

Post by leerandall » Fri Jul 26, 2019 2:38 pm

On my Android TV box (Shield), once you have the slice pulled out, it's as fast as you'd want it to change channels, in my experience. But it takes between 3 and 5 seconds from the time you press up or down on the remote until the slice slides out so you can actually scroll to change channels. That's irritating as hell.

tonyimp0707
Posts: 5
Joined: Fri Jul 26, 2019 7:58 pm

Re: New Interface - Lag

Post by tonyimp0707 » Fri Jul 26, 2019 8:19 pm

Please revert back. The new UI is not ready.

Jimmersd
Posts: 301
Joined: Thu Jun 27, 2013 5:32 pm

Re: New Interface - Lag

Post by Jimmersd » Sat Jul 27, 2019 4:12 am

Updated to 20190726

Lag is better, there is still about a 5 second lag the first time the guide is opened but after that it is less than 3 seconds. Scrolling up and down better. Blank screen on return to live TV is resolved.

I think the way that each channel bounces out if you pause any longer than a heart beat while scrolling up isn't really necessary or should be delayed for a real pause, like a second or more...

Jimmersd
Posts: 301
Joined: Thu Jun 27, 2013 5:32 pm

Re: New Interface - Lag

Post by Jimmersd » Tue Jul 30, 2019 5:15 pm

I really seems to be getting slower with the 20190726 version.

Jimmersd
Posts: 301
Joined: Thu Jun 27, 2013 5:32 pm

Re: New Interface - Lag

Post by Jimmersd » Wed Jul 31, 2019 4:35 am

20190729d

First button push after opening app, 6~7 seconds. After that much quicker less than 2 seconds. Still a lag though. Might be an issue with network connectivity.

nateb
Silicondust
Posts: 962
Joined: Mon Aug 06, 2018 3:22 pm
Device ID: 1051C73D, 10759F29

Re: New Interface - Lag

Post by nateb » Wed Jul 31, 2019 10:11 am

Those of you experiencing lag, are you all using the Prime and/or do you have more than 50 or 60 channels? Anyone seeing this lag exclusively with OTA?

Jimmersd
Posts: 301
Joined: Thu Jun 27, 2013 5:32 pm

Re: New Interface - Lag

Post by Jimmersd » Wed Jul 31, 2019 11:25 am

I have 2 Primes and a Quatro with the DVR running on a Synology DS415+ NAS. Everything is connected CAT5 through Ubiquiti equipment. ( ER-4 and TS-8 Pro )

Post Reply