[solved] Win10 - Protected Channels not working with UEFI Enabled BIOS

Downloads & Instructions
Post Reply
Posts: 157
Joined: Tue May 27, 2014 2:42 pm
Location: Seattle Area
x 1

[solved] Win10 - Protected Channels not working with UEFI Enabled BIOS

Post by scyto »

Hi, maybe this has already been addressed - if so i apologize but i never found this fix easily on this site, but i had followed all the requisites of creator edtion + mpeg 2 from store and enabled UEFI in BIOS and still could not get the protected channels to play.

Turned out that while UEFI was enabled in BIOS windows 10 was installed in legacy mode. This happens if your OS was installed before UEFI was enabled or sometimes if you had BIOS set to compatibility mode i.e BIOS first UEFI second boot orders etc when the original install (in my case this was because my original install was actually windows 7 on a different mobo! yes i have done ~100 build to build upgrades since then, anywho, back to the plot).

This used to require a complete re-install but can now easily be corrected thanks to a new MS tool called MBR2GPT available in the creators update.
  1. to check if your win10 is in legacy or UEFI mode run msinfo32 and look at the bios mode section in system summary
    if it says UEFI this won't fix for you, if it says legacy these steps will work. (note you still need to meet the other requirements about HDCP etc)
  2. You are going to need covert your install from an MBR to GPT install
  3. Luckily there is an official way to do this in windows 10 creator update and beyond. https://docs.microsoft.com/en-us/window ... mbr-to-gpt
  4. Requires latest winpe - get from 1703 version of ADK (do not use any other version, only ever use official MS winpe, not ones you find on interwebs) https://developer.microsoft.com/en-us/w ... oyment-kit
  5. use these winpe creation instructions: https://docs.microsoft.com/en-us/window ... able-drive
  6. if you hit error -2147212243 with the makewinpemedia command use this fix https://www.virtualizationhowto.com/201 ... 147212243/
    remember to change the drive letter in the command from f: to p: if you followed exactly the steps in step 5 - also pay attention to using the x86 or amd64 - i reccomend using the latter - so change the line in this manual copy as needed
conversion takes 2 mins, longest thing is downloading the winpe and making the winpe bootable USB key!

Good luck and remember backup before you do this, this is messing with your disks.
Last edited by scyto on Sun Jul 30, 2017 4:19 pm, edited 4 times in total.

Posts: 16757
Joined: Tue Jan 13, 2004 9:39 am
x 88

Re: [solved] Win10 - Protected Channels not working with UEFI Enabled BIOS

Post by nickk »

Good write up - thanks!

I have moved it to the Instructions forum.


Posts: 190
Joined: Sat Jun 25, 2016 6:45 am

Re: [solved] Win10 - Protected Channels not working with UEFI Enabled BIOS

Post by RF2016 »


I just wanted to follow up to scyto's great posting on UEFI conversion, and also just mention you can convert the Windows Creators Update, to UEFI from with the running OS. this will eliminate the need to create a Boot USD WINPE.

Open a Command Prompt Window, with "Run as Administrator"

validate disk
The line option for this is mbr2gpt /allowfullos /validate /disk:0


mbr2gpt /convert /disk: n /allowfullOS
This will convert, and once the conversion has been performed , reboot, enter the BIOS and switch the BIOS to UEFI, save the BIOS settings, and WA LA, boot into Windows with UEFI.

Posts: 13
Joined: Tue Jun 02, 2015 6:40 pm

Re: [solved] Win10 - Protected Channels not working with UEFI Enabled BIOS

Post by srieker »

Recently made a first attempt at DRM play on a Windows 10 Intel NUC5i5 PC. Followed the suggested procedure re: changing drive from MBR2GPT, which ran successfully without disturbing the Windows partition software. Was then still getting HDCP errors on Spectrum DRM channels indicating a broken HCDP chain. Was running through a Marantz HT reciever from the NUC mini-HDMI output/ Tried running directly from the mini output to a desktop monitor HDMI input using a mini-to-HDMI adapter cable. Still no DRM channels. All those components are 2012-13 vintage, HDMI 1.4a or b standard.

Happened to have a mini-DisplayPort to HDMI adapter on hand, so tried using the NUC5 mini-DP output rather than the mini-HDMI.

Bingo--now have DRM play capability the the HDHomerun software !!

Whether non-HDCP compatability is a characteristic of all mini-HDMI outputs or just in the NUC5 model is inknown. I believe that Intel switched to full-size HDMI outputs with the series 6 NUCs and beyond, perhaps because of that incompatibility. The mini-DP port is only version 1.2, but it did work, apparently with sufficient speed to handle HD video without any issues.

Post Reply