QNAP QPKG for DVR Record Engine

Downloads & Instructions
Post Reply
demonrik
Posts: 1346
Joined: Mon May 04, 2015 10:03 am
Device ID: 10736454, 1073A35A, 1075C377, 108042A1
x 8

Re: QNAP QPKG for DVR Record Engine

Post by demonrik »

Heads up if you install latest 4.5.1.1456 firmware
For some reason QNAP basically flags unsigned applications in the App Center, and now only allows you to REMOVE the application.. so no ability to stop/start the HDHomeRunDVR package :(

Here's the workaround.. is not great, but works.
Hopefully they will fix the issue and I can drop this, if they don't I'll add to OP.

Workaround is to start/stop via Qboost
Open Qboost and you should have dialog presented like
Image
then select the dots over on the bottom right to drop down the list of apps, e.g.
Image
The right column has a bunch of icons for actions.. These are what we care about, i.e.
Image
The top one above has a play icon to start it, while others have a stop symbol to stop them.
Use these to control the app when a new engine is made available.

OR you can use new command console..
SSH to the NAS as admin and you can select app management, find the app, and the start/stop/restart from the console.
Or as other priviledged user use the command qpkg_service to start/stop the service, e.g.

Code: Select all

qpkg_service start HDHomeRunDVR

Rew452
Posts: 245
Joined: Wed Nov 23, 2011 1:18 pm

Re: QNAP QPKG for DVR Record Engine

Post by Rew452 »

New firmware 4.5.1.1465 corrects this issue, 2020/10/24
It still flags the apps without digital-signature but again peovides for Stop/Start.

Rew

demonrik
Posts: 1346
Joined: Mon May 04, 2015 10:03 am
Device ID: 10736454, 1073A35A, 1075C377, 108042A1
x 8

Re: QNAP QPKG for DVR Record Engine

Post by demonrik »

Rew452 wrote: Fri Oct 30, 2020 2:16 pm New firmware 4.5.1.1465 corrects this issue, 2020/10/24
It still flags the apps without digital-signature but again peovides for Stop/Start.

Rew
thanks for the heads up - will make it a little easier :)

likeaw
Posts: 22
Joined: Wed Nov 16, 2011 11:13 am

Re: QNAP QPKG for DVR Record Engine

Post by likeaw »

QNAP had released firmware 4.5.1.1480. I updated my NAS to this version as well as the latest HDHomeRunDVR engine so could try my 4k tuner. Lost my recording schedule for some reason and was giving me log error that could not create directory. See Log:

20201111-23:59:30 Recording: current time = Wed Nov 11 23:59:30 2020 (correction of 1s)
20201111-23:59:30 Recording: event Rick Steves' Europe S10E12 20181222 [20201111-2300] already ended
20201111-23:59:30 Recording: event FOX 4 News at 6 20051004 [20201112-0000] creating new worker
20201111-23:59:30 Recording: event NOVA S42E05 20150218 [20201112-0200] in future
20201111-23:59:30 Recording: next timer event in 0h31m00s
20201111-23:59:30 Recording: sending request to 10463E3A at 10.10.10.40 for FOX 4 News at 6 20051004 [20201112-0000]
20201111-23:59:30 Recording: failed to create dir for FOX 4 News at 6 20051004 [20201112-0000]

BTW FOX 4 should be broadcasting in 4K here in DFW and need to read the posts Connect 4K on that part of board. Reboot may have fixed record at this point for channels other then FOX 4. Will continue to read other posts and check back with more data later. I have a Quattro as well as the 4K tuner. 8 tuners total...well 10 as have old Connect that I disconnected at this time.

BTW 2 QNAP TS431P took about 5-7 minutes to stop the DVR engine..(thought it was hung but waited it out) and reboot was about 15- 20 minutes (way too long). Seems like changing channels takes longer also. Guess that is the cost of progress.

demonrik
Posts: 1346
Joined: Mon May 04, 2015 10:03 am
Device ID: 10736454, 1073A35A, 1075C377, 108042A1
x 8

Re: QNAP QPKG for DVR Record Engine

Post by demonrik »

likeaw wrote: Wed Nov 11, 2020 7:47 pm QNAP had released firmware 4.5.1.1480. I updated my NAS to this version as well as the latest HDHomeRunDVR engine so could try my 4k tuner. Lost my recording schedule for some reason and was giving me log error that could not create directory. See Log:

20201111-23:59:30 Recording: current time = Wed Nov 11 23:59:30 2020 (correction of 1s)
20201111-23:59:30 Recording: event Rick Steves' Europe S10E12 20181222 [20201111-2300] already ended
20201111-23:59:30 Recording: event FOX 4 News at 6 20051004 [20201112-0000] creating new worker
20201111-23:59:30 Recording: event NOVA S42E05 20150218 [20201112-0200] in future
20201111-23:59:30 Recording: next timer event in 0h31m00s
20201111-23:59:30 Recording: sending request to 10463E3A at 10.10.10.40 for FOX 4 News at 6 20051004 [20201112-0000]
20201111-23:59:30 Recording: failed to create dir for FOX 4 News at 6 20051004 [20201112-0000]

BTW FOX 4 should be broadcasting in 4K here in DFW and need to read the posts Connect 4K on that part of board. Reboot may have fixed record at this point for channels other then FOX 4. Will continue to read other posts and check back with more data later. I have a Quattro as well as the 4K tuner. 8 tuners total...well 10 as have old Connect that I disconnected at this time.

BTW 2 QNAP TS431P took about 5-7 minutes to stop the DVR engine..(thought it was hung but waited it out) and reboot was about 15- 20 minutes (way too long). Seems like changing channels takes longer also. Guess that is the cost of progress.
failed to create dir can be a permissions issue or something else in the engine
If you got it working after - was it a recording of an existing series (i.e. you have previous 5recordings of the show) or a brand new series
i.e. you may still have the issue of creating folders in the recordpath for new shows

check 2 things
1. Open File Station, and select your record path folder in the explorer pane on the left. Right click and select Properties.. What are the owner and group set as? Select the Permissions Tab - what are the permissions?
Ideally you want hdhomerundvr as owner with administrators as group
2. open control panel -> privilege -> shared folders.. select your share for the recordpath and click on 'edit shared folder permission' on the right (middle icon typically). should list admin and hdhomerundvr both with read/write permissions.. fix if necessary

likeaw
Posts: 22
Joined: Wed Nov 16, 2011 11:13 am

Re: QNAP QPKG for DVR Record Engine

Post by likeaw »

demonrik wrote: Wed Nov 11, 2020 9:52 pm
likeaw wrote: Wed Nov 11, 2020 7:47 pm QNAP had released firmware 4.5.1.1480. I updated my NAS to this version as well as the latest HDHomeRunDVR engine so could try my 4k tuner. Lost my recording schedule for some reason and was giving me log error that could not create directory. See Log:

20201111-23:59:30 Recording: current time = Wed Nov 11 23:59:30 2020 (correction of 1s)
20201111-23:59:30 Recording: event Rick Steves' Europe S10E12 20181222 [20201111-2300] already ended
20201111-23:59:30 Recording: event FOX 4 News at 6 20051004 [20201112-0000] creating new worker
20201111-23:59:30 Recording: event NOVA S42E05 20150218 [20201112-0200] in future
20201111-23:59:30 Recording: next timer event in 0h31m00s
20201111-23:59:30 Recording: sending request to 10463E3A at 10.10.10.40 for FOX 4 News at 6 20051004 [20201112-0000]
20201111-23:59:30 Recording: failed to create dir for FOX 4 News at 6 20051004 [20201112-0000]

BTW FOX 4 should be broadcasting in 4K here in DFW and need to read the posts Connect 4K on that part of board. Reboot may have fixed record at this point for channels other then FOX 4. Will continue to read other posts and check back with more data later. I have a Quattro as well as the 4K tuner. 8 tuners total...well 10 as have old Connect that I disconnected at this time.

BTW 2 QNAP TS431P took about 5-7 minutes to stop the DVR engine..(thought it was hung but waited it out) and reboot was about 15- 20 minutes (way too long). Seems like changing channels takes longer also. Guess that is the cost of progress.
failed to create dir can be a permissions issue or something else in the engine
If you got it working after - was it a recording of an existing series (i.e. you have previous 5recordings of the show) or a brand new series
i.e. you may still have the issue of creating folders in the recordpath for new shows

check 2 things
1. Open File Station, and select your record path folder in the explorer pane on the left. Right click and select Properties.. What are the owner and group set as? Select the Permissions Tab - what are the permissions?
Ideally you want hdhomerundvr as owner with administrators as group
2. open control panel -> privilege -> shared folders.. select your share for the recordpath and click on 'edit shared folder permission' on the right (middle icon typically). should list admin and hdhomerundvr both with read/write permissions.. fix if necessary
Thanks for getting back with me so quickly. I think this is a 4K tuner issue. I ended up having to unplug it. I could not disable the problem channel on the 4K tuner as kept getting error on device I was watching. As long as it (Connect 4K) was online could not watch HEVC channel.

Post Reply