Audio / Video keeps losing synch

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Peacock
Posts: 5
Joined: Thu Aug 05, 2021 7:06 am

Re: Audio / Video keeps losing synch

Post by Peacock »

nickk wrote: Mon Aug 02, 2021 5:51 pm Roughly how long does it take before you start to notice it?

If you can, try side-loading the latest app release: https://download.silicondust.com/hdhome ... ndroid.apk

Nick
I'm having similar issues with my Quatro and 4K Fire Stick. I side-loaded 20210728 but the sync issues persist.

However if I use the HDHR through Plex on my 4K Fire Stick everything works normally. Other Android devices are unaffected.

Running all the latest firmwares, os', etc.

walkerx
Posts: 48
Joined: Sat May 15, 2021 8:41 am
x 1

Re: Audio / Video keeps losing synch

Post by walkerx »

I have two NVidia Shield TV Pro's - one a 2015 model and the other is a 2019 model and a 2017 Apple TV 4K. I use the Quatro and based in UK and have audio sync issues on all devices, but if I watch live TV on the TV directly I have no problems, the audio is in sync. This doesn't just happen with the SD app, but also Channels DVR, Plex and Emby.

It's also not with all broadcasts either, so has to be something to do with certain ones and sometimes like others have said it gets worse overtime while watching.

Not sure if the SD app goes straight to the tuner and receives the channels from that or if it goes via my server first. If I watch any other media from my server or internet I have no issues with audio being out of sync.

I have thought about moving my server closer to the Quatro, but as this is sending data out via IP, I shouldn't need to and should not have issues. I'm also using a wired connection.

walkerx
Posts: 48
Joined: Sat May 15, 2021 8:41 am
x 1

Re: Audio / Video keeps losing synch

Post by walkerx »

nickk wrote: Sun Jun 06, 2021 10:38 pm Make sure you are using the latest version of the HDHomeRun app. The A/V sync problem was fixed and the app re-released.

Nick
I've just tested on 2 Nvidia Shield TV's, both playing the same channel using the Quatro with firmware 20210624

Virtual Channel 102 BBC TWO HD
Frequency 634.000 MHz
Program Number 17472
Modulation Lock t8dvbt2
Signal Strength 90%
Signal Quality 100%
Symbol Quality 100%
Streaming Rate 3.853 Mbps

On my 2015 Pro the audio is currently in sync, but on the 2019 Pro it is out of sync, both running 20210728 (App) / 20210722 (UI) - both are hardwired connections, ac3 passthrough disabled on both. The 2019 Pro is connected via a Marantz NR1711 to a LG 55" TV while the 2015 Pro is connected directly to a LG 43" TV.

The DVR is on a linux based PC and I've copied the mpg to local computer and this is playing without any audio issues

Update: tested on xbox one x wired connection (connected via avr) and the audio seems fine, still testing on the apple tv wired connection and using an samsung tab s6 works fine, but the shield connected via the avr definitely has audio sync issues

dr_glove
Posts: 1
Joined: Thu Aug 12, 2021 9:37 am

Re: Audio / Video keeps losing synch

Post by dr_glove »

I'm having the same issue on both my fire cubes. It makes the HDHomeRun app unwatchable.

nickk
Silicondust
Posts: 17282
Joined: Tue Jan 13, 2004 9:39 am
x 94

Re: Audio / Video keeps losing synch

Post by nickk »

Please side load the latest app: https://download.silicondust.com/hdhome ... ndroid.apk

We submitted this update to Amazon a few weeks ago but it takes Amazon about 3 weeks to approve anything. Not impressed with Amazon.

walkerx
Posts: 48
Joined: Sat May 15, 2021 8:41 am
x 1

Re: Audio / Video keeps losing synch

Post by walkerx »

nickk wrote: Thu Aug 12, 2021 10:53 am Please side load the latest app: https://download.silicondust.com/hdhome ... ndroid.apk

We submitted this update to Amazon a few weeks ago but it takes Amazon about 3 weeks to approve anything. Not impressed with Amazon.
this is not just amazon products affected, the nvidia shield is also affected, both 2015 Pro and 2019 Pro, I've now setup two xbox's to test with and both are working fine, no audio sync issues at all and both are running the latest version 20210728

Not sure why these are working on the same network, in the same locations as the shield tvs and also the tablets work fine, it just seems whatever build has been released for the android tv's is messed up and is currently holding me off from buying another unit

Peacock
Posts: 5
Joined: Thu Aug 05, 2021 7:06 am

Re: Audio / Video keeps losing synch

Post by Peacock »

nickk wrote: Thu Aug 12, 2021 10:53 am Please side load the latest app: https://download.silicondust.com/hdhome ... ndroid.apk

We submitted this update to Amazon a few weeks ago but it takes Amazon about 3 weeks to approve anything. Not impressed with Amazon.
Amazon not updating their app store fast enough doesn't seem to be the problem. I've just side-loaded 20210813 and the sync issues persist.

This is now the 3rd or so manual app install I've done and the sync issues have gotten worse. Before it would slowly go out of sync but now it's out of sync as soon as I start streaming.

At this point I might have better luck side-loading an older copy of the app.

nickk
Silicondust
Posts: 17282
Joined: Tue Jan 13, 2004 9:39 am
x 94

Re: Audio / Video keeps losing synch

Post by nickk »

Can you please turn on "send diagnostic information" from within the HDHomeRun app and then post back with the Device ID of your HDHomeRun.

Nick

Peacock
Posts: 5
Joined: Thu Aug 05, 2021 7:06 am

Re: Audio / Video keeps losing synch

Post by Peacock »

nickk wrote: Mon Aug 16, 2021 2:52 pm Can you please turn on "send diagnostic information" from within the HDHomeRun app and then post back with the Device ID of your HDHomeRun.

Nick
Diagnostics on.

10797D14 CONNECT QUATRO

nickk
Silicondust
Posts: 17282
Joined: Tue Jan 13, 2004 9:39 am
x 94

Re: Audio / Video keeps losing synch

Post by nickk »

Peacock wrote: Tue Aug 17, 2021 2:23 pm Diagnostics on.
10797D14 CONNECT QUATRO
Looks like PCM output to an AV receiver.

The Fire OS is reporting that the audio output latency is 324ms which seems high.

On the Fire TV go into Settings, Display & Sounds, Audio, AV Sync Tuning to test and set the delay.

Nick

Peacock
Posts: 5
Joined: Thu Aug 05, 2021 7:06 am

Re: Audio / Video keeps losing synch

Post by Peacock »

nickk wrote: Tue Aug 17, 2021 4:47 pm
Peacock wrote: Tue Aug 17, 2021 2:23 pm Diagnostics on.
10797D14 CONNECT QUATRO
Looks like PCM output to an AV receiver.

The Fire OS is reporting that the audio output latency is 324ms which seems high.

On the Fire TV go into Settings, Display & Sounds, Audio, AV Sync Tuning to test and set the delay.

Nick
The delay that literally only happens in the HD app?

Netflix, Plex, YouTube, HBO etc all work perfectly fine with no lag. If I manually adjust a delay in the firestick settings every other app goes out of sync.

This has only been a problem in recent months after having the exact same hardware setup for years.

The one thing I've noticed is the sync gets worse when I change channels. If I reboot the firestick and load HD the first channel that comes up is usually in sync, then when I start changing channels it goes out of sync.

Manually adjusting a delay won't correct this behavior.

nickk
Silicondust
Posts: 17282
Joined: Tue Jan 13, 2004 9:39 am
x 94

Re: Audio / Video keeps losing synch

Post by nickk »

Peacock wrote: Tue Aug 17, 2021 6:45 pm The one thing I've noticed is the sync gets worse when I change channels. If I reboot the firestick and load HD the first channel that comes up is usually in sync, then when I start changing channels it goes out of sync.
Very odd. I ran a test this morning on a Fire TV Stick 4K - audio was still in sync after 50 channel changes.

fracarvic
Posts: 2
Joined: Thu Aug 19, 2021 8:29 am

Re: Audio / Video keeps losing synch

Post by fracarvic »

I have the same problem from a few months with the app on my Fire TV Cube 2nd. Gen.

I start the app and audio stay in sync, when I change channels audio gets out of sync until I close and start the app. Only get audio sync on the start of the app, before any channel change.

I send diagnostics on device ID 1241199F.

My connections are : Fire TV <--- hdmi ----> LG TV <--- hdmi arc ---- > Denon heos bar.

All other apps works perfectly in sync, the problem only happens in hdhomerun app in FireTv. Android mobile and windows apps works perfectly.

nickk
Silicondust
Posts: 17282
Joined: Tue Jan 13, 2004 9:39 am
x 94

Re: Audio / Video keeps losing synch

Post by nickk »

Hi fracarvic,

Thanks for enabling debug information. The Fire OS is sometimes reporting the audio output latency as 50ms and sometimes as 312-313ms.

Investigating...

Nick

nickk
Silicondust
Posts: 17282
Joined: Tue Jan 13, 2004 9:39 am
x 94

Re: Audio / Video keeps losing synch

Post by nickk »

We identified and fixed an AV sync issue on FireTV - can you please sideload the new release:
https://download.silicondust.com/hdhome ... ndroid.apk

Nick

Post Reply