Weird Issues with Playing Recordings After Upgrading to Connect 4K

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
KevinM
Posts: 3
Joined: Thu Jul 16, 2020 11:12 am

Weird Issues with Playing Recordings After Upgrading to Connect 4K

Post by KevinM »

Hello,

Last week I swapped out my old HDHR Extend for the new Connect 4K. I am having issues with certain recordings, but only within the HDHomerun view app on my HTPC which is connected to an AVR. Everything plays back flawlessly on devices like my phone/iPad, and they also play fine in other apps on the HTPC such as VLC or Windows Movies & TV. I have not figured out exactly which recordings are affected... I think it may be related to which tuner they recorded on. I am in the Washington DC market where, to my knowledge, no channels are yet on the air with ATSC 3.0.

Here's how the issue plays out: When I open an affected recording, I see either a black screen or the first frame of the program. It sticks on this image. No audio plays. If I do something to force my PC to reset its connection with the AVR (e.g. unplug/replug the HDMI, or switch the default output device in windows to something other than the AVR and then back), the video will start playing with proper Dolby Digital audio. I have to repeat this process for EVERY affected recording.

Disabling native audio passthrough or disabling Exclusive Mode on the audio device within Windows prevents this problem, however, I lose Dolby Digital surround when I do this which I certainly don't want to do. As I mentioned earlier, I have tested the exact same affected recordings in VLC and Windows Movies & TV and they play perfectly fine, including the proper DD audio.

NedS
Silicondust
Posts: 1888
Joined: Mon Dec 10, 2018 12:38 pm
x 63

Re: Weird Issues with Playing Recordings After Upgrading to Connect 4K

Post by NedS »

We would like to get some diagnostic data:
  1. Please go to the http://my.hdhomerun.com/ site
  2. Click your HDHomeRun's device ID
  3. Click System Status
  4. Check the Send diagnostic information box
  5. Go back one page
  6. Click Channel Lineup
  7. Click on Detect Channels
  8. After the scan finishes, open the HDHomeRun app
  9. Go into the app settings: the gear icon in the top right corner of the "Live/Recorded/Discover/Tasks" page
  10. Enable the option to "Send diagnostic information"
  11. Watch a channel with your normal audio settings (where things don't work)

Reply back to this post and provide us the device ID of your HDHomeRun and we will check the logs. You can find the device ID at the top of the my.hdhomerun.com web page as well as on a label on the bottom of the HDHomeRun itself.

KevinM
Posts: 3
Joined: Thu Jul 16, 2020 11:12 am

Re: Weird Issues with Playing Recordings After Upgrading to Connect 4K

Post by KevinM »

Just completed all the steps. Device ID: 10815C51

You will notice that I am on a beta version of the app. I only enabled that yesterday to see if my issue had been resolved in a beta build. The issue exists in both the current stable version and the beta.

Post Reply