Win 10 client can't see Synology Record engine

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
ppasteur
Posts: 80
Joined: Thu Sep 05, 2019 3:54 pm
x 3

Win 10 client can't see Synology Record engine

Post by ppasteur »

This is a peculiar problem. I have been using a Synology DS918+ for over a year to run the HDHR record engine. Everything has worked fine. It runs the 20200907 version of the software. I believe that this is current for that system. I also have two Nvidia Shields running record engines. Long story, but I run the Synology through a VPN from time to time, so I wanted a record engine available locally. So I setup the Shields.
Recently, the client on my most used PC will not see recordings on the Synology NAS. I am using the 20210102 version of the client on Win 10 20H2. The Synology is plugged into the same switch as the PC. I can transfer files and ping in either direction. I use a web browser from the machine in question to manage the Synology regularly. So communications between the devices is solid.

Other clients, including Win 10, Shield, Fire tablet, all "see" the Synology record engine and show all of the recordings. MyHDHomerun.com identifies the record engine correctly.
The machine in question will startup and shows the list of devices discovered. It says that it sees 6. It lists the three tuners and the 2 Shield record engines, pauses for about 8 seconds, but never lists the Synology. It then starts normally, but recordings that are only stored on the Synology are not listed.

I am aware that the problem is machine specific. I have uninstalled and reinstalled the app several times. I have used downloads from the HDHomerun web site as well as from the MS store. I have rebooted both the PC and even the DS918+ on several occasions. So the question is, can anyone think of something else I can try? Is the device list stored somewhere that I can find it and delete it (hoping it would rebuild it correctly)? Any known issues with the "old" version of the Synology record engine that I am using (20200907)?

This is not the end of the world, but it is something that is aggravating me and I want to fix it.

Thanks,
Phil

ppasteur
Posts: 80
Joined: Thu Sep 05, 2019 3:54 pm
x 3

Re: Win 10 client can't see Synology Record engine

Post by ppasteur »

I set the Windows client to send diagnostic information. Can someone at SD look at it, please?
If more data is needed, do let me know. I would like to get this going. I am happy to take an active part in troubleshooting,

Phil

jasonl
Expert
Posts: 15562
Joined: Sun Oct 28, 2007 9:23 pm
x 36

Re: Win 10 client can't see Synology Record engine

Post by jasonl »

If you're using a static IP on anything, make sure the subnet mask exactly matches what is in use elsewhere. Even the slightest mismatch could cause issues with discovery. Also check to see if the Synology firewall got turned on.

Spar
Posts: 7
Joined: Fri Sep 21, 2018 5:59 pm

Re: Win 10 client can't see Synology Record engine

Post by Spar »

I know personally that when I am running a VPN on my network, hdhomerun does not play well with my Synology 918+. I never figured out split tunneling the VPN to work around the problem, just switched my VPN tasks to run through a laptop. It is my understanding that HDHomerun needs to run on the same network and using the VPN will change that visibility making it seeing your server to clients problematic.

Post Reply