App stopped working on Kindle Fire HDX 7"

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
Lupo
Posts: 15
Joined: Fri Apr 20, 2018 9:51 am
x 1

App stopped working on Kindle Fire HDX 7"

Post by Lupo »

After the latest automatic (!) update, the app fails to start on my Kindle Fire HDX 7".

Error message:
"Unsupported device. The application failed to load native libraries."

Could you please fix this? Thank you!

TJ1
Posts: 2
Joined: Thu Nov 19, 2020 5:33 pm

Re: App stopped working on Kindle Fire HDX 7"

Post by TJ1 »

Hi. I have the same problem. Recently started getting the same error, "The application failed to load native libraries."
My device is a Samsung Galaxy Tab Pro (2014/2015 model) with Android version 4.4.2.

nickk
Silicondust
Posts: 16226
Joined: Tue Jan 13, 2004 9:39 am
x 72

Re: App stopped working on Kindle Fire HDX 7"

Post by nickk »

Unfortunately we are no longer able to support Android 4.4.2 as Android 4.4.2 doesn't support TLS 1.2 which became a standard in 2008.

Nick

NedS
Silicondust
Posts: 1682
Joined: Mon Dec 10, 2018 12:38 pm
x 74

Re: App stopped working on Kindle Fire HDX 7"

Post by NedS »

We can't guarantee how well it will work, but we can find a link for the older version of the app that can be sideloaded. Failing that, I think VLC still supports Android 4.4 and does a pretty good job, though it lacks a channel guide.

TJ1
Posts: 2
Joined: Thu Nov 19, 2020 5:33 pm

Re: App stopped working on Kindle Fire HDX 7"

Post by TJ1 »

Thanks for the replies! I would like to try loading the old version if you could link it.

kyl416
Posts: 56
Joined: Wed Sep 17, 2014 12:09 pm
Device ID: 1080DB11
Location: Tobyhanna, PA
x 4
Contact:

Re: App stopped working on Kindle Fire HDX 7"

Post by kyl416 »

You should raise the minSdkVersion from 19 to 21 when compiling the app to prevent it from being installed on older Android OS's without TLS 1.2 support.

NedS
Silicondust
Posts: 1682
Joined: Mon Dec 10, 2018 12:38 pm
x 74

Re: App stopped working on Kindle Fire HDX 7"

Post by NedS »

kyl416 wrote: Thu Nov 19, 2020 8:57 pm You should raise the minSdkVersion from 19 to 21 when compiling the app to prevent it from being installed on older Android OS's without TLS 1.2 support.
Ah nuts, now I remember that's why we raised the requirements. That means older versions of the app won't work.

Post Reply