Puchased DVR - Cannot Install on NAS "SMBD not found"

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
vbyte
Posts: 17
Joined: Thu Dec 13, 2018 7:53 pm

Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by vbyte »

Hi all, I just purchased the DVR service and intended to use my QNAP NAS as storage. I go through the process steps and when I get to step 7 in the link below:

https://info.hdhomerun.com/info/dvr:nas:qnap

I get an error saying "smbd not found or not running Unable to install"

Can someone please assist on how to proceed?

signcarver
Expert
Posts: 9318
Joined: Wed Jan 24, 2007 1:04 am
Device ID: 10802091 131B34B7 13231F92 1070A18E 1073ED6F 15300C36
x 21

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by signcarver »

My suggestion for a qnap is to use demonrik's package. Though on one of those platforms a recent update on the nas makes it a bit harder (and I think it was qnap)

However for the error you mentioned, one of the first steps is to create a share with the name HDHomeRun. The other part of that is perhaps you don't have network sharing/discovery on at all or permissions of the share/folder. I'd also double check that smb is up on the qnap.

nickk
Silicondust
Posts: 16226
Joined: Tue Jan 13, 2004 9:39 am
x 73

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by nickk »

Hi,

What model of QNAP and what firmware version is it running?

Nick

vbyte
Posts: 17
Joined: Thu Dec 13, 2018 7:53 pm

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by vbyte »

nickk wrote: Sun Oct 25, 2020 10:01 am Hi,

What model of QNAP and what firmware version is it running?

Nick
Hi, running a TS-453-Be, version 4.5.1.1465

vbyte
Posts: 17
Joined: Thu Dec 13, 2018 7:53 pm

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by vbyte »

signcarver wrote: Sun Oct 25, 2020 9:12 am My suggestion for a qnap is to use demonrik's package. Though on one of those platforms a recent update on the nas makes it a bit harder (and I think it was qnap)

However for the error you mentioned, one of the first steps is to create a share with the name HDHomeRun. The other part of that is perhaps you don't have network sharing/discovery on at all or permissions of the share/folder. I'd also double check that smb is up on the qnap.
Sorry, i'm a bit of a novice. How do I check SMB is installed and running on my QNAP?

I did create a sharefolder called HDHomeRun but not sure how to check if network sharing/discorery is all turned on.

signcarver
Expert
Posts: 9318
Joined: Wed Jan 24, 2007 1:04 am
Device ID: 10802091 131B34B7 13231F92 1070A18E 1073ED6F 15300C36
x 21

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by signcarver »

I'm not saying not installed... there are times that it becomes disabled (by user) or for some reason doesn't come up (usually due to a bug or error on restart) or has too many connections. As I recall about 3 years ago a windows and/or qnap update crippled such in the installer, something to do with smb version (i believe 2 worked if 3 was disabled but also might have been from dropping 1)

My main point is don't use the NAS installer, either install manually or use demonrik's package. Unfortunately this particular issue with the installer is long gone in the forums and I don't know if ever fixed as most went to the package but i do remember there was an issue 2-3 years ago after a windows update but my previous answer was more generic for smb not found.

nickk
Silicondust
Posts: 16226
Joined: Tue Jan 13, 2004 9:39 am
x 73

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by nickk »

Updating our QNAP to 4.5.1 now...

nickk
Silicondust
Posts: 16226
Joined: Tue Jan 13, 2004 9:39 am
x 73

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by nickk »

Problem confirmed. I will see if we can get it fixed tomorrow.

Nick

vbyte
Posts: 17
Joined: Thu Dec 13, 2018 7:53 pm

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by vbyte »

nickk wrote: Sun Oct 25, 2020 10:07 pm Problem confirmed. I will see if we can get it fixed tomorrow.

Nick
Thanks Nick! Appreciate the support.

vbyte
Posts: 17
Joined: Thu Dec 13, 2018 7:53 pm

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by vbyte »

nickk wrote: Sun Oct 25, 2020 10:07 pm Problem confirmed. I will see if we can get it fixed tomorrow.

Nick
Nick, just wondering if this was resolved?

nickk
Silicondust
Posts: 16226
Joined: Tue Jan 13, 2004 9:39 am
x 73

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by nickk »

QNAP changed things a bit... support for these changes added...
https://download.silicondust.com/hdhome ... s_beta.exe

Nick

vbyte
Posts: 17
Joined: Thu Dec 13, 2018 7:53 pm

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by vbyte »

nickk wrote: Wed Oct 28, 2020 8:50 am QNAP changed things a bit... support for these changes added...
https://download.silicondust.com/hdhome ... s_beta.exe

Nick
Nick, I downloaded and installed and still received the same message of "smbd not found or not running unable to install"

I tried downloading and manually installing demonrik's installer package but when I click to open the app, I get a message with the IP address and says "refused to connect".

At this point, I still have no way to install the DVR on my QNAP. Is there possible some setting i'm missing on the NAS? Can you kindly advise?

nickk
Silicondust
Posts: 16226
Joined: Tue Jan 13, 2004 9:39 am
x 73

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by nickk »

vbyte wrote: Wed Oct 28, 2020 8:31 pm Nick, I downloaded and installed and still received the same message of "smbd not found or not running unable to install"

I tried downloading and manually installing demonrik's installer package but when I click to open the app, I get a message with the IP address and says "refused to connect".

At this point, I still have no way to install the DVR on my QNAP. Is there possible some setting i'm missing on the NAS? Can you kindly advise?
Please run HDHomeRun Setup, enable "send diagnostic information" on the Advanced tab, then run through NAS Install once more.

Then post back with the device ID your HDHomeRun - I will check the diagnostic logs.

Nick

demonrik
Posts: 1346
Joined: Mon May 04, 2015 10:03 am
Device ID: 10736454, 1073A35A, 1075C377, 108042A1
x 8

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by demonrik »

vbyte wrote: Wed Oct 28, 2020 8:31 pm I tried downloading and manually installing demonrik's installer package but when I click to open the app, I get a message with the IP address and says "refused to connect".
I assume by click to open the app you mean the icon on the QTS desktop
This is a known issue - originally posted here viewtopic.php?p=186338#p186338
but fast forward a few years and now QNAP have added an option, so no need to go to SSH
Under Control Panel -> Applications -> Webserver
make sure to uncheck 'Do not allow Web Server embedding in iFrames' and Apply
OR you can simply navigate to http://<your nas ip address>/HDHomeRunDVR and not worry about the embedding

On the smbd issues - while waiting for nick here are some things to check
first check windows sharing is enabled in Control Panel -> Network & File Services -> Win/Mac/NFS
Next is to check that there is no bad default in the privileges
Control Panel -> Privilege -> Shared Folder
Over on right of each share listed are 3 icons - middle one should be (you can hover to confirm) 'Edit Shared Folder Permission'
Select the one for you HDHomeRun share
This will open a new dialog box - in the top is a drop down box, select 'Microsoft Networking host access'
Make sure you select your share in the left pane - and then you should see either blanks in the right pane, or some IP addresses combos.. Ideally it's either the IP address of your PC, or a network address (e.g. 192.168.0.1/24)
Thing here is basically with new security counsellor they've started warning about this - but not sure if they do any lock down yet, but can see it coming if not already hitting (just doing latest firmware update - third in less than a week :()

Anyway, best of luck.

vbyte
Posts: 17
Joined: Thu Dec 13, 2018 7:53 pm

Re: Puchased DVR - Cannot Install on NAS "SMBD not found"

Post by vbyte »

nickk wrote: Wed Oct 28, 2020 9:31 pm
vbyte wrote: Wed Oct 28, 2020 8:31 pm Nick, I downloaded and installed and still received the same message of "smbd not found or not running unable to install"

I tried downloading and manually installing demonrik's installer package but when I click to open the app, I get a message with the IP address and says "refused to connect".

At this point, I still have no way to install the DVR on my QNAP. Is there possible some setting i'm missing on the NAS? Can you kindly advise?
Please run HDHomeRun Setup, enable "send diagnostic information" on the Advanced tab, then run through NAS Install once more.

Then post back with the device ID your HDHomeRun - I will check the diagnostic logs.

Nick
Nick, whatever was in the last update solved the issue. I was able to finish the install and record onto my QNAP NAS.

I do have one pending issue. Although I am able to view all channels on my android device, Windows 10 and my LG OLED app will not show certain channels (seemingly the DRM channels). Do you have any experience with this?

As always, thanks for your support.

Post Reply