Windows 10 Live Playback Issue

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
bigfan99
Posts: 64
Joined: Wed Oct 30, 2019 11:41 am

Windows 10 Live Playback Issue

Post by bigfan99 »

For the last several weeks playback on Windows 10 App 20200529 has been experiencing intermittent video/audio break-up and freezing. This does not seems to be the case for recorded content (playback of SERVIO recorded content on the same Windows 10 machine seems normal). Sometimes this Live TV issue is so bad it makes the experience unwatchable. The error MF_MEDIA_ENGINE_ERR_DECODE : HRESULT - 0xC00D36F2 will sometimes be generated. In some cases the app will crash (close without warning or error message while experiencing the impairment)

I have turned on diagnostics in the App and in HDHomeRun Prime.

HDHomeRun PRIME 131125B5
HDHomeRun SERVIO 153022CF

Thanks in advance,

toddphi
Posts: 24
Joined: Thu Jul 13, 2017 3:47 pm

Re: Windows 10 Live Playback Issue

Post by toddphi »

I'm having similar issues. It seems HDHomerun on Windows 10 will be reliable for months and then will suddenly stop working. Right now I'm getting "Unable to play channel: HDCP required to display protected content." Literally nothing in my setup has changed. The HDHomerun software just starts hanging. I'm running the latest versions of the software. I wish Silicondust would improve the reliability of this product. By contrast my Tivo is about 100 times more reliable. Tivo virtually never goes down.

mchias13
Posts: 181
Joined: Thu Jun 27, 2013 3:57 am
Device ID: 131D4055

Re: Windows 10 Live Playback Issue

Post by mchias13 »

unfortunately there was another thread about this and nothing came of it. viewtopic.php?f=119&t=73844

there's obviously something going on since all us are getting the same error on Win10. We don't have the same providers and don't live in the same houses.

@Neds or @ Nickk, Is there any information we could provide to help with figuring out why we are getting this error?

While I'm thinking about it, I feel like I'm also only getting the error on non-DRM channels. Is this the same for you as well or is it any channel?

thedoomster
Posts: 150
Joined: Fri Nov 27, 2015 6:14 pm
Device ID: 131CC070
Location: Rochester, NY

Re: Windows 10 Live Playback Issue

Post by thedoomster »

I also see similar popup Windows error windows that do not close unless I close the app. Just started happening over the last week or so.

leerandall
Posts: 713
Joined: Sat Mar 16, 2013 5:49 pm
Device ID: 131102D9, 1326E147

Re: Windows 10 Live Playback Issue

Post by leerandall »

I've had multiple freeze-ups on both my Win10 desktop and my Win10 laptop today. I occasionally get the pop-up Media Engine Err also.

jph1589
Posts: 24
Joined: Sun Feb 24, 2019 11:19 am

Post by jph1589 »

I had numerous problems with live tv freezing and it turned out to be Nvidias new drivers that they came out with in July. I opened a trouble ticket and Silicon dust people really worked hard to come to a solution. When they mentioned nvidia as a possible culprit I checked for a driver update and there was a new one dated August 2020. When I installed that one and all the problems went away.

I have an Hdhomerun Duo and Windows 10 with the dvr running on my Asus Zenbook laptop. Nvidia geforce 1050 with maxQ design. All the latest firmware and software and updates. The new nvidia driver is 8/12/2020 V27.21.14.5206

I have run the live tv for 3 days now without a glitch. Hope this helps someone.

bigfan99
Posts: 64
Joined: Wed Oct 30, 2019 11:41 am

Re: Windows 10 Live Playback Issue

Post by bigfan99 »

Thanks for sharing you Nvidia driver experience. I can currently running the Nvidia Studio Drivers (not the Game Ready Drivers), v 441.66. I see there is a v 452.06 released on 2020.8.18, so I will give that a try and report back.

REPORTING BACK: Updating the Nvidia Studio Driver to v 452.06 made NO difference. Live viewing intermittently freezes whereas viewing SERVIO recorded content is fine.

--Rob

NedS
Silicondust
Posts: 1383
Joined: Mon Dec 10, 2018 12:38 pm

Re: Windows 10 Live Playback Issue

Post by NedS »

Doesn't seem to be packet loss, and if recording-playback works it shouldn't be a decoding issue. Will work with dev team to figure it out.

bigfan99
Posts: 64
Joined: Wed Oct 30, 2019 11:41 am

Re: Windows 10 Live Playback Issue

Post by bigfan99 »

Thanks Ned. I will assume I can disable the sending of diagnostic info. (i.e., you got what you needed)

bigfan99
Posts: 64
Joined: Wed Oct 30, 2019 11:41 am

Re: Windows 10 Live Playback Issue

Post by bigfan99 »

FYI, it appears HDHomeRun PRIME 20200907 Firmware fixed this issue.

Post Reply