Unable to play channel: Content protection error

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
Posts: 21
Joined: Thu Jul 13, 2017 3:47 pm

Unable to play channel: Content protection error

Post by toddphi »


I've been running HD Homerun Prime on Windows 10 for a couple of years with few problems. Suddenly, in mid-June reliability is completely gone. Now when I select a channel that formerly worked I get a black screen, followed after a delay by "Unable to play channel: Content protection error." I have tried restarting Windows 10, rebooting the HD Homerun Prime unit, and updating to the latest version of the software (HDHomeRunSetup v20200602). None of this helps.

Sometimes I also get an error dialog box that says: "MF_MEDIA_ENGINE_ERR_DECODE: HRESULT - OxC00D36F2" but this error does not appear consistently.

Here are my specs
Windows 10 OSBuild 19041.329 (recently auto-updated)
HW: Intel i7 with 32GB ram and tons of HD space
Cable provider: Spectrum

The iOS app is working fine so I don't think there is anything wrong with the HD Homerun Prime hardware.

Can anyone suggest a solution? How can I get support from SiliconDust?



Posts: 8918
Joined: Wed Jan 24, 2007 1:04 am
Device ID: 131B34B7 13231F92 1070A18E 1073ED6F 15300C36

Re: Unable to play channel: Content protection error

Post by signcarver »

First double check app version (settings icon in app... gives both app and ui version) as sometimes that doesn't update and it must periodically update for DRM "keys" to be current.

The error you are getting for playing DRM protected channels suggests either something wrong with the content protection path (most often video/hdcp but can be almost anything with the system) or network issues causing a delay in RTT (I have seen various security software cause such delays as well as changes/bridge to media such as to/from wifi or moca cause such delays). Make sure you are not cloning the display (there are some utilities that can access the display that essentially clones it), also try adjusting resolution to 1080 if you are running at 4k as often the hdcp level used doesn't support hdcp at 4k... not sure I have ever seen it with the app but I have seen other software such as wmc and some dvd software that supports dtcp-ip have issues when refresh rate is too low or too high.

The other error you are getting may also be related but I have heard of people reporting that error and still have drm work when the error isn't present but may get it when changing channels or when a commercial comes on.. In some cases, it is related to ac3 passthrough but I believe it is more related to various drivers and sometimes the latest isn't always the best.

For SD's help make sure to enable sending of diagnostics data on the device AND in the app, reproduce the problem and report the time/channel it occurred and the DeviceID either hear or in a trouble ticket.

Post Reply