Bug found in 6/21/2019 windows software

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
TPeterson
Posts: 33
Joined: Thu May 31, 2007 8:29 pm
Location: San Carlos, CA
Contact:

Bug found in 6/21/2019 windows software

Post by TPeterson » Thu Jan 09, 2020 1:39 pm

Hi, Nick!

I've just updated my Windows 10 systems to the June 2019 software (to get the viewer app to work with my older HDHR tuners) and I've discovered that the stream of diagnostic characters sent every second by HDHomerun_config.exe when using the save command after selecting a program substream is "ssss<etc>" instead of the expected "....<etc>". If I request the full TS the stream is still the expected "....<etc>". This occurs with both HDHR-US and HDHR3-US units.

This plays havoc with my app's attempts to counteract reception quality issues, so I hope that you can issue a fix!

--Terry

nickk
Silicondust
Posts: 15761
Joined: Tue Jan 13, 2004 9:39 am

Re: Bug found in 6/21/2019 windows software

Post by nickk » Thu Jan 09, 2020 2:00 pm

Hi,

I re-tested here - tuning by frequency/program and tuning by vchannel - not seeing a problem.

Can you please make a 30s unfiltered capture of the channel so I can test with the capture.

Nick

TPeterson
Posts: 33
Joined: Thu May 31, 2007 8:29 pm
Location: San Carlos, CA
Contact:

Re: Bug found in 6/21/2019 windows software

Post by TPeterson » Thu Jan 09, 2020 2:58 pm

OK, I've made a 30-second full-ts (72-MB) file. I'm not sure what you're going to learn from it though. Both unfiltered and filtered captures are fine, it's just the diagnostic character stream that's dorked in the latter case.

How do I transmit this file to you?

TPeterson
Posts: 33
Joined: Thu May 31, 2007 8:29 pm
Location: San Carlos, CA
Contact:

Re: Bug found in 6/21/2019 windows software

Post by TPeterson » Thu Jan 09, 2020 3:10 pm

Perhaps to clarify, here is the DOS box record of two captures that show this problem:

Code: Select all

C:\Program Files\Silicondust\HDHomeRun>hdhomerun_config.exe 103AEA6C set /tuner0/channel 8vsb:12

C:\Program Files\Silicondust\HDHomeRun>hdhomerun_config.exe 103AEA6C save /tuner0 "D:\30-sec_full-ts.ts"
..............................
-- Video statistics --
56473 packets received, 0 overflow errors, 0 network errors, 0 transport errors, 0 sequence errors

C:\Program Files\Silicondust\HDHomeRun>hdhomerun_config.exe 103AEA6C set /tuner0/channel 8vsb:12

C:\Program Files\Silicondust\HDHomeRun>hdhomerun_config.exe 103AEA6C set /tuner0/program 3

C:\Program Files\Silicondust\HDHomeRun>hdhomerun_config.exe 103AEA6C save /tuner0 "D:\30-sec_prog3.ts"
ssssssssssssssssssssssssssssss
-- Video statistics --
24746 packets received, 0 overflow errors, 0 network errors, 0 transport errors, 305 sequence errors
Again, both captures are OK, even though the diagnostic stream indicates a problem. This did not occur with the earlier config.exe app.

TPeterson
Posts: 33
Joined: Thu May 31, 2007 8:29 pm
Location: San Carlos, CA
Contact:

Re: Bug found in 6/21/2019 windows software

Post by TPeterson » Thu Jan 09, 2020 3:22 pm

Also, I've just confirmed that the problem does not occur with HDHR5-4US tuners.

BTW, all tuners are on their latest firmware, but the HDHR-US and HDHR3-US ones are from 9/2017, while the HDHR5-4US firmware is from 6/2019.

jasonl
Expert
Posts: 15174
Joined: Sun Oct 28, 2007 9:23 pm

Re: Bug found in 6/21/2019 windows software

Post by jasonl » Thu Jan 09, 2020 3:36 pm

Please upload both to the file storage site of your choice (Dropbox, Google Drive, iCloud, OneDrive, etc.) and send links to them to support at silicondust dot com along with a link to this thread so we know they are.

TPeterson
Posts: 33
Joined: Thu May 31, 2007 8:29 pm
Location: San Carlos, CA
Contact:

Re: Bug found in 6/21/2019 windows software

Post by TPeterson » Thu Jan 09, 2020 4:27 pm

Files posted to Mega.nz and links sent to support.

jasonl
Expert
Posts: 15174
Joined: Sun Oct 28, 2007 9:23 pm

Re: Bug found in 6/21/2019 windows software

Post by jasonl » Thu Jan 09, 2020 5:26 pm

Thanks, we're looking at them. Everything looks normal so far, but there are more tools to check with.

nickk
Silicondust
Posts: 15761
Joined: Tue Jan 13, 2004 9:39 am

Re: Bug found in 6/21/2019 windows software

Post by nickk » Thu Jan 09, 2020 9:37 pm

I put your 30s-full test capture on a modulator and I was able to reproduce the problem on a gen2 device.

Investigating!

Nick

ebo
Posts: 558
Joined: Thu Jan 07, 2010 6:58 pm
Device ID: 1016F746, 101C8CF9, 1041F134, 10532394

Re: Bug found in 6/21/2019 windows software

Post by ebo » Thu Jan 09, 2020 10:04 pm

I tried the same test on one of my gen2 boxes and my HDHR4 and got the same results TPeterson did: a string of s's when recording a single subchannel on the gen2 and dots on all the other tests. So I'm pretty sure you'd get the same results using a legacy HDHR on one of your local channels. I haven't seen any problem with recordings, many of which are done on a legacy HDHR.

nickk
Silicondust
Posts: 15761
Joined: Tue Jan 13, 2004 9:39 am

Re: Bug found in 6/21/2019 windows software

Post by nickk » Fri Jan 10, 2020 8:56 am

Problem found and fixed.

We will be releasing a new firmware.

Nick

TPeterson
Posts: 33
Joined: Thu May 31, 2007 8:29 pm
Location: San Carlos, CA
Contact:

Re: Bug found in 6/21/2019 windows software

Post by TPeterson » Fri Jan 10, 2020 9:13 am

Thanks, Nick!

Terry
CW_EPG team
tmpeterson.net/cw_epg-support-page/

nickk
Silicondust
Posts: 15761
Joined: Tue Jan 13, 2004 9:39 am

Re: Bug found in 6/21/2019 windows software

Post by nickk » Tue Jan 21, 2020 7:34 am

Beta release: viewtopic.php?f=126&t=20613

Nick

TPeterson
Posts: 33
Joined: Thu May 31, 2007 8:29 pm
Location: San Carlos, CA
Contact:

Re: Bug found in 6/21/2019 windows software

Post by TPeterson » Wed Jan 22, 2020 3:06 pm

@nickk, thanks I've confirmed that the 01/22/20 beta package fixed the "ssss" save response issue. However, there appears to be an issue with its installer. I was prompted to let it install the C++ redistributable stuff, which was not requested when installing the 06/21/19 package, but I consented. After C++ had gone through its motions it said I needed to restart Windows, so I did. Then, since the HDHR installation did not resume, I started the installer again and it again requested to install C++ stuff. Smelling a rat, I declined that time and the HDHR installer said that C++ was not properly installed, but it let me proceed anyway, which I did and the beta package seems to be running as expected.

jasonl
Expert
Posts: 15174
Joined: Sun Oct 28, 2007 9:23 pm

Re: Bug found in 6/21/2019 windows software

Post by jasonl » Wed Jan 22, 2020 3:26 pm

20190621 used an earlier VC++ version (2017), while the latest beta moved to the current (2019) version. On a 64 bit OS, both the 32 bit and 64 bit versions get installed, so it is normal for 2 installers to run. Prior versions did the install quietly in the background, but we elected in this new version to run them in the foreground because people were sometimes confused when it looked like the installer was frozen, when really it was just downloading/installing behind the scenes.

Post Reply