HDHR opens to black screen, no menu/EPG, no video, no sound - reboots fix - suspect network [Looking for insight]

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
destrekor
Posts: 118
Joined: Mon May 04, 2015 8:20 am

HDHR opens to black screen, no menu/EPG, no video, no sound - reboots fix - suspect network [Looking for insight]

Post by destrekor » Wed Jan 08, 2020 7:50 pm

As post title/subject states, I can open the app on Windows 10 and on Nvidia Shield (Android TV) and they will sometimes open fine, and sometimes open blank. Whenever it opens blank, I can get it working again by rebooting the device.

But as I loathe rebooting my main PC because I have so many things open all the time, that's getting me to dig into why this is happening. Strangely I haven't encountered this on my Android phone (Pixel 3 on Android 10).

Is it something like a discovery service that can only get a few attempts to communicate before it gives up until something is reset in the platform? If so, would you be looking at the networking stack in general, or even specific system services and/or processes? Is a full reboot really necessary or is that just the sledgehammer fix, whereas a more finessed service restart could do the trick?

Or is it more specific to the network fundamentals? I haven't yet performed any kind of network scans but I have an atypical home network with business/enterprise-grade networking equipment in a "homelab" environment. I'm not pro yet so I haven't quite tracked down what is specifically occurring.

I fully expect this to be more network oriented but upon reboot the software does pull everything up successfully so it's not totally blocked from any discovery protocol use, multicast, etc or else it shouldn't find the HDHR Prime ever.
Rebooting the HDHR Prime does not resolve the issue, btw.

With the network issue hunch, I also don't expect this to be a fault of the developers whatsoever, as usage of UPnP (Universal Plug and Play), multicast, discovery protocols, are all normal and expected to be functioning in a home network. These kinds of devices/services/platforms can be notoriously tricky to get functioning in enterprise networks, because stuff like UPnP is often disabled and multicast might be limited.

Really I'm just looking for insights into how the device discovery works; if a first search works after a reboot that suggests some network-related interface or service reset might do the trick. Note: I just tried resetting the network interface on my PC, did not resolve.
I am not seeing anything in the event logs (at least at any found in the Windows Event Viewer).

Any thoughts?

jasonl
Silicondust
Posts: 14915
Joined: Sun Oct 28, 2007 9:23 pm

Re: HDHR opens to black screen, no menu/EPG, no video, no sound - reboots fix - suspect network [Looking for insight]

Post by jasonl » Thu Jan 09, 2020 12:01 pm

When you first open the app, it loads the UI via HTTPS from our servers, and then proceeds with device discovery. If the device discovery was the issue, you'd at least get a flash of text in the bottom-left corner while it was doing discovery, and it would report that no devices were found if it couldn't find them, so it's probably not even getting to that point. Something might be interfering with the loading of the UI, which could be something interfering with the connection like a fancy traffic filter/parental control software/etc., or IPv6 connectivity issues if you have IPv6 available (the servers are dual-stack).

destrekor
Posts: 118
Joined: Mon May 04, 2015 8:20 am

Re: HDHR opens to black screen, no menu/EPG, no video, no sound - reboots fix - suspect network [Looking for insight]

Post by destrekor » Thu Jan 09, 2020 4:16 pm

Interesting. So it's just trying to pull in UI info via TCP 443? I definitely am not getting the flash of text in the bottom (I've seen issues at that point, but nothing consistent like this, and as noted it's not even getting that far.

Not sure what a restart on the local affected system is accomplishing that would sometimes let that traffic through and then other times not. Oddly enough, my Android phone is getting multiple filters applied and never struggles! I have some firewall-level filtering on my whole network, and on my phone I also have the AdGuard Premium/VPN.

I'm going to have to load up some network traffic analyzers to see why/where that traffic gets dropped.

Any recommended logs I should look through for clues?

jasonl
Silicondust
Posts: 14915
Joined: Sun Oct 28, 2007 9:23 pm

Re: HDHR opens to black screen, no menu/EPG, no video, no sound - reboots fix - suspect network [Looking for insight]

Post by jasonl » Thu Jan 09, 2020 5:29 pm

Yes, the UI is HTML and Javascript, so it just loads like a normal web page. If you have IPv6, it will be from a 2606:4700 IP. If IPv4, it will be in 104.24.

destrekor
Posts: 118
Joined: Mon May 04, 2015 8:20 am

Re: HDHR opens to black screen, no menu/EPG, no video, no sound - reboots fix - suspect network [Looking for insight]

Post by destrekor » Thu Jan 09, 2020 6:48 pm

So is HDHR not going to work during an internet outage? I haven't tested that, but that kind of worries me considering that cable TV does not need internet service to function. Sure, guide updates are important, but considering the channels are local content -- is that really the right approach?

NedS
Silicondust
Posts: 689
Joined: Mon Dec 10, 2018 12:38 pm

Re: HDHR opens to black screen, no menu/EPG, no video, no sound - reboots fix - suspect network [Looking for insight]

Post by NedS » Sat Jan 11, 2020 5:21 pm

destrekor wrote:
Thu Jan 09, 2020 6:48 pm
So is HDHR not going to work during an internet outage? I haven't tested that, but that kind of worries me considering that cable TV does not need internet service to function. Sure, guide updates are important, but considering the channels are local content -- is that really the right approach?
The UI files should cache in the app itself, though it will still need internet for guide data.

Post Reply