hdhomerun_config_gui libhdhomerun.so not found

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
ksanger35
Posts: 1
Joined: Thu May 09, 2019 5:38 am

hdhomerun_config_gui libhdhomerun.so not found

Post by ksanger35 » Thu May 09, 2019 5:52 am

I've recently tried to compile and install hdhomerun_config_gui on Fedora Core 29. Downloaded source, placed both uncompressed folders in the same folder. Ran ./config, make, sudo make install. Also ran sudo ldconfig. When attempting to run hdhomerun_config_gui we get the error that the libhdhomerun.so is not found. I found the library in the folder /usr/local/lib directory.

I was able to remove all files with hdhomerun manually. Then found that there is an rpm for Fedora and installed that with sudo dnf install hdhomerun. After which the libhdhomerun.so was located in /usr/local/lib64 directory. Pretty sure this is the issue and there must be something in the make file that is incorrect.

Ken.F
Posts: 2089
Joined: Fri Apr 05, 2013 9:20 am
Device ID: 1041A706, 1043EB32, 104BAD9E, 13168DC5, 1322A7AC
Location: West Rockhill, PA

Re: hdhomerun_config_gui libhdhomerun.so not found

Post by Ken.F » Thu May 09, 2019 8:32 am

I had the same problem on Arch and Manjaro. The libhdhomerun.so file is placed in usr/local/lib. When I ran ldconfig it didn't find it because I didn't have a .conf file in /etc/ld.so.conf.d pointing to usr/local/lib. I created the file libc.conf in the /etc/ld.so.conf.d directory with the following contents:

Code: Select all

# libc default configuration
/usr/local/lib
Once that file was created I ran ldconfig again and hdhomerun_config_gui worked as expected. I haven't run Fedora since Core 4 so I don't know if that is helpful to you or not, but maybe it gives SD a head start.

Post Reply