Resolved: FreeBSD tuning for RECORD performance?

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
averyfreeman
Posts: 98
Joined: Sun Apr 09, 2017 11:12 am
Location: Olympia, WA
Contact:

Resolved: FreeBSD tuning for RECORD performance?

Postby averyfreeman » Thu Apr 19, 2018 1:03 pm

Hey,

Does anyone else use FreeBSD for their RECORD platform?

I had been using CentOS 7, but I decided to switch to FreeBSD just recently because the zfs set sharesmb=on setting doesn't work in CentOS, and the userland Samba implementation was terrible in my domain (we're talking like 1MBs transfer speeds, just awful).

Well, now I'm having slow seek performance, when the frames used to skip as fast as I could hit the buttons, now it has a serious lag (like 1-2 sec). This is while recording two streams (before it never used to matter).

I have been using ZFS for the FS on both platforms. I had ARC set as low as possible on CentOS so after I tried a 'normal' system-managed ARC with 8GB RAM and prefetch, I thought maybe that was what was making it slow so I turned prefetch off and set the ARC way down low. My current settings are:

Code: Select all

/boot/loader.conf #Multicast settings ip_mroute_load="YES" gateway_enable="YES" routed_enable="YES" routed_flags="-s" #for NTFS support fuse_load="YES" #ZFS settings vfs.zfs.prefetch_disable=1 vfs.zfs.arc_max="128M" vfs.zfs.vdev.cache.size="64M"

Code: Select all

/etc/rc.conf #general hostname="fbsd111" ifconfig_vmx0="inet 192.168.1.54 netmask 255.255.255.0" defaultrouter="192.168.1.1" ifconfig_vmx0_ipv6="inet6 accept_rtadv" sshd_enable="YES" ntpd_enable="YES" powerd_enable="YES" # Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable dumpdev="AUTO" #miniDLNA, pimd and hdhomerun rc script I threw together: minidlna_enable="YES" pimd_enable="YES" hdhomerun_record_enable="YES"
People who know this stuff probably have noticed:
1) It's an ESXi VM using a para-virtualized ethernet interface (vmxnet3)
2) I tried my best to implement multicast for the DLNA server (minidlna) without really knowing what I was doing
3) the ZFS memory resources are super paltry for a 4TB array (4x 2TB in "z-raid 10")

My thinking behind setting the memory resources for ARC and cache way down were because I had it set down far in CentOS and time-shifting worked *great*.

I wonder if it's not slow because I didn't install the VMWare-native vmtools (I'm using open-vm-tools package). I will try and do that now.

Damn so much to get done on these *Nix machines before they work right. I swear, I spent 3 straight days trying to tune my Samba settings in CentOS not to get the most awful transfer speeds I'd ever seen in my life, and nothing. ever. worked.

I'm starting to wonder if I should just run hdhomerun RECORD in a server 2016 core VM.

Anyway, thanks!

Edit: I think I nailed down what the issue was -- the pool was available but still importing which was slowing down its response time. Now that it's done, it's extremely, extremely responsive...

This is by far the best thing I've decided to do since I bought my first HDHomeRun Prime 4 years ago.

viewtopic.php?f=119&t=68470
Last edited by averyfreeman on Fri Apr 20, 2018 11:55 pm, edited 1 time in total.

Return to “HDHomeRun Software Setup & Troubleshooting (Live & DVR)”

Who is online

Users browsing this forum: No registered users and 7 guests