Video Playback not working

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Post Reply
dwrede
Posts: 126
Joined: Fri May 08, 2015 5:31 pm

Video Playback not working

Post by dwrede »

'This device does not support video - screen turned off?'. Win10 app has been working just fine on my laptop until recently, now a black screen with this error message. Other HDHomerun screens fine, just live and recorded playback not working. Still working fine on my win10 desktop, just laptop with problem. Other sources of video working fine on this laptop, just HDHomerun having issues now. Not sure how to troubleshoot this one.... Anyone else having this issue? Solution? - David

Model: HDHR4-2US
Device ID: 1042A61B
Firmware: 20210624

Model: HDHR4-2US
Device ID: 1043D825
Firmware: 20210624

NedS
Silicondust
Posts: 2357
Joined: Mon Dec 10, 2018 12:38 pm
x 52

Re: Video Playback not working

Post by NedS »

Where do you see that message that says "screen turned off?"? Is that in the HDHomeRun app, in a pop-up window, etc?

Online
nickk
Silicondust
Posts: 17282
Joined: Tue Jan 13, 2004 9:39 am
x 94

Re: Video Playback not working

Post by nickk »

AMD GPU?

The message indicates that the app is attempting to do software decode of MPEG2 and Windows is unable to do NV12 format video.

First thing to do is go to the AMD/Intel/Nvidia website and install the latest drivers for your video card.

Nick

HDUserAU
Posts: 5
Joined: Sat Sep 11, 2021 3:41 am
x 1

Re: Video Playback not working

Post by HDUserAU »

I'm having this issue too (although I posted in the wrong forum) viewtopic.php?t=75851

I'm also getting an error requesting that the 'Microsoft MPEG-2 Video Extension' be installed - https://imgur.com/mhKEHkr
However this is already installed! https://imgur.com/OM0MbDw

The system has an Nvidia GPU. Updating Nvidia drivers didn't help.
The system also has onboard video out, but this is disabled in the UEFI, and has been for years.

dwrede
Posts: 126
Joined: Fri May 08, 2015 5:31 pm

Re: Video Playback not working

Post by dwrede »

I have the Intel UHD graphics 620, Running on a Lenovo YOGA C930-131KB

Both Lenovo and Microsoft Win10 says I have the most current Video driver.
Driver Date 4/18/2018
Driver Version 23.20.16.5037

Like HDUserAu, I sometimes (but not every time) get a popup on the black HDHomerun screen "Microsoft MPEG-2 Video Extension' needs to be installed". (The MPEG-2 is installed and re-installation does nothing). Clicking the OK, then I get the next popup .'This device does not support video - screen turned off?'. .

Usually I only get the 'This device does not support video - screen turned off?' on a black HDHomeRun screen on startup. Clicking the "Close" and I am left with just a black screen.

While on the "Live" screen pressing escape I get all the HDHomerun controls and menu. Also can change to all the other Screens, Recorded, Task, etc... Only Live Video playback and Recorded Video playback is affected as Nick said. My video card plays back other app (YouTube) video fine. So it seems to be only related to the HDHomeRun video format.

This is a recent issue. I have always been able to watch HDHomeRun on this laptop. My Lenovo Desktop and Apple products all work fine. So definitely something in this laptop has changed.

Processor Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz 1.99 GHz
Edition Windows 10 Home
Version 21H1
OS Build 19043.1237

HDUserAU
Posts: 5
Joined: Sat Sep 11, 2021 3:41 am
x 1

Re: Video Playback not working

Post by HDUserAU »

I was able to fix the issue by performing a scan and repair of the windows system files.

Run the following commands from a elevated command prompt:
  • DISM.exe /Online /Cleanup-image /Restorehealth
  • sfc /scannow

dwrede
Posts: 126
Joined: Fri May 08, 2015 5:31 pm

Re: Video Playback not working

Post by dwrede »

I haven't done anything but the windows updates and everything is back this morning... Working fine now..

Post Reply