No guide data

Help and support for HDHomeRun DVR and HDHomeRun software for Windows 10, Mac, Android, XBox, etc.
Lessmore
Posts: 129
Joined: Fri Mar 11, 2016 11:25 am

No guide data

Post by Lessmore »

After a power outage, Kodi isn't importing guide data. Any ideas what I can do to get it back? I have an HDHR Prime.

Online
NedS
Silicondust
Posts: 1501
Joined: Mon Dec 10, 2018 12:38 pm
x 40

Re: No guide data

Post by NedS »

Try using this version of the Kodi add-on using the "Install from zip" option: https://github.com/Silicondust/script.h ... master.zip

Lessmore
Posts: 129
Joined: Fri Mar 11, 2016 11:25 am

Re: No guide data

Post by Lessmore »

Thanks, NedS. I wasn't able to get that to work. Probably due to operator error and incompetence. I appreciate it, though. Thanks.

Rickt1962
Posts: 164
Joined: Tue Dec 01, 2015 2:17 pm

Re: No guide data

Post by Rickt1962 »

Lessmore wrote: Thu Oct 15, 2020 9:15 pm After a power outage, Kodi isn't importing guide data. Any ideas what I can do to get it back? I have an HDHR Prime.
I have the same problem :( seems know one knows how to fix it

RF2016
Posts: 188
Joined: Sat Jun 25, 2016 6:45 am

Re: No guide data

Post by RF2016 »

I also have been experiencing the Guide Data Issue, on 2 Android Boxes I have.

There are no Channel Icons either.

In the little bit of testing i had performed I removed the PVR client ( Version 3.5 ) that comes with Kodi, and installed

From this page.
viewtopic.php?t=71135

Download it
Import it from within Kodi Addon's

This does fix the issue of guide data.
But I still do not have the Channel Icons.


I have Verizon Fios, and they just recently updated their Cable Boxes, with a new interface.
I dont know if this has something to do with the issue, as the update occurred around the same time that my Channel Data / Guide Data / Channel Icons stopped working with the Kodi Default HDHomerun PVR Client 3.5

Online
signcarver
Expert
Posts: 9242
Joined: Wed Jan 24, 2007 1:04 am
Device ID: 10802091 131B34B7 13231F92 1070A18E 1073ED6F 15300C36
x 14

Re: No guide data

Post by signcarver »

What version of android... from what I can tell Pie (9) or later requires https unless allowed in the manifest of the apk and logos are http not https (even when trying to view one via https, it appears to fall back to http) however that would appear to be all images retrieved from guide not just channel icons.

RF2016
Posts: 188
Joined: Sat Jun 25, 2016 6:45 am

Re: No guide data

Post by RF2016 »

Version 10 Android

It has been working fine, for a while, up to the last 2 days is when it started.

RF2016
Posts: 188
Joined: Sat Jun 25, 2016 6:45 am

Re: No guide data

Post by RF2016 »

I am wondering if it has anything to do with Microsoft most recent TCP/IP patches released Tuesday.

https://thehackernews.com/2020/10/windo ... esday.html


As the Guide works fine on HDHomerun Windows box, that runs the HD app.

Kodi on Windows also works fine Guide Data and Station ICON's

So this may point to an issue with the Android Boxes and the latest Windows TCP/IP update
Last edited by RF2016 on Fri Oct 16, 2020 2:58 pm, edited 2 times in total.

Lessmore
Posts: 129
Joined: Fri Mar 11, 2016 11:25 am

Re: No guide data

Post by Lessmore »

I'm using Kodi on a 4K Firestick. I've lost the channel icons, too. I'll try reinstalling the PVR manager in Kodi later and see if that helps.

RF2016
Posts: 188
Joined: Sat Jun 25, 2016 6:45 am

Re: No guide data

Post by RF2016 »

Just curious

What Service providers/cable providers is everyone using?

I have FIOS, and they also updated in the last few days, at the same time the issue has arisen.

Lessmore
Posts: 129
Joined: Fri Mar 11, 2016 11:25 am

Re: No guide data

Post by Lessmore »

I'm on Xfinity cable card.

RF2016
Posts: 188
Joined: Sat Jun 25, 2016 6:45 am

Re: No guide data

Post by RF2016 »

If you are on Xfinity,
then that would rule out anything to do with the Cable Providers, since I am on FIOS, and experiencing it too.

Lessmore
Posts: 129
Joined: Fri Mar 11, 2016 11:25 am

Re: No guide data

Post by Lessmore »

Tried rebooting everything, clearing the guide data, reinstalling the PVR, messing with all the switches in the guide settings. Nothing works so far.

Lessmore
Posts: 129
Joined: Fri Mar 11, 2016 11:25 am

Re: No guide data

Post by Lessmore »

NAS DVR seems to still be recording everything as scheduled. HDHR View software seems to be functioning OK.

djp952
Posts: 1262
Joined: Wed Oct 01, 2008 8:46 pm
Device ID: 131EB7F7;131ED0E0
Location: Elkridge, MD USA
x 5

Re: No guide data

Post by djp952 »

There seems to be a growing problem with Kodi 18 Leia and HTTP/2 enabled sites. People are also having problems with sites like The Movie Database wherein movie posters and info cannot be loaded with the same underlying cURL error (56). My guess is that SD recently enabled HTTP/2 for the backend server(s) and Kodi can't handle it. Unfortunately this seems like a Kodi problem that needs to be solved as opposed to a backend problem; there is no reason to believe that SD's server(s) are in error -- Kodi 18 Leia is eight releases behind current on it's cURL library code.

I see the same thing on non-Windows platforms, and confirmed that at a minimum the server(s) that host the channel logos now support HTTP/2 whereas they didn't used to. I can't speak to the guide data server(s) at this time. For example, on a Vero 4K (Linux) device which has an even more outdated cURL binary on it, the error can be replicated if HTTP/2 is enabled, but works fine otherwise:

HTTP/2 enabled (fails):

Code: Select all

~$ curl --http2 http://img.hdhomerun.com/channels/US19611.png -o test.jpg
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (56) Recv failure: Connection reset by peer
HTTP/2 not enabled (works):

Code: Select all

curl http://img.hdhomerun.com/channels/US19611.png -o test.jpg
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  4707  100  4707    0     0  55937      0 --:--:-- --:--:-- --:--:-- 56710

Post Reply