Strange display behaviour

Help and support with third-party TV software.
Windows Media Center, J River Media Center, Next PVR, MythTV, InstaTV, etc.
Post Reply
linksys7
Posts: 8
Joined: Sat Mar 28, 2020 6:10 am

Strange display behaviour

Post by linksys7 »

I have dual monitors setup, one is a standard monitor DVI input, and second is a TV with a HDMI input. Ive tryed to clone the desktop but I get "Display Driver Error" message when I open Windows Media Center to view Live TV. But if I Extend the desktop and Move WMC to the TV screen, Live TV plays fine, DRM channels and All. Anyone know Why this would happen? Graphics card is a EVGA Geforce GTX 1070 ti, with updated Drivers. WMC is on Windows 7 Ultimate.

3ton
Posts: 55
Joined: Sun Sep 22, 2019 6:34 pm

Re: Strange display behaviour

Post by 3ton »

It might be the dvi connection does not do hdcp. I am actually surprised you get anything if the dvi is connected. Each video connection must have hdcp from video card to tv or monitor. I think (might be wrong), but no dvi connection can do hdcp. If you have two HDMI outputs on video card then connect the monitor and TV by HDMI cable.

jasonl
Expert
Posts: 15226
Joined: Sun Oct 28, 2007 9:23 pm

Re: Strange display behaviour

Post by jasonl »

Cloning displays violates the copy protection requirements. It's not supposed to work.

linksys7
Posts: 8
Joined: Sat Mar 28, 2020 6:10 am

Re: Strange display behaviour

Post by linksys7 »

Ahhhh, I did not know that cloning violates copy rights. I figured since it was on the same computer it was all good. Good to know thanx. Out of all the things Ive read about dual monitors, I hadnt come accross anyone stating that, so I didnt know.

Ken.F
Posts: 2255
Joined: Fri Apr 05, 2013 9:20 am
Device ID: 1041A706, 1043EB32, 104BAD9E, 13168DC5, 1322A7AC
Location: West Rockhill, PA

Re: Strange display behaviour

Post by Ken.F »

3ton wrote:
Fri Apr 17, 2020 7:08 pm
I think (might be wrong), but no dvi connection can do hdcp.
My Asrock motherboard (onboard Intel graphics) and Dell monitor support HDCP over DVI.

3ton
Posts: 55
Joined: Sun Sep 22, 2019 6:34 pm

Re: Strange display behaviour

Post by 3ton »

Ken.F wrote:
Sat Apr 18, 2020 7:36 am
3ton wrote:
Fri Apr 17, 2020 7:08 pm
I think (might be wrong), but no dvi connection can do hdcp.
My Asrock motherboard (onboard Intel graphics) and Dell monitor support HDCP over DVI.
I thought all hdcp connections need audio and video on the same cable. Thanks learn something new everyday.

Post Reply