Tuner Drops Connection on AppleTV

Reception, channel detection, network issues, CableCARD setup, etc.
Post Reply
mpatel181
Posts: 2
Joined: Mon Sep 03, 2018 9:30 am

Tuner Drops Connection on AppleTV

Post by mpatel181 »

Hi,

I'm having an issue with watching TV using the Channels and HomeRunHD app in my upstairs game room. After tuning to a channel, the channel freezes after 15 or so seconds and I can't seem to figure out what the issue is. When I initially tune on to a channel and go to the HomeRun Web UI, it uses tuner 2 and displays the signal and speed, which is approximately (16Mpbs). But within 15 sec, it drops to .24Mbps. I've included links to 2 pics showing good Streaming rate and bad streaming rate. https://www.icloud.com/photos/#0wCSFUi3 ... JCKalAyoOQ
If I use any other streaming device on that Apple TV, it works fine. I've done plenty of speed test and up/down comes to over 100Mbps. I have other TVs which are configured similarly and none of them have issues. Also no other tuner is in use when this happens. I thought that tuner2 is probably bad so I tested another TV and it too used tuner 2 but did not have any issues playing the channels. The freezing issue occurs with Channels app, HomeRunHD and Plex. Its not the app b/c I can see the connection drop in the Web UI. It can't be my network b/c all other streaming services work fine. The logs do not have anything in them w/ an error or connection drop. I'm clueless at this point.

TV setup
- Apple TV connected to Samsung TV
- Use Channels app and HomeRun HD
- Apple TV is hardwired with internet connection
- Verizon FIOS cable card with Extreme HD package.
- SiliconDust HomeRun HD prime is using the latest firmware.

Things I have tried:
- Changed from Hardwire to wireless - Same results
- Swapped my Apple TV with the one in the basement. - Same result. The swapped/new Apple TV in game room starts having issue
- Reset the whole Apple TV - Same issue

signcarver
Expert
Posts: 9538
Joined: Wed Jan 24, 2007 1:04 am
Device ID: 10802091 131B34B7 13231F92 1070A18E 1073ED6F 15300C36
x 30

Re: Tuner Drops Connection on AppleTV

Post by signcarver »

What provider?

Usually when I have seen such drops it is because mid stream it encountered a change in drm and results in delivering only the audio tracks (though typically that is 5 seconds rather than 15). Other times have been sdv related.

mpatel181
Posts: 2
Joined: Mon Sep 03, 2018 9:30 am

Re: Tuner Drops Connection on AppleTV

Post by mpatel181 »

My internet provider is FIOS but that can't be the issue. I can run speed test from AppleTV within 15 sec of this issue and get 100/100 Mbps. As I said, other services work just fine from the same Apple TV (Netflix, Hulu and Prime). This happens every time to the point where I stopped watching live tv from that room. Not to mention, I have swapped Apple TV from another room and the swapped one has the same issue.
signcarver wrote: Fri Jan 29, 2021 7:43 am What provider?

Usually when I have seen such drops it is because mid stream it encountered a change in drm and results in delivering only the audio tracks (though typically that is 5 seconds rather than 15). Other times have been sdv related.

signcarver
Expert
Posts: 9538
Joined: Wed Jan 24, 2007 1:04 am
Device ID: 10802091 131B34B7 13231F92 1070A18E 1073ED6F 15300C36
x 30

Re: Tuner Drops Connection on AppleTV

Post by signcarver »

Your reply has virtually nothing to do about what I mentioned (what I mentioned may not be your issue but is why I would usually see such a dramatic drop to such low speed). I was asking about "cable" provider not internet provider as internet should have nothing to do with it (unless you are connecting from that room through the internet and then back into your home) and getting content from the internet is completely different than content from a tuner on you local network. Somehow I must have missed fios in your first post as well as a lot of those other details.

The speed drop I was mentioning was because of the required behavior of the cablecard if drm was detected (it stops decrypting the vdeo stream thus no bits to send depending on provider/card it may continue to send the bits of the audio). Until one stops the stream the card must treat the stream as being drm protected if it encountered such. (I'd be interested to know if a fox channel is on the same frequency as I've always been told they shouldn't mix drm vs non-drm channels on the same frequency as occasionally such things you described can happen) That bit rate (99% of the time) has nothing to do with your network but the bits actually being "decoded" (filtered...) and sent out by the tuner.

Because it is fios, you can ignore it being sdv related. Because of the channel it should not be drm related but I would run a channel scan to see if such switched.

When you did your test were you using the hdhomerun app (and do you have the dvr engine anywhere if hdhomerun) as plex and channels can request the stream a bit differently (though usually not with cablecard). On all 3 there is also the possibility of a dvr coming into play (and the tuner should be showing the streaming rate to the dvr not the client). How well does that channel work in other rooms? It also may be related to apparent issues some are having with recorded content after an atv update (though i have not heard of issues with live).

My suggestion is to use the hdhomerun app, make sure sending of diagnostic data is turned on for both the app and the hdhomerun, duplicate the issue and post the channel, time, and deviceid so the folks at SD can check the Iogs.

Post Reply