Pixelization on some HD channels

Reception, channel detection, network issues, CableCARD setup, etc.
Post Reply
john262
Posts: 13
Joined: Sun Apr 07, 2019 10:56 am

Pixelization on some HD channels

Post by john262 »

Hi, I have an HDHomerun duo. I have the HDHomerun app on an Nvidia Shield and two Miboxes and on my iPhone. On the Shield and Miboxes I get pixelization on channels 4.1 and 8.1, both HD channels. Both have SD subchannels and I do not get pixelization on those. I also get several other HD channels and I do not get pixelization on those. Also, on my iPhone I do not get pixelization on any channel. I am wondering why that is and if there is anything I can do about it. I don't think it's the fault of my wifi network because my Shield is hard wired to my router with an Ethernet cable and as I said I get pixelization on it too. And it's funny that every channel works fine on my iPhone but not on the three streaming boxes. Edit- I almost forgot. I also have it on my Windows computer which is also connected via Ethernet and no pixelization on any channel.

Thank you.

NedS
Silicondust
Posts: 1511
Joined: Mon Dec 10, 2018 12:38 pm
x 41

Re: Pixelization on some HD channels

Post by NedS »

Could be a bad ethernet cable on the Shield. I would test it on wifi just to see if it improves or not.

john262
Posts: 13
Joined: Sun Apr 07, 2019 10:56 am

Re: Pixelization on some HD channels

Post by john262 »

I don't think so. When i do a speed test on the Shield I get the same speed I get on my hard wired computer. Thanks for your reply.

jasonl
Expert
Posts: 15341
Joined: Sun Oct 28, 2007 9:23 pm
x 7

Re: Pixelization on some HD channels

Post by jasonl »

Probably the NVIDIA decoder bug. NVIDIA hardware is defective when it comes to decoding certain video streams, and you'll get video corruption at certain points, usually on very high motion scenes like fast camera pans and graphic wipes. There is no fix or good workaround since the problem is apparently in the hardware. It also affects most NVIDIA GPUs on PCs.

john262
Posts: 13
Joined: Sun Apr 07, 2019 10:56 am

Re: Pixelization on some HD channels

Post by john262 »

Well that's nice. Considering how much they charge for that box you would think they would fix it.

NedS
Silicondust
Posts: 1511
Joined: Mon Dec 10, 2018 12:38 pm
x 41

Re: Pixelization on some HD channels

Post by NedS »

Can we have you create a sample file: https://info.hdhomerun.com/info/trouble ... g_a_sample

Save it as something like "sample.mpeg" and then upload it to a file sharing site, then reply with the link. Then we can try it ourselves and confirm if that's the issue or not.

john262
Posts: 13
Joined: Sun Apr 07, 2019 10:56 am

Re: Pixelization on some HD channels

Post by john262 »

Thanks. I will do that when I get time.

Daniel15
Posts: 5
Joined: Sat Aug 22, 2020 12:38 am

Re: Pixelization on some HD channels

Post by Daniel15 »

Yeah I'm pretty sure this is the infamous Nvidia MPEG2 decoder bug. There's a very long forum thread about it here: https://www.nvidia.com/en-us/geforce/fo ... -channels/

You can hackily work around the issue by using software decoding rather than hardware decoding, if the app you're using on your Shield supports that.

The way I work around it is by running a Plex server on my Shield, using its live TV + DVR functionality, and running the Plex client on my TV (LG C9 OLED) rather than my Shield. As long as Plex is configured to direct play, that'll use the TV's MPEG2 decoder, which doesn't have the same bug.

Bubbster
Posts: 39
Joined: Mon Nov 08, 2010 9:34 am

Re: Pixelization on some HD channels

Post by Bubbster »

Daniel15 wrote: Mon Aug 24, 2020 11:59 pm Yeah I'm pretty sure this is the infamous Nvidia MPEG2 decoder bug. There's a very long forum thread about it here: https://www.nvidia.com/en-us/geforce/fo ... -channels/

You can hackily work around the issue by using software decoding rather than hardware decoding, if the app you're using on your Shield supports that.

The way I work around it is by running a Plex server on my Shield, using its live TV + DVR functionality, and running the Plex client on my TV (LG C9 OLED) rather than my Shield. As long as Plex is configured to direct play, that'll use the TV's MPEG2 decoder, which doesn't have the same bug.
I've been hoping for a fix for this for several years now. I can work around it easily enough on a PC but I just don't like using external players in software mode on my Shield because I lose the pause/rewind/FF utilities I need for sports.

john262
Posts: 13
Joined: Sun Apr 07, 2019 10:56 am

Re: Pixelization on some HD channels

Post by john262 »

Thanks. That solved it for me. I am using the Kodi HDHomerun PVR client. And in my Kodi settings I turned off hardware decoding. I guess it's enabled by default and I had never changed it before. Actually it's funny. Every station that pixelated before I fixed it was broadcasting in 720p. All of the stations that broadcast in either 480i or 1080p were okay.

Daniel15
Posts: 5
Joined: Sat Aug 22, 2020 12:38 am

Re: Pixelization on some HD channels

Post by Daniel15 »

I'm hoping for a fix too. I wrote to HDHomeRun support to see if they had heard anything from Nvidia, and I never got a response.
john262 wrote: Sat Oct 10, 2020 5:36 pm I guess it's enabled by default and I had never changed it before.
It usually makes sense to have it enabled, as the decoding is done by hardware that's specially designed for it, rather than doing it in software. More efficient and uses less power. I don't think it's common to have hardware decoding bugs like this one :(

Post Reply