Channels pixelated on Pixel XL Oreo

Reception, channel detection, network issues, CableCARD setup, etc.
Post Reply
tlkg
Posts: 12
Joined: Thu Oct 20, 2016 8:46 am

Channels pixelated on Pixel XL Oreo

Post by tlkg » Wed May 22, 2019 8:48 am

I just acquired a Pixel XL phone running Oreo. When I run the HDHomerun app, all but 3 channels are all pixelated, but the audio seems to be fine. I have an Extend and is running the 20190417fw. All of the channels that are pixelated have signal strength, quality, etc that are showing 100%, so doesn't seem to be a signal strength issue.

When running the HDHomerun app on my other android devices, Plex, windows, etc. All works fine. (i.e. the channels that are pixelated on the Pixel display work fine on the other devices.)

Thanks for any help.

jasonl
Silicondust
Posts: 13690
Joined: Sun Oct 28, 2007 9:23 pm

Re: Channels pixelated on Pixel XL Oreo

Post by jasonl » Wed May 22, 2019 1:25 pm

Do you see a difference in that depending on what transcode mode you're using, particularly between none vs. anything else?

tlkg
Posts: 12
Joined: Thu Oct 20, 2016 8:46 am

Re: Channels pixelated on Pixel XL Oreo

Post by tlkg » Wed May 22, 2019 1:33 pm

No, I'm currently using Heavy, but tried the others without any change.
This problem only occurs on the Pixel, all my other Android devices work fine. They are on Nougat, if that might make a difference.

Thanks

jasonl
Silicondust
Posts: 13690
Joined: Sun Oct 28, 2007 9:23 pm

Re: Channels pixelated on Pixel XL Oreo

Post by jasonl » Wed May 22, 2019 1:57 pm

Please enable the sending of diagnostic data on the HDHomeRun, run a channel scan, and enable the sending of data in the app (see viewtopic.php?f=15&t=69066) then watch live TV for 10 minutes. Reply back with the device ID for your HDHomeRun and we will check the logs.

tlkg
Posts: 12
Joined: Thu Oct 20, 2016 8:46 am

Re: Channels pixelated on Pixel XL Oreo

Post by tlkg » Wed May 22, 2019 2:19 pm

Enabled.

Model: HDTC-2US
Device ID: 1054197A
Firmware: 20190417

jasonl
Silicondust
Posts: 13690
Joined: Sun Oct 28, 2007 9:23 pm

Re: Channels pixelated on Pixel XL Oreo

Post by jasonl » Wed May 22, 2019 2:31 pm

Nothing looks out of the ordinary in the logs. Can you repeat with the transcode set to none?

tlkg
Posts: 12
Joined: Thu Oct 20, 2016 8:46 am

Re: Channels pixelated on Pixel XL Oreo

Post by tlkg » Wed May 22, 2019 2:57 pm

Set transcode to None and stream seems to work on the pixel. I had (thought anyway) that I had tried the other transcode settings with no luck. Must of not actually set it to none)

So if the transcode is set to none is the Extend still doing the transcoding ? I thought it needed to set to heavy to convert from mpeg2?

Thanks

jasonl
Silicondust
Posts: 13690
Joined: Sun Oct 28, 2007 9:23 pm

Re: Channels pixelated on Pixel XL Oreo

Post by jasonl » Wed May 22, 2019 3:27 pm

If it's set to none, that means there's no transcode and it's passing the original MPEG2. If that works but transcoded video doesn't, that points to a broken H.264 decoder in the phone, which was a problem for a while on several Pixel devices. Do you have all the system updates installed? That's the kind of thing that usually gets fixed through a driver update included in a system update.

tlkg
Posts: 12
Joined: Thu Oct 20, 2016 8:46 am

Re: Channels pixelated on Pixel XL Oreo

Post by tlkg » Wed May 22, 2019 3:54 pm

Thanks. I'll check.
I know it did some updates when I first logged in.

The weird thing is that 3 of the channels worked fine on the Pixel when in still in transcode mode. I guess those channels were broadcasting in a different format??

Thanks for all the assistance.

jasonl
Silicondust
Posts: 13690
Joined: Sun Oct 28, 2007 9:23 pm

Re: Channels pixelated on Pixel XL Oreo

Post by jasonl » Wed May 22, 2019 4:38 pm

It may depend on the resolution (480i vs. 720p vs. 1080i).

I'm pretty sure you're not up to date, since the Pixel XL got upgraded to Pie last year.

tlkg
Posts: 12
Joined: Thu Oct 20, 2016 8:46 am

Re: Channels pixelated on Pixel XL Oreo

Post by tlkg » Wed May 22, 2019 5:21 pm

Thanks for the info!

Yeah, my Pixel is still at 8.0.0. Noticed there was a 8.1.0 update so might give that a try before Pie. Need read up on Pie to see if there are any issues that might impact other apps I am using before upgrading.

Again, many thanks for your support and assistance.

-Tom

Post Reply