dropouts and pixelation with new quattro

Reception, channel detection, network issues, CableCARD setup, etc.
inline_phil
Posts: 14
Joined: Thu Oct 18, 2018 2:00 pm

dropouts and pixelation with new quattro

Postby inline_phil » Thu Oct 18, 2018 2:13 pm

Have a new quattro, Model: HDHR5-4US, Device ID: 1074D2A3, Firmware: 20180817.

Have followed others with this same issue so I have already power cycled, assured current software, and re-scanned channels from the "Digital Antenna" tab in the setup app. I have also re-scanned channels [Detect Channels] from the admin login on the HDHomerun TV [from its IP address].

Tuner status shows: Virtual Channel 8.1 WFLA HD
Frequency 177.000 MHz
Program Number 3
Modulation Lock 8vsb
Signal Strength 95%
Signal Quality 100%
Symbol Quality 100%
Streaming Rate 10.044 Mbps
Resource Lock 192.168.1.103

Problem occurs most frequently when a scene quickly changes and there is motion in the new scene. Pixelation appears where the motion starts and follows the motion.

HELP!!!

jasonl
Silicondust
Posts: 12964
Joined: Sun Oct 28, 2007 9:23 pm

Re: dropouts and pixelation with new quattro

Postby jasonl » Thu Oct 18, 2018 5:10 pm

Is it specific to that one channel?

Are you using something with NVIDIA graphics?

inline_phil
Posts: 14
Joined: Thu Oct 18, 2018 2:00 pm

Re: dropouts and pixelation with new quattro

Postby inline_phil » Thu Oct 18, 2018 6:19 pm

Channel 8 shown is the worst but it also appears on channel 3.

Signal level was low [about 74%] so I bought an antenna preamp and mounted it just below the antenna. Made no difference in dropouts but it did improve the signal strength to 95-97%.

Dropouts appear on my PC and on the TV. Yes, it has an NVIDIA GeForce GTX 1060 graphics card on the PC.

Also using an NVIDIA Shield to the Samsung TV.

jasonl
Silicondust
Posts: 12964
Joined: Sun Oct 28, 2007 9:23 pm

Re: dropouts and pixelation with new quattro

Postby jasonl » Thu Oct 18, 2018 6:30 pm

Do you have any devices that don't have NVIDIA that you can compare to? There's an issue with NVIDIA decoding on certain streams that we have encountered before and reported to NVIDIA.

inline_phil
Posts: 14
Joined: Thu Oct 18, 2018 2:00 pm

Re: dropouts and pixelation with new quattro

Postby inline_phil » Fri Oct 19, 2018 10:06 am

No I do not. Same dropouts/pixelation on my TV and my PC on these channels. Streaming from my NAS. Recordings/live show the same results.

I thought the HD HomeRun TV had an HDMI output but I was wrong. Cannot test it by switching HDMI cables.

Thoughts?

inline_phil
Posts: 14
Joined: Thu Oct 18, 2018 2:00 pm

Re: dropouts and pixelation with new quattro

Postby inline_phil » Sat Oct 20, 2018 6:42 pm

Watching the NASCAR Xfinity race recorded earlier today. I believe your suspicions about the NVIDIA Shield TV is spot on. Here is what I've found:

Watching the TV [WD NAS > HD HomeRun Quattro > NVIDIA Shield TV > OPPO UDP-205 > Samsung TV] all hard-wired ethernet is pixelating terribly, and not just when scenes change but definitely a motion-related issue. Have a video I can send you if you need it.

Watching from my cell phone [WD NAS > HD HomeRun Quattro > MOTO G5+] via wireless connection is fine.

So, looks like NVIDIA is having an issue with the Shield driver again.

What's the next step?

jasonl
Silicondust
Posts: 12964
Joined: Sun Oct 28, 2007 9:23 pm

Re: dropouts and pixelation with new quattro

Postby jasonl » Mon Oct 22, 2018 2:55 pm

Wait and hope NVIDIA fixes it. We've got a sample of an affected station and have confirmed that it plays properly when not using the NVIDIA decoder, but has issues when using the NVIDIA decoder (including using the builtin player on the Shield). We've sent it to NVIDIA and they responded that they believe it's part of an issue they're already aware of, but were sending it to their engineering team for further review. Haven't heard anything more since then.

inline_phil
Posts: 14
Joined: Thu Oct 18, 2018 2:00 pm

Re: dropouts and pixelation with new quattro

Postby inline_phil » Mon Oct 22, 2018 5:07 pm

Thanks for your efforts. Glad you could confirm the issue.

inline_phil
Posts: 14
Joined: Thu Oct 18, 2018 2:00 pm

Re: dropouts and pixelation with new quattro

Postby inline_phil » Sat Nov 17, 2018 5:08 am

Any news on an update/fix?

beefjerky
Posts: 5
Joined: Sat Nov 18, 2017 7:48 pm

Re: dropouts and pixelation with new quattro

Postby beefjerky » Sat Dec 15, 2018 11:58 pm

I seem to be having this same issue with Channel 2 (KPRC) in Houston. I think it started a few weeks ago. Signal strength, SNR quality and Symbol quality are all consistently at 100% on this channel.

I have the same tuner, and experience the issue with my Shield TV. It happened both before as well as after the 7.2 Shield software update. It happens in the native HDHomeRun app, in Kodi and also in the LiveTV app.

That said, I do not experience the issue on my PC, which does use a mobile nVidia GTX1060. I'm currently running drivers that are few months old, so maybe that's why.

inline_phil
Posts: 14
Joined: Thu Oct 18, 2018 2:00 pm

Re: dropouts and pixelation with new quattro

Postby inline_phil » Fri Dec 28, 2018 5:20 pm

See item #21 at https://forums.geforce.com/default/topi ... nnel-s-/2/
======
We're have been in communication with silicondust. We unfortunately do not have an imminent solution as it's a corner case in the video decoder hw. (I don't personally understand how this wasn't seen prior, something changed in one or more encoders used by particular channels is my only guess without being a subject matter expert at all...).

We considered one possible quick workaround, but so far the SD guys don't like that it would make shield look lower quality versus other client devices. I can't easily argue that point!

To the best of my understanding... If you can watch/play using an app like Kodi, and disable hardware decoder, that would fix the bigger corruption -- but of course, it'll then be up to the kodi mpeg2 decoder performance, kodi deinterlace (if any), and kodi scaling (which can actually be better..). That's my best suggestion to try for HDHR users hitting this problem with high frequency with specific channels and relying on HDHR+SHIELD for their TV/cord cutting.

We're still discussing alternative solutions here, but clearly no ETA.
=====
This is obviously NOT a quick fix issue. Not sure what a "corner case" is in the decoder but it appears to be an end-to-end encoder/decoder issue [starts at the broadcast encoder and ends at the NVIDIA decoder].

So from my humble interpretation of this issue, the stations with pixelation have a different encoding scheme than most and the NVIDIA Shield hardware accelerator has an issue decoding it properly . Disabling the NVIDIA accelerator via another app that can disable acceleration seems to prove this assertion but unfortunately the NVIDIA units cannot natively disable acceleration.

SPECULATION: This sounds like a much bigger issue than a simple firmware upgrade [hardware-limited issue preventing complete elimination of this problem]. Also sounds like another huge "whoops! missed that one" [the lip-sync issue caused by variable video processing schemes being the other one].

HEY SD! Is my interpretation correct?


Return to “HDHomeRun Hardware Setup & Troubleshooting”

Who is online

Users browsing this forum: No registered users and 1 guest