My PVR Server No longer Shows on myhdhomerun.com

Reception, channel detection, network issues, CableCARD setup, etc.
jsthomps
Posts: 7
Joined: Fri Sep 18, 2015 12:23 pm

My PVR Server No longer Shows on myhdhomerun.com

Postby jsthomps » Mon Oct 15, 2018 10:07 am

Hi,
I recently got everything installed and working using Ubuntu as my server OS. My HdHomerun page displayed my device as well as my PVR Server. All was well.
Yesterday my server rebooted and my router assigned another IP to the server (I have now locked the IP to 192.168.1.110). All was well until I went to My HdHomerun and the PVR no longer shows up.
I searched this forum and found this discover command (wget -q -O - my.hdhomerun.com/discover) which I executed and got this:

{
"StorageID": "fcac0db1-705d-4b0a-9d6f-1b10f7486869",
"LocalIP": "10.22.11.6:65001",
"BaseURL": "http://10.22.11.6:65001",
"DiscoverURL": "http://10.22.11.6:65001/discover.json",
"StorageURL": "http://10.22.11.6:65001/recorded_files.json"
}

The storage id is correct but the IP is wrong. If I substitute the 10.22.11.6 for 192.168.1.110 (eg. http://192.168.1.110:65001/discover.json) I get what appears to be a correct response:

{"FriendlyName":"HDHomeRun RECORD","Version":"20180817","StorageID":"fcac0db1-705d-4b0a-9d6f-1b10f7486869","BaseURL":"http://192.168.1.110:65001","StorageURL":"http://192.168.1.110:65001/recorded_files.json","FreeSpace":6014371393536}

How do I correct this?
Thanks,
Scott

jasonl
Silicondust
Posts: 12881
Joined: Sun Oct 28, 2007 9:23 pm

Re: My PVR Server No longer Shows on myhdhomerun.com

Postby jasonl » Mon Oct 15, 2018 3:42 pm

Once the DVR has synced from the new IP it should update the discover page on the site. Is it still showing the wrong IP right now?

jsthomps
Posts: 7
Joined: Fri Sep 18, 2015 12:23 pm

Re: My PVR Server No longer Shows on myhdhomerun.com

Postby jsthomps » Tue Oct 16, 2018 9:39 am

Yes it is:

wget -q -O - my.hdhomerun.com/discover
[
{
"StorageID": "fcac0db1-705d-4b0a-9d6f-1b10f7486869",
"LocalIP": "10.22.11.6:65001",
"BaseURL": "http://10.22.11.6:65001",
"DiscoverURL": "http://10.22.11.6:65001/discover.json",
"StorageURL": "http://10.22.11.6:65001/recorded_files.json"
}

rebooted the OS and restarted the service many times.
Scott

signcarver
Expert
Posts: 7562
Joined: Wed Jan 24, 2007 1:04 am

Re: My PVR Server No longer Shows on myhdhomerun.com

Postby signcarver » Tue Oct 16, 2018 1:10 pm

Most likely a firewall/internet connection issue of allowing the engine to connect to SD... or perhaps even no longer having the StorageID (but I think you made it clear there was one). I have seen it take a couple of days for a "removed/turned off" engine to no longer list as SD but once it checks in with the same StorageID, the listing there gets updated.

Also note that to show up at SD, it must connect to internet from same public ip, so make sure there isn't a vpn or proxy running.

jsthomps
Posts: 7
Joined: Fri Sep 18, 2015 12:23 pm

Re: My PVR Server No longer Shows on myhdhomerun.com

Postby jsthomps » Wed Oct 17, 2018 3:44 pm

Hi Guys,
Problem solved I'm embarrassed to say. I had recently install a VPN on the server and forgot to turn it off! :oops:
Thanks for all your help!
Scott


Return to “HDHomeRun Hardware Setup & Troubleshooting”

Who is online

Users browsing this forum: Google [Bot] and 4 guests