deinterlacing

Reception, channel detection, network issues, CableCARD setup, etc.
chop
Posts: 2
Joined: Thu Oct 11, 2018 7:00 am

deinterlacing

Postby chop » Thu Oct 11, 2018 7:31 am

wrecks my stream "vlc --deinterlace=-1 udp://@127.0.0.1:5000". how can i modify this command to something like "vlc udp://@127.0.0.1:5000" so hdhomerun gui calls vlc with no deinterlacing?

nickk
Silicondust
Posts: 15006
Joined: Tue Jan 13, 2004 9:39 am

Re: deinterlacing

Postby nickk » Thu Oct 11, 2018 6:06 pm

Hi,

The "--deinterlace=-1" option set deinterlacing enable to "auto", ie deinterlace if the content is interlaced, do nothing if the content is progressive. This is actually the default in VLC now.

It sounds like you are experiencing poor results... the first thing that comes to mind is VLC may be defaulting to a sub-optimal deinterlacing method.

If you are playing 480i60 content use Yadif2x - that will give you 480p60.

If you are playing 1080i60 content your choices depend on the performance of your PC...
Very fast PC - use yadif2x to get 1080p60.
Most PCs - use yadif to get 1080p30.
Slow PC - use discard to get 540p30.

Nick

chop
Posts: 2
Joined: Thu Oct 11, 2018 7:00 am

Re: deinterlacing

Postby chop » Sun Oct 14, 2018 10:35 am

i tried every combination of deinterlacing but the video will not recover from intermittent signal loss. after i turn off deinterlacing while the stream is being interrupted, it recovers quickly. if i leave deinterlacing on, or auto, after a good signal is restored, the video shows a freeze frame of content every few seconds, indefinitely. so i guess i'll just keep turning it off..


Return to “HDHomeRun Hardware Setup & Troubleshooting”

Who is online

Users browsing this forum: drknow888 and 7 guests