Golf Channel Audio Problem

Reception, channel detection, network issues, CableCARD setup, etc.
srieker
Posts: 6
Joined: Tue Jun 02, 2015 6:40 pm

Golf Channel Audio Problem

Postby srieker » Mon Feb 12, 2018 10:46 pm

Only about a month into Spectrum TV with 2 HDHR3 Primes. Have an odd audio problem with the Golf Channel in that the voice tracks are missing from the live tournament telecasts, interview mics, some studio programs, and some commercials. Wild sound from fairway and tee microphones is always present. The problem is present when watching live on the Kodi 17.6 HomeRun plug-in running in Linux Mint 18.3 or Kodi 17.6 on Windows 10. However, all audio is present when watching live on the HDHomerun software on Windows 10 on the same Intel NUC5i5. Also, when viewing recordings of the HD channel, the problem tracks the same-all audio present on HDHomeRun playbacks, but missing audio on Kodi playbacks.

Another detail is that full audio is present on the standard definition Golf Channel (58), it's only on the HD channel (1154) that the problem is heard.

When viewing those two channels with the Spectrum DVR/STB, full audio is present on both channels.

One gets the impression that the Kodi plug-in and HDHomerun software share a lot of code from the appearance and operational features.

jasonl
Silicondust
Posts: 11253
Joined: Sun Oct 28, 2007 9:23 pm

Re: Golf Channel Audio Problem

Postby jasonl » Tue Feb 13, 2018 3:03 pm

What you're describing sounds like the center channel is missing. What audio output are you using on the PC and what is the speaker configuration of whatever it's hooked up to?

srieker
Posts: 6
Joined: Tue Jun 02, 2015 6:40 pm

Re: Golf Channel Audio Problem

Postby srieker » Tue Feb 13, 2018 7:53 pm

Good questions and pertinent. Am using PC HDMI for audio and video to the Marantz receiver. Configured the PC HDMI output to the Digital Surround 5.1 mode, with sub-woofer and two back speakers. Have never used a center channel speaker, as the dialogue is always sufficient from the front speakers. During speaker setup and calibration, the receiver senses the lack of a center-channel speaker, and routes 5.1 center-channel audio to the main fronts. The Marantz receiver offers several surround-sound algorithms-Stereo, Virtual, and Multi-Channel (LF and LR repeated in back speakers). Have tried switching between those surround modes but the problem persists.

Your question prompted me to switch the PC output from 5.1 Digital to 2.0 Stereo. The problem persisted.

Again, it's only on Golf Channel HD, not the golf telecasts from NBC or CBS that the problem is heard, and then only with Kodi, not HDHomeRun software.

Will contact Spectrum regarding this issue. I have heard that individual Cable Cards can display symptoms.

Thanks.

nickk
Silicondust
Posts: 14231
Joined: Tue Jan 13, 2004 9:39 am

Re: Golf Channel Audio Problem

Postby nickk » Wed Feb 14, 2018 3:37 pm

Hi,

By default the app will output AC3 audio to your receiver regardless of the PC being set to 2 channel or 5.1 channel (ie the receiver will still get 5.1 audio when the PC is set to 2 channel).

As a test try turning off "Use AC3 passthrough when possible" in the app config menu (click near the top-left corner of the video area to open the menu).

Nick

rpcameron
Posts: 543
Joined: Fri Mar 25, 2016 9:55 am

Re: Golf Channel Audio Problem

Postby rpcameron » Wed Feb 14, 2018 4:36 pm

What are Kodi's audio settings? I find that making sure your audio channel settings in Kodi match your physical setup. My system is a stereo soundbar with a subwoofer, meaning 2.1 audio. When I have passthrough audio enabled, it all plays fine. However, if my audio layout in Kodi is set as 5.1, even though the soundbar can handle 5.1 passthrough, I get the same problems you are experiencing. Setting my layout to 2.1 (or even 2.0) fixes it.

srieker
Posts: 6
Joined: Tue Jun 02, 2015 6:40 pm

Re: Golf Channel Audio Problem

Postby srieker » Sat Feb 17, 2018 2:16 pm

Nick,

Could not find the "Use AC3 pass-through when possible" switch in the drop down menu, only choices like minimize, maximize, general window settings. In the Settings/System/Audio/Audio Pass through/ Audio DSP, config window, found Audio DSP Processing disabled. This must be the default, as I don't recall having changed it since the last Kodi install.

srieker
Posts: 6
Joined: Tue Jun 02, 2015 6:40 pm

Re: Golf Channel Audio Problem

Postby srieker » Sat Feb 17, 2018 3:29 pm

On the two-channel TVs running Kodi, am set to 2.0. Have tried both the HDMI audio output and Pulse Audio settings in the Kodi config menu. Pulse is the default for Linux Mint. Have also tried turning audio DSP on and off. So far no remedy. The Golf Channel voice tracks are missing on the 2-channel NUC and TV set ups as well as the two home theatre rigs.

rpcameron
Posts: 543
Joined: Fri Mar 25, 2016 9:55 am

Re: Golf Channel Audio Problem

Postby rpcameron » Sat Feb 17, 2018 4:48 pm

On the two-channel TVs running Kodi, am set to 2.0. Have tried both the HDMI audio output and Pulse Audio settings in the Kodi config menu. Pulse is the default for Linux Mint. Have also tried turning audio DSP on and off. So far no remedy. The Golf Channel voice tracks are missing on the 2-channel NUC and TV set ups as well as the two home theatre rigs.
Pulse is often the source of issues. Try starting Kodi without Pulse, and using ALSA instead.

nickk
Silicondust
Posts: 14231
Joined: Tue Jan 13, 2004 9:39 am

Re: Golf Channel Audio Problem

Postby nickk » Sat Feb 17, 2018 9:32 pm

Could not find the "Use AC3 pass-through when possible" switch in the drop down menu, only choices like minimize, maximize, general window settings. In the Settings/System/Audio/Audio Pass through/ Audio DSP, config window, found Audio DSP Processing disabled. This must be the default, as I don't recall having changed it since the last Kodi install.
Ah, I was referring to the HDHomeRun app. Not sure how Kodi handles audio passthrough.

If you are testing with the HDHomeRun app, click near the top-left corner of the video area (not the titlebar) to open the config menu.

Nick

jasonl
Silicondust
Posts: 11253
Joined: Sun Oct 28, 2007 9:23 pm

Re: Golf Channel Audio Problem

Postby jasonl » Sun Feb 18, 2018 1:31 pm

Kodi's setting is under Settings > System > Audio and is called Allow passthrough. You may need to increase the level to see it.


Return to “HDHomeRun Hardware Setup & Troubleshooting”

Who is online

Users browsing this forum: No registered users and 4 guests